Ragazzi ho un problema..all'avvio mi esce questo errore: unsupported splx structure ubuntu

ho letto un po in giro ed è dovuto dalla mia scheda wirelles intel 7260 (anche se si collega normalmente ad nternet)..su internet ho trovato questo sito https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-7260-ucode-22.24.8.0.tgz

dove c'è il firmware che non so come installare...secondo voi riesco a risolvere il problema installando il firmware? grazie

chiesto 20 Mag '15, 14:10

zabby995's gravatar image

zabby995
17369

modificato 20 Mag '15, 14:13

@zabby995, dici che si collega normalmente a internet, quindi hai problemi oppure no?

(20 Mag '15, 15:37) enzotib ♦♦ enzotib's gravatar image

si collega a internet solo che all'avvio di ubuntu mi esce quel messaggio

(20 Mag '15, 21:47) zabby995 zabby995's gravatar image

@zabby995: se fossi in te, finché funziona tutto, non me ne preoccuperei.

(20 Mag '15, 21:50) enzotib ♦♦ enzotib's gravatar image

lo so solo che vorrei capire perché mi esce quell'errore.. se mi esce un errore penso vuol dire che c'è qualcosa che non va..

(20 Mag '15, 21:56) zabby995 zabby995's gravatar image

Metto in gioco i miei due soldi.

Sì, c'è qualcosa che non va, ma non è nulla di grave. Quello che "non va" è il fatto che la Intel ha prodotto una scheda che non rispetta i suoi stessi standard e se n'è dimenticata.

Nel dettaglio, quell'splx è un interrupt che riporta il processore della scheda di rete allo stato originario quando termina una connessione TCP (fai una ricerca Google per chiarirti un po' le idee).

Sempre per tua fortuna la comunità è vasta e chi scrive il kernel e i firmware usati in Ubuntu è stato in grado di aggirare questo problema di auto-incompatibilità di Intel. [...]

(20 Mag '15, 22:48) dadexix86 ♦♦ dadexix86's gravatar image

[...] Non sei ovviamente l'unico che usa questa scheda su Linux, né l'unico che ha notato il problema.

Qui c'è un bug legato a questa scheda e al suo firmware, ma sulla 14.04.

Non mi stupirebbe che sulla 15.04 il problema sia stato risolto. Nel caso tu avessi lo stesso problema faccelo sapere e scrivi lì nel bug, così che ritorni "alta" l'attenzione.

(20 Mag '15, 22:50) dadexix86 ♦♦ dadexix86's gravatar image

ma come faccio ad installare il firmware?

(21 Mag '15, 17:36) zabby995 zabby995's gravatar image

Il firmware è già installato, altrimenti non funzionerebbe... Oppure non ho capito la tua domanda?

(21 Mag '15, 19:57) dadexix86 ♦♦ dadexix86's gravatar image

aggiornando il firmware con il file che c'è in questo sito https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-7260-ucode-22.24.8.0.tgz non si risolve il problema?

(21 Mag '15, 20:35) zabby995 zabby995's gravatar image

Cito da quella pagina

Note that many distributions ship the firmware, you could install the “linux-firmware” package or similar. If that doesn't work, or you need newer firmware, read on.

Hai installato quello che viene distribuito con Ubuntu (che è l'ultimo testato con il kernel che hai installato) prima di voler provare ad installare a mano quello (e trovarti in una situazione in cui la distribuzione non è più testata)?

Ma comunque, se funziona, non vedo perché vorresti toccare qualcosa.

(21 Mag '15, 20:41) dadexix86 ♦♦ dadexix86's gravatar image

A me dava quel problema in fase di installazione ed ho risolto andando ad attivare l'opzione dei driver grafici generici.

Io proverei ad aggiornarli in modalità recovery.

Se proprio non si avvia prova a premere 'e' ad aggiungere 'nomodeset' alla fine della riga di linux(che dovrebbe finire con splash) prima di avviare ubuntu.

coll. permanente

ha risposto 16 Mar, 17:39

Barald's gravatar image

Barald
201

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,466

domanda posta: 20 Mag '15, 14:10

domanda visualizzata: 1,147 volte

ultimo aggiornamento: 16 Mar, 17:39

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.