Potete aiutarmi con questo errore? "errore nell'aprire la cache (E:Malformed line 1 in source list etc/apt/sources.list.d/mono-xamarin.list(type), E:the list of sources cuold not be read" grazie

chiesto 06 Feb, 12:03

mp85's gravatar image

mp85
2512

modificato 09 Feb, 09:51

ho digitato il comando sudo -H gedit etc/apt/sources.list.d/mono-xamarin.list

la lista è vuota e una volta chiusa trovo questo messaggio nel terminale

* (gedit:8684): WARNING : Set document metadata failed: Impostazione dell'attributo metadata::gedit-position non supportata*

portate pazienza non sono esperto. Cosa devo fare?

(06 Feb, 16:29) mp85 mp85's gravatar image

il messaggio '(gedit:8684): WARNING ...' è normale, ma non dannoso, quando si fa 'sudo gedit' c'è un bug aperto in proposito: https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/1575484

(07 Feb, 08:40) corradoventu corradoventu's gravatar image

hai provato ad andare su /etc/apt/ semplicemente da nautilus?

(07 Feb, 08:56) corradoventu corradoventu's gravatar image

@mp85 il messaggio "Malformed line 1 in source list etc/apt/sources.list.d/mono-xamarin.list" indica che il file /etc/apt/sources.list.d/mono-xamarin.list contiene, appunto, degli errori. Come hai aggiunto questo repository esterno? Hai seguito qualche guida?

Nel frattempo, scrivi nel terminale il comando:

gedit etc/apt/sources.list.d/mono-xamarin.list

copia tutto e incollalo in un commento qui sotto

(07 Feb, 09:40) alevipri alevipri's gravatar image

guardando da nautilus il file contiene solo questo: 12345678 mentre scrivendo nel terminale gedit etc/apt/sources.list.d/mono-xamarin.list il file che si apre è sempre vuoto. La guida che ho usato è questa: http://www.mono-project.com/docs/getting-started/install/linux/ grazie

(07 Feb, 10:36) mp85 mp85's gravatar image

Dato che quel file .list è vuoto, suppongo che tu non abbia installato nulla da quel repository, giusto?

Se così è, proviamo a disabilitarlo per vedere se non compaiono più errori. Apri Software e aggiornamenti → Altro software, togli la spunta dal (o dai) repository di Mono, quindi premi Chiudi.
Ti verrà chiesto di ricaricare le sorgenti software, fallo. Una volta terminato, apri il terminale e digita:

sudo apt update

quindi copia tutto l'output e caricalo su pastebin. Lasciaci il link a pastebin qui sotto ;)

(07 Feb, 11:19) alevipri alevipri's gravatar image

EDIT: scusa, il comando corretto era:

gedit /etc/apt/sources.list.d/mono-xamarin.list

mi ero dimenticato una "/".
In ogni caso, 12345678 non può essere considerato come file .list serio, chiaramente qualcosa non è andato per il verso giusto. Vediamo intanto come procede la disabilitazione del repository di mono.

(07 Feb, 11:39) alevipri alevipri's gravatar image

Ho tolto la spunta dai repository di mono ed ho premuto chiudi. Quando poi vado a ricaricare le sorgenti mi da questo errore.

http://paste.ubuntu.com/23949731/

Questo è poi l'output del terminale

http://paste.ubuntu.com/23949657/

(07 Feb, 21:09) mp85 mp85's gravatar image

Hai tolto la spunta a tutti i repo di mono? Vedo che cerca ancora di leggerli. Se riavvii il pc, compare ancora lo stesso problema?

Se il problema persiste, prova a rimuoverli sempre da Aggiornamenti e software, quindi riprova con:

sudo apt update
(07 Feb, 23:30) alevipri alevipri's gravatar image

La spunta è tolta a tutti i repo di mono. Ho riavviato il computer ma il problema rimane. Ho rimosso i repo ma il problema rimane anche riavviando

http://paste.ubuntu.com/23950654/

(07 Feb, 23:53) mp85 mp85's gravatar image

La chiave del repo di mono non c'è più. Questa è l'uscita dal terminale.

http://paste.ubuntu.com/23956199/

Mi sembra ok. Occorre fare altro ? Grazie mille.

(08 Feb, 21:07) mp85 mp85's gravatar image

@mp85: il titolo della domanda non corrisponde al contenuto, puoi correggere oppure integrare, per cortesia?

(09 Feb, 08:52) enzotib ♦♦ enzotib's gravatar image

@mp85 ok, mi pare tutto sistemato.
Converto il mio commento in risposta, ricordati di segnalarla come corretta.

Ciao

(09 Feb, 15:41) alevipri alevipri's gravatar image

Prova con

sudo rm /etc/apt/sources.list.d/mono-xamarin.list

quindi apri Software e aggiornamenti → Autenticazione e controlla se è presente la chiave del repository di Mono. Se presente, rimuovila.

Poi riprova con

sudo apt update
coll. permanente

ha risposto 08 Feb, 00:39

alevipri's gravatar image

alevipri
5.4k1479

modificato 09 Feb, 15:43

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×100

domanda posta: 06 Feb, 12:03

domanda visualizzata: 314 volte

ultimo aggiornamento: 09 Feb, 15:43

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.