Salve, sono nuovo del forum. Ho usato Ubuntu per un anno su un vecchio hp con il bios senza problemi. Poi a gennaio 2017 ho comprato un Acer Aspire E 15 ( modello: e5-575g-55gr ) con window 10 già insallato. Volendo quindi istallare Ubuntu ho iniziato ad informarmi sull'UEFI e su come fare. Dopo tanti tentativi ho abilitato il Legacy Mode e disabilitato il secure boot. Poi durante il riavvio sono acceduto al boot e ho selezionto la chiavetta ( si ho usato una Live USB creata con Rufus ). Così facendo sono finalmente riuscito ad accedere al desktop di Ubuntu e installarlo affianco di Window 10. Bene! Il problema è sorto quando ho riavviato volendo accedere a window 10 ma niente. Non mi da l'opzione del dual boot e se apro il pannello del UEFI non mi vede il MBR nella lista dei dispositivi da cui fare il boot. Da ubuntu però vedo la partizione di window. Se lancio il comando fdisk -l

Dispositivo      Start       Fine   Settori   Size Tipo
/dev/sda1         2048     206847    204800   100M EFI System
/dev/sda2       206848     239615     32768    16M Microsoft reserved
/dev/sda3       239616  983212031 982972416 468,7G Microsoft basic data
/dev/sda4   1951426560 1953523711   2097152     1G Windows recovery environment
/dev/sda5    983212032  983214079      2048     1M BIOS boot
/dev/sda6   1934919680 1951426559  16506880   7,9G Linux swap
/dev/sda7    983214080 1934919679 951705600 453,8G Linux filesystem

credo che bisogni fixare il boot loader ma non ci capisco molto e preferirei non fare danni. Se qualcuno mi può dare una mano gliene sarei grato :)

chiesto 20 Feb, 15:52

valgi95's gravatar image

valgi95
1012

modificato 23 Feb, 08:15

enzoge's gravatar image

enzoge
4.5k153787

Ciao @valgi95: mi risulta che su pc UEFI gli ultimi Windows possano funzionare solo in quest'ultima modalità, mentre Ubuntu può funzionare sia in Legecy che in UEFI. In questa risposta e in questa guida puoi trovare maggiori dettagli.

Tieni anche presente che Ubuntu è certificato per essere installato con il Secure Boot attivo, ma che purtroppo non tutti i produttori hanno aggiornato UEFI.

(21 Feb, 11:15) enzoge enzoge's gravatar image

Ho riprestinato legacy e infatti window è ripartito. Ma il boot loader di ubuntu non viene più visualizzato neanche nel bootmanager... però ho scaricato il programma easyUEFI e quando entro nella partizione EFI mi vede il boot di linux

(21 Feb, 12:05) valgi95 valgi95's gravatar image

Allora. Credo di aver trovato il problema! Quando apro easyUefi (programma per window ) mi mostra che il Windows boot manager è sempre al primo posto. Io lo sposto sotto a Linux e riavvio. Neanche a dirlo, mi apre windows e in effetti il boot di windows è tornato primo. Se antro con la chiavetta di ubuntu nella versione di prova con il comando

sudo efibootmgr -v

Mi mostra che il Windows boot manager è il primo dell'elenco. Ho provato dalla versione di prova a metterlo dopo il GRUBx64 ma al riavvio WBM è ancora il primo.

Cosa sto sbagliando? E' come se non mi facesse modificare la partizione EFI

(21 Feb, 15:00) valgi95 valgi95's gravatar image

Per comunicare devi usare i commenti, le risposte servono solo per le soluzioni!
Credo che se non trovi la risposta nelle pagine che ti ho linkato e nelle innumerevoli domande/risposte che puoi trovare qui su chiedi, il problema sia di difficile soluzione.

(21 Feb, 18:56) enzoge enzoge's gravatar image

Bene. Mi scuso per aver usato erratamente i commenti e le risposte. Ho finalmente trovato la soluzione che purtroppo non era in nessuna guida o nelle domane/risposte. La posto qui di seguito sperando possa essere utile a qualcun'altro.

In poche parole il firmware UEFI del mio PC se ne sbatteva completamente di quello che gli dicevo e continuava a eseguire Window boot manager malgrado io cercassi di impostarlo come seconda scelta dopo il Grubx64.

Soluzione:

  1. accedere al UEFI ( f2 all'accensione )
  2. abilitare il secure mode
  3. andare in Security
  4. Selezionare la voce select an UEFI file as trustered for executing se non è abilitata dovete impostare una password
  5. poi seguire la directory HDD0/EFI/ubuntu/
  6. selezionare grubx64
  7. premere invio e inserire un nome nel database e premere yes ( o ok non ricordo )
  8. tornare alla pagina iniziale del uefi ( se non ci torna in automatico premere esc )
  9. andare nel ordine di boot e tra le voci sarà comparsa una voce GRUB EFI e qualcos'altro
  10. mettere qualla voce prima con f5
  11. disabilitare il securemode
  12. Salvare e riavviare il pc ( f10 )

N.B: Questa procedura funziona solo se ubuntu è gia installato nel pc e ha il grub v2 correttamente installato nella partizione EFI.

coll. permanente

ha risposto 22 Feb, 16:20

valgi95's gravatar image

valgi95
1012

modificato 23 Feb, 08:11

enzoge's gravatar image

enzoge
4.5k153787

@valgi95: per evidenziare che una determinata risposta risolve il problema, chi ha formulato la domanda deve accettare la risposta. In questo caso, devi accettare la tua stessa risposta.

(23 Feb, 08:21) enzoge enzoge's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×246

domanda posta: 20 Feb, 15:52

domanda visualizzata: 347 volte

ultimo aggiornamento: 23 Feb, 08:21

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.