Salve a tutti,
è la prima volta che partecipo a questo sito e sono quasi disperato, per colpa di un segnale di blocco che mi è apparso in alto a destra vicino alla scelta della lingua, che praticamente mi dice:

Si è verificato un errore. Per ulteriori informazioni avviare il gestore pacchetti tramite il menu richiamabile con un clic del tasto destro del mouse, oppure dare da terminale il comando apt-get. Il messaggio di errore è :Errore sconosciuto:<class systemerror'="">(E:Type'Complain_dialog_title= Tor Browser Bundle' is not known on line 10 in source list /etc/apt/sources.list) Di solito questo significa che i pacchetti installati presentano delle dipendenze irrisolte.

Questo è tutto cio che so dirvi e in più per questo problema non posso aprire l'Ubuntu Softwar Center né installare nessun programma da terminale.

chiesto 18 Dic '13, 20:49

ilcolibri2's gravatar image

ilcolibri2
20112

modificato 18 Dic '13, 21:02

enzotib's gravatar image

enzotib ♦♦
14.0k112186

1

@ilcolibri2: secondo me hai fatto danni editando il file /etc/apt/sources.list. Aprilo, copiane il contenuto e mettilo su pastebin, poi metti qui il link.

(18 Dic '13, 21:04) enzotib ♦♦ enzotib's gravatar image
(19 Dic '13, 11:16) ilcolibri2 ilcolibri2's gravatar image
1

@ilcolibri: per prima cosa, non usare le risposte, usa i commenti. Poi, per vedere il contenuto del file usa il comando: gedit /etc/apt/sources.list

(19 Dic '13, 11:20) enzotib ♦♦ enzotib's gravatar image

scusa ma e la prima volta che uso il forum, e non sono tanto esperto su ubuntu, sono alle prime armi. Ho inserito il comando e mi da Questo:

emiliobuntu@emiliobuntu-laptop:~$ gedit /etc/apt/sources.list

** (gedit:3171): WARNING **: Could not load Gedit repository: Typelib file for namespace 'GtkSource', version '3.0' not found

Poi mi apre il documento che ho incollato in questo link.

(19 Dic '13, 11:54) ilcolibri2 ilcolibri2's gravatar image

Prova ad eseguire il comando:

sudo cp /etc/apt/sources.list{.save,}

e se questo non dà errore, esegui:

sudo apt-get update

Se anche questo non dà errore, dovrebbe a questo punto essere tutto a posto.

Edit

Se questo non funziona, lancia i seguenti comandi:

sudo mkdir /etc/apt/bak
sudo mv /etc/apt/sources.list!(.d) /etc/apt/bak

poi lancia software-properties-gtk, dove appariranno tutti i checkbox vuoti.
Clicca sul primo checkbox, ti chiederà la password e e poi ti ritroverai tutti i campi riempiti.
Clicca su Chiudi, ti chiederà di ricaricare le informazioni, digli di sì e infine tutto dovrebbe tornare a posto.

coll. permanente

ha risposto 19 Dic '13, 12:11

enzotib's gravatar image

enzotib ♦♦
14.0k112186

modificato 19 Dic '13, 16:19

fatto, ecco quello che succede:

emiliobuntu@emiliobuntu-laptop:~$ sudo cp /etc/apt/sources.list{.save,} [sudo] password for emiliobuntu: emiliobuntu@emiliobuntu-laptop:~$ emiliobuntu@emiliobuntu-laptop:~$ emiliobuntu@emiliobuntu-laptop:~$ sudo apt-get update E: Tipo "complain_dialog_title=Tor Browser Bundle" non riconosciuto alla riga 10 nel file /etc/apt/sources.list E: Impossibile leggere l'elenco dei sorgenti.

(19 Dic '13, 13:24) ilcolibri2 ilcolibri2's gravatar image

@ilcolibri2: ho modificato la risposta con ulteriori azioni da eseguire, fammi sapere.

(19 Dic '13, 16:20) enzotib ♦♦ enzotib's gravatar image

in software-properties-gtk la lista e vuota non ho nessun checkbox mentre dando il comando dal terminale mi da questo :

emiliobuntu@emiliobuntu-laptop:~$ sudo mkdir /etc/apt/bak [sudo] password for emiliobuntu: emiliobuntu@emiliobuntu-laptop:~$ sudo mv /etc/apt/sources.list!(.d) /etc/apt/bak emiliobuntu@emiliobuntu-laptop:~$ software-properties-gtk WARNING:root:could not open file '/etc/apt/sources.list' WARNING:root:could not open file '/etc/apt/sources.list' gpg: /tmp/tmp_rz_0u/trustdb.gpg: creato il trustdb

(19 Dic '13, 19:42) ilcolibri2 ilcolibri2's gravatar image

@ilcolibri2: lancia software-properties-gtk e poi fammi uno screenshot, lo carichi da qualche parte, per esempio su http://imagebin.org/ e poi mi dai il link

(19 Dic '13, 20:13) enzotib ♦♦ enzotib's gravatar image

scusa forse non capito bene, ma quando lancio il comando software-properties-gtk mi si apre la finestra di softwar e aggiornamenti, di quale pannello ti linco lo screenshot?

(19 Dic '13, 20:21) ilcolibri2 ilcolibri2's gravatar image

@ilcolibri2: della finestra che appare appena lo lanci

(19 Dic '13, 20:32) enzotib ♦♦ enzotib's gravatar image

Scusa la mia ignoranza ma non so proprio come usare quel sito ne conosco alternative per caricare l immaggine..

(19 Dic '13, 21:02) ilcolibri2 ilcolibri2's gravatar image

@ilcolibri2: puoi modificare la tua domanda in alto ed aggiungere l'immagine, altrimenti non so come aiutarti

(19 Dic '13, 21:11) enzotib ♦♦ enzotib's gravatar image

Ho risolto nel modo piu semplice ho provato re installare tor browser con questi comandi sudo add-apt-repository ppa:upubuntu-com/tor64 sudo apt-get update sudo apt-get install tor-browser ovviamente al update mi dava errore, quindi sono andato in impostazioni di sistema-software e aggiornamenti-altro software ed ho eliminato le ppa che ho trovato,e scomparso l errore

coll. permanente

ha risposto 19 Dic '13, 21:16

ilcolibri2's gravatar image

ilcolibri2
20112

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×168

domanda posta: 18 Dic '13, 20:49

domanda visualizzata: 3,538 volte

ultimo aggiornamento: 21 Dic '13, 19:05

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.