Ciao a tutti! Purtroppo ieri per sbaglio ho disinstallato da Ubuntu Software Center Compiz e Unity e in conseguenza di ciò il pc all'avvio, dopo la schermata di identificazione utente, mostra lo schermo completamente nero. Mi servirebbe quindi sapere come ripristinare i software grafici da recovery mode da terminale. Premetto inoltre che quando tento di installare Unity con il comando "apt-get install unity" mi dà errore e la modalità grafica di emergenza non funziona perché non riesce a rilevare la scheda grafica.

chiesto 29 Dic '13, 12:37

Michi-Pine's gravatar image

Michi-Pine
244202632


Dovrebbe essere sufficiente reinstallare il pacchetto ubuntu-desktop con il comando:

sudo apt-get install ubuntu-desktop

Edit

Se non riesci a farlo da recovery, puoi farlo da Live CD o Live USB:

  1. avvia il sistema con "Prova Ubuntu senza installarlo";
  2. connettiti alla rete wifi
  3. apri un terminale e digita i seguenti comandi (dove ho supposto che il sistema sia installato nella partizione relativa al device /dev/sda1):

    $ sudo mount /dev/sda1 /mnt
    $ for path in dev dev/pts proc run sys; do sudo mount --bind /$path /mnt/$path; done
    $ sudo chroot /mnt
    #
    

    dopodiché ti troverai in un terminale root sul sistema installato, dove potrai eseguire i comandi:

    # apt-get update
    # apt-get install ubuntu-desktop
    
  4. riavvia il sistema senza Live CD

coll. permanente

ha risposto 29 Dic '13, 13:01

enzotib's gravatar image

enzotib ♦♦
14.0k112186

modificato 30 Dic '13, 14:35

Il problema è che ogni volta che uso il comando install mi dice che è impossibile scaricare alcuni file e in pratica non fa più nulla...

(29 Dic '13, 13:07) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine, probabilmente non funziona la rete, prova a collegarti con un cavo, che dovrebbe funzionare sempre. Poi prova a fare prima un "sudo apt-get update" prima dell'install.

(29 Dic '13, 13:12) enzotib ♦♦ enzotib's gravatar image

Ho provato ad attivare la wifi da terminale, ma niente... Cerco un cavo LAN e poi ti faccio sapere, intanto grazie per l'aiuto!

(29 Dic '13, 13:26) Michi-Pine Michi-Pine's gravatar image

Purtroppo non riesco a trovare un cavo, il problema è che non riesco a connettermi alla wifi perché ha una WPA (anche il comando restricted: non funziona, cioè funziona senza errori, ma quando do dhclient mi dice che alcuni file sono di sola lettura e quindi non mi dà l'IP), in particolare mi dà l'errore mv: cannot stat '/etc/samba/dhcp.conf.new': No such file or directory. Qualcuno sa cosa potrei fare?

(30 Dic '13, 13:32) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine: ho modificato la domanda aggiungendo ulteriori istruzioni, dacci un'occhiata

(30 Dic '13, 14:35) enzotib ♦♦ enzotib's gravatar image

Grande! Non avevo pensato ad usare il live CD; appena arrivo a casa stasera provo e ti faccio sapere, intanto grazie.

(30 Dic '13, 15:43) Michi-Pine Michi-Pine's gravatar image

C'è un problema: mi dà lo stesso risultato di prima con apt-get update, ovvero una valanga di errori per ogni pacchetto, come se non fosse connesso... Idem quando do apt-get install

(31 Dic '13, 09:01) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine ma ha seguito la procedura esattamente come l'ho scritta, compreso il fatto di connetterti ad internet con il sistema live prima di eseguire i comandi elencati?

(31 Dic '13, 09:27) enzotib ♦♦ enzotib's gravatar image

Sì, sono connesso anche mentre sto scrivendo da CD live

(31 Dic '13, 09:45) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine: ping -c3 8.8.8.8 cosa fa? e anche cat /etc/resolv.conf (sempre nel terminale con il chroot)

(31 Dic '13, 09:55) enzotib ♦♦ enzotib's gravatar image

Allora ping -c3 8.8.8.8

root@ubuntu:/# ping -c3 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. 64 bytes from 8.8.8.8: icmp_seq=1 ttl=43 time=62.8 ms 64 bytes from 8.8.8.8: icmp_seq=2 ttl=43 time=59.9 ms 64 bytes from 8.8.8.8: icmp_seq=3 ttl=43 time=56.9 ms

--- 8.8.8.8 ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 2000ms rtt min/avg/max/mdev = 56.951/59.897/62.821/2.396 ms

mentre cat /etc/resolv.conf non fa nulla, non mi dà errore nè niente:

root@ubuntu:/# cat /etc/resolv.conf root@ubuntu:/#

(31 Dic '13, 11:33) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine, apri un altro terminale ed esegui:
cp /etc/resolv.conf /mnt/etc/
poi torna nel terminale chroot e riprova l'update e l'installazione del pacchetto

(31 Dic '13, 12:31) enzotib ♦♦ enzotib's gravatar image

Mi dà:

ubuntu@ubuntu:~$ cp /etc/resolv.conf /mnt/etc/ cp: cannot create regular file ‘/mnt/etc/resolv.conf’: Permission denied

(31 Dic '13, 12:45) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine, si scusa, mettici davanti sudo

(31 Dic '13, 13:38) enzotib ♦♦ enzotib's gravatar image

Finalmente ho risolto! Volevo chiederti se gentilmente potessi spiegarmi quale fosse il problema e qual è stata la soluzione, in modo che la prossima volta possa farcela anche da solo... Grazie infinite intanto!

(31 Dic '13, 14:17) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine: se hai risolto il problema iniziale relativo a Compiz e Unity, allora dovresti accettare la risposta cliccando sul segno di spunta accanto alla stessa.
Il problema è stato evidentemente che hai disinstallato dei pacchetti che non dovevi togliere. La prossima volta chiedi informazioni prima di fare operazioni di questo tipo, anche perché lo spazio che ne ricavi è davvero poco.

(31 Dic '13, 14:39) enzotib ♦♦ enzotib's gravatar image

Scusa avevo sbagliato a cliccare. Comunque è stata proprio una svista, poi me ne sono accorto solo riaccendendo il pc, grazie ancora

(31 Dic '13, 15:32) Michi-Pine Michi-Pine's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×263
×122
×71
×43
×21

domanda posta: 29 Dic '13, 12:37

domanda visualizzata: 2,234 volte

ultimo aggiornamento: 31 Dic '13, 15:32

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.