Ubuntu 13.10, in seguito all'installazione dei driver nVidia (dove ho cominciato a riscontrare problemi all'avvio) ed all'installazione di bumblebee, il notebook rimanda l'errore

The System is runnig in low-graphics mode Your screen, graphics card, and input device settings could not be detected correctly. You will need to configure these yourself.

premo invio e mi appare la schermata

what would you like to do? run in
low-graphics mode for just one session
reconfigure graphics Troubleshoot the
error Exit to console login

dove posso solamente premere invio senza fare selezioni perché né il mouse né la tastiera mi permettono di modificare la scelta o non riesco,

tramite ctrl-alt-f1 accedo alla console virtuale ed ho provato a seguire le istruzioni

sudo apt-get install --reinstall ubuntu-desktop
sudo reboot

indicate nella discussione http://forum.ubuntu-it.org/viewtopic.php?p=4405352

all'inserimento della prima stringa ricevo il seguente messaggio

i seguenti pacchetti hanno dipendenze non soddisfatte:
primus-libs-ia32:i386 : dipende: primus-libs:i386 ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).

inserisco quindi l'istruzione

sudo apt-get -f install

ma ricevo il seguente errore:

si sono verificati errori nell'elaborazione:
/var/cache/apt/archives/primus-libs_20131127- saucyppa1_i386.deb
E: sub-process /usr/bin/dpkg returned an error code (1)

qualcuno sa come risolvere?
grazie.

chiesto 30 Dic '13, 21:28

danida's gravatar image

danida
30469

modificato 04 Gen '14, 19:48

enzotib's gravatar image

enzotib ♦♦
14.0k112186

sudo dpkg -i --force-overwrite /var/cache/apt/archives/primus-libs_20131127- saucyppa1_i386.deb sudo apt-get autoremove sudo apt-get update

se hai ancora l'errore:

gksu nautilus naviga in /var/lib/dpkg/info..ed elimina primus-libs-ia32:i386 chiudi nautilus e poi sudo rm -rf /var/cache/apt/archives/primus-libs_20131127- saucyppa1_i386.deb sudo apt-get install -f sudo apt-get update

(31 Dic '13, 10:13) Beppe Beppe's gravatar image

insersco "sudo dpkg -i --force-overwrite /var/cache/apt/..." e ricevo il seguente errore

"dpkg: errore nell'elaborare /var/cache/apt/archives/primus-libs_20131127- (--install): impossibile accedere all'archivio_ file o directory non esistente dpkg: errore nell'elaborare saucyppa1_i386.deb (--install): impossibile accedere all'archivio: file o directory non esistente si sono verificati degli errori nell'elaborazione: /var/cache/apt/archives/primus-libs_20131127- saucyppa1_i386.deb"

ho quindi inserito "gksu nautilus" ed ho ricevuto

"Gtk-WARNING **: cannot open display:"

(02 Gen '14, 14:37) danida danida's gravatar image

Apri Synaptic e vai in "Danneggiati". Elimina completamente ciò che trovi. Apri la sezione "repository" ed elimina il PPA saucyppa1. Il problema ridiede in quel pacchetto, che va eliminato sudo rm -rf /var/cache/apt/archives/primus-libs_20131127-saucyppa1_i386.deb sudo apt-get install -f sudo apt-get update.

(03 Gen '14, 06:20) Beppe Beppe's gravatar image

ho inserito sudo rm -rf /var/cache/apt/archives/primus-libs_20131127-saucyppa1_i386.deb sudo apt-get install -f ma ricevo il seguente errore

(03 Gen '14, 23:13) danida danida's gravatar image

Dpkg: errore nell’elaborazione /var/cache/apt/archives/primus-libs_20131127-1 saucyppa1_i386.deb ((--unpack): tentata sovrascrittura di “/usr/lib/i386-linux-gnu/primus/libGL.so.1” presente anche nel pacchetto primus-lib:i386 201303160857git quantal1 segnalazione apport non scritta poiché è stato raggiunto il valore massimo di maxreports si sono verificati degli errori nell’elaborazione: /var/cache/apt/archives/primus-libs_20131127-1 saucyppa1_i386.deb E: sub-process /usr/bin/dpkg returned an error code (1)

(03 Gen '14, 23:13) danida danida's gravatar image

e se inserisco sudo apt-get update ricevo un sacco di errori tipo impossibile risolvere "it.archive.ubuntu.com" err http://it.archive.ubuntu.com saucy-updates relase.gpg impossibile risolvere "it.archive.ubuntu."com err http://ppa.launchpad.net saucy release.gpg impossibile risolvere "ppa.launchpad.net" w:impossibile recuperare http://it.archive.ubuntu.com/ubuntu/dists/saucy/inrelease W: impossibile scaricare alcuni file di indice: saranno ingorati o verranno usati quelli vecchi

(03 Gen '14, 23:24) danida danida's gravatar image

A me continua a crashiare non so più che fare...idee???...ho tolto anche i driver open ma appena installo i 311 non mi parte più...sto impazzendo??!!O_O

(04 Gen '14, 11:42) s-giancarli s-giancarli's gravatar image

Purtroppo non so come poterti aiutare. Se non riesci ad eliminare quei files, e non riesci ad entrare in nautilus come root, forse è il caso di fare una reinstallazione col CD live di ubuntu. Lo so che non è una soluzione tecnica ma, essendomi trovato in passato in queste condizioni, ti capisco e reinstallando, in 15/20min. sei a posto. Mi spiace, e spero per te che qualcuno con più conoscienze di me possa suggerirti un altro percorso. Ciao

(04 Gen '14, 13:16) Beppe Beppe's gravatar image

@s-giancarli: 1) cosa c'entri tu con questa domanda? 2) non usare le risposte per postare qualcosa che non è una soluzione

(04 Gen '14, 13:42) enzotib ♦♦ enzotib's gravatar image

Il tuo numero 1 è completamente fuori luogo ma non ho voglia nemmeno di perderci tempo con te 2)se sai leggere ho messo una soluzione provata che nun funziona questo potrebbe aiutare di chi più competenza in una soluzione vera.3)Ciao.. a mai più risentirci...

(04 Gen '14, 14:47) s-giancarli s-giancarli's gravatar image

@s-giancarli: non c'era nessun intento polemico nel mio commento, mi spiace se lo hai inteso in questo modo, ma il tuo intervento sembrava come una continuazione di qualcosa, solo che non c'era nessun intervento precedente. Inoltre la tua risposta non mi sembra proponga alcuna soluzione utile a qualcuno per risolvere il suo problema.

(04 Gen '14, 15:35) enzotib ♦♦ enzotib's gravatar image

Scusami avevo letto dell'arroganza ma se non era così sono felicissimo di ritirare quello che ho detto da subito. Purtroppo i forum le community e quanto altro di Ubuntu è diventato un campo di battaglia. Scusa! amici più di prima :D!...bè dicevo che ho provato con la soluzione di togliere prima i driver open per mettere poi gli Nvidia e non va- pensavo che potesse essere d'aiuto-. Purtroppo è lo stesso problema che ho io da 3 giorni e non trovo soluzione e 3 computer praticamente inusabili...:\

(04 Gen '14, 15:43) s-giancarli s-giancarli's gravatar image

@s-giancarli apri una nuova domanda se hai un problema, non agganciarti a quelle degli altri, che crei solo confusione ;)

(04 Gen '14, 16:07) dadexix86 ♦♦ dadexix86's gravatar image

OK! è la stessa cmq ne apro un'altra..:D

(04 Gen '14, 16:17) s-giancarli s-giancarli's gravatar image

ciao beppe, ti ringrazio veramente per la disponibilità...proverò ancora una volta a rimuovere il file manualmente altrimenti vada per una nuova installazione!! grazie ancora

(09 Gen '14, 17:49) danida danida's gravatar image

Quale scheda video possidi? io ho una 01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 520] (rev a1) e non riesco a installare questi benedetti driver

(09 Gen '14, 21:46) El_drake El_drake's gravatar image

Geforce 650...e io non ci riesco uguale...ho due o 3 guide da provare..

(09 Gen '14, 22:03) s-giancarli s-giancarli's gravatar image

@El_drake: le risposte servono per proporre soluzioni, per quello che dovevi dire dovevi usare un commento.

(09 Gen '14, 22:42) enzotib ♦♦ enzotib's gravatar image

Ciao, io ho ubuntu 13.10 installato ed ho avuto lo stesso problema, che ho risolto eliminando Bumblebee...magari risolvi anche tu...

prova:

sudo apt-get purge bumblebee

coll. permanente

ha risposto 10 Gen '14, 23:01

bio's gravatar image

bio
25126

modificato 10 Gen '14, 23:01

Grazie mille della risposta...si infatti ho risolto anche io così dopo mille tentativi..solo che ai prossimi aggiornamenti che succederà??

(10 Gen '14, 23:06) s-giancarli s-giancarli's gravatar image

guarda,non vorrei dire una fesseria, ma penso che se non hai installato bumblebee non dovrebbero esserci gli aggiornamenti...cmq io l'ho eliminato un mesetto fa e fino ad ora nessun aggiornamento richiesto...

(10 Gen '14, 23:18) bio bio's gravatar image

ciao bio, ho seguito la tua indicazione inserendo sudo apt-get purge bumblebee-nvidia

ho continuato ad avere un errore su primus-libs-ia32:i386, ho quindi inserito l'istruzione e riavviato il sistema

sudo apt-get purge primus-libs-ia32:i386

sudo reboot

pensavo di aver risolto il problema anche se ho ricevuto l'errore sulla scheda grafica che ho cominciato a ricevere con i driver nvidia, dopodiche ubuntu mi ha indicato la presenza di alcuni aggiornamenti che ho eseguito se non che ho ricevuto un errore su di un pacchetto non installato che però non ricordo

(14 Gen '14, 14:43) danida danida's gravatar image

ho riavviato il sistema e mi sono ritrovato nuovamente con l'errore iniziale "The System is runnig in low-graphics mode Your screen, graphics card, and input device settings could not be detected correctly. You will need to configure these yourself."

non ho più il problema delle dipendenze non soddisfatte, e magari potrebbe essere già un passo avanti, ma mi ritovo nuovamente bloccato!

(14 Gen '14, 14:45) danida danida's gravatar image

ciao danida, puoi provare a disinstallare e reinstallare nvidia ricordandoti di disinstallare bumblebee alla fine...

sudo apt-get purge nvidia*

sudo apt-get install nvidia-current

sudo apt-get purge bumblebee

sudo reboot

prova così...ciao!

(14 Gen '14, 16:58) bio bio's gravatar image

ciao bio, ho reinstallare Xorg e sono riuscito a tornare alla risoluzione normale

1)Rimuovere xorg esistente utilizzando il seguente comando sudo apt-get remove --purge xserver-xorg 2)Installare xorg utilizzando il seguente comando sudo apt-get install xserver-xorg 3)Riconfigurare xorg utilizzando il seguente comando sudo dpkg-reconfigure xserver-xorg

4)ho rimosso nvidia e reintallato come mi hai consigliato sudo apt-get purge nvidia* sudo apt-get install-nvdia-current sudo apt-get purge bumblebee

5) infine ho riavviato sudo reboot

però rimane la achermata nera!

(17 Gen '14, 14:16) danida danida's gravatar image

Ho notato che hai risolto il problema con primus-libs-ia32:i386 il mio consiglio è di installare bumblebee. L'errore che hai fatto è molto semplice. Probabilmente quando hai installato i driver nvidia hai installato anche il pacchetto nvidia-prime un tool ancora instabile che in futurò dovra gestire la tecnologia optimus. Ovviamente questo tool non è compatibile con bumblebee e installando entrambe i pacchetti potresti avere appunto l'errore da te descritto (lo so perché anche a me è capitato). Altra possibile causa può essere la mancata installazione del pacchetto bumblebee-nvidia che è quello che permette il corretto funzionamento di bumblebee con i driver nvidia. Comunque sia in primo luogo disinstalla i driver nvidia:

sudo apt-get purge nvidia*

In secondo luogo installiamo correttamente bumblebee dando il comando:

sudo apt-get install bumblebee bumblebee-nvidia
coll. permanente

ha risposto 17 Gen '14, 16:28

jorged's gravatar image

jorged
3.0k101653

ho provato anche questa soluzione rimuovendo tutti i driver nvidia o reinstallato nvidia-319 (ho notato durante l'installazione il seguente messaggio "no original module exists within this kernel")

successivamente ho installato bumblebee e bumblebee-nvidia

ho dato il comando sudo apt-get purge primus che però non risulta installato ho riavviato ed ho ricevuto dopo l'accesso al tty1 il seguente messaggio ripetuto 18 volte con valori numerici differenti [ 52.417954] hda-codec: out of range cmd 0:5:707:fffffffc

(18 Gen '14, 15:02) danida danida's gravatar image

in un report di errore quando il pc ripartiva con grafica 800x600 -JokeyStatus kmod:nvidia_319_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propietario, disabilitato, Non in uso) kmod:nvidia_304 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Libero, disabilitato, Non in uso) kmod:nvidia_304_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propietario, disabilitato, Non in uso) kmod:nvidia_331 - nvidia_331 (Propietario, Abilitato, Non in uso)

(18 Gen '14, 15:02) danida danida's gravatar image

PS: ho eseguito l'aggiornamento di 27 pèaccheti non aggiornati sudo apt-get update e ricevo il seguente errore W: impossibile recuperare bzip2:/var/lib/apt/lists/partial/it.archive.ubuntu.com_ubuntu_dists_saucy-updates_main_binary-amd64_Packages Somma hasa non corrispondente E: impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi

credo che sia arrivato il momento di arrendersi....ho tre partizioni sul pc con windos, ubuntu e una per i dati, esiste un comando per reinstallare ubuntu da terminale senza formattare il resto?

(18 Gen '14, 15:05) danida danida's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×229
×113
×11

domanda posta: 30 Dic '13, 21:28

domanda visualizzata: 2,230 volte

ultimo aggiornamento: 18 Gen '14, 15:22

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.