Salve a tutti, sono nuovo di Chiedi e spero di trovare aiuto qui una grande community. È da qualche giorno che cerco di installare Ubuntu al fianco di Windows 8.1, perché avendo un Raspberry pi necessito di un sistema Linux.

Premetto che ho messo su una pendrive una ISO di Ubuntu 12.04.4 LTS e ho avviato dal BIOS in modalità UEFI, Ubuntu carica normalmente in modalità live e al momento dell'installazione, quando bisogna selezionare la modalità con cui installare Ubuntu, non appare la voce affianca a windows, ma solo cancella il disco o altro. Ora io non posso cancellare il disco, perché windows mi serve per alcuni programmi che non sono su linux.

Non so come fare, so che sono il milionesimo che fa questa domanda, ma leggendo le altre discussioni non ho capito molto.

chiesto 11 Feb '14, 19:40

lucamigliore's gravatar image

lucamigliore
68115

modificato 11 Feb '14, 22:30


Guarda qui:

http://chiedi.ubuntu-it.org/questions/12182/installazione-ubuntu-in-dual-boot-con-windows-8-uefi-e-secure-boot

Spero possa esserti utile.

Se a causa di un errore nell'ubicazione di Grub il dual Boot non dovesse funzionare, è possibile provare a rimediare così:

  1. scaricare e masterizzare la iso della Live di Ubuntu 13.04 Linux-Secure-Remix, che al suo interno contiene il software Gparted e Boot-Repait;
  2. avviare Secure-Remix in modalità prova;
  3. cliccare sull'icona di Gparted per visualizzare la maschera che indica l'area in cui è dislocata la partizione Fat32 (che contiene EFI),

alt text

generalmente la si trova in sda2.

Dopodiché, chiudere Gperted, avviare il programma Boot-Repair e seguendone le indicazioni ed indicandogli l'area del disco che contiene EFI (nell'esempio sda2) procedere al ripristino di Grub.

coll. permanente

ha risposto 11 Feb '14, 20:39

enzoge's gravatar image

enzoge
4.6k213987

modificato 12 Feb '14, 07:33

Mille grazie per la risposta, ho seguito le guida, e in piú ho aggiunto una partizione montata in /boot dove installare grub. Purtroppo l'installazione di grub é fallita e mi sono trovato senza ubuntu :(. Seguendo la tua guida, in che partizione va installato grub per ottenere il dual boot uefi? @ilgallinetta

(11 Feb '14, 22:27) lucamigliore lucamigliore's gravatar image

@lucamigliore: Le risposte non servono per chiedere chiarimenti o comunicare i risultati di qualcosa, ma tutto questo può essere scritto tramite i commenti.

(11 Feb '14, 22:30) enzotib ♦♦ enzotib's gravatar image

Scusatemi, sono appena iscritto e non conosco bene come funziona. Proverò a cancellare la risposta e ad aggiungere un commento.

(11 Feb '14, 22:32) lucamigliore lucamigliore's gravatar image

@lucamigliore: ho aggiunto qualche altra considerazione alla risposta

(12 Feb '14, 07:28) enzoge enzoge's gravatar image

@ilgallinetta non é quello il problema, il fatto é che grub non si é proprio installato nella partizione /boot creata da me quindi il sisema si avviava normalmente in windows. La mia domanda é, seguendo la tua guida che mi hai mandato all'inizio, in che partizione devo installare grub? Devo installarlo sul disco /dev/sda ?

(12 Feb '14, 07:48) lucamigliore lucamigliore's gravatar image

@lucamigliore: come dico nell'aggiunta che ho fatto alla risposta, perché in presenza di EFI il Dual Boot possa funzionare, Grub va installato nella partizione Fat32 dove c'è EFI con il Boot UEFI, che viene sovrascritto da Grub. Puoi creare tutte le partizioni che vuoi, ma Grub deve stare lì.

(12 Feb '14, 08:14) enzoge enzoge's gravatar image

Mille grazie per l'aiuto, come torno a casa proverò, ora sono a scuola! @ilgallinetta

(12 Feb '14, 08:18) lucamigliore lucamigliore's gravatar image

Io ti ho solo riferito come ha funzionato sul mio computer, dove la prima volta installando la 13.10 non ho dovuto usare Boot-Repair, mentre quando ho sovrapposto la 12.04.3 alla 13.10, ho dovuto usarlo. Spero sia lo stesso anche per te.

(12 Feb '14, 08:42) enzoge enzoge's gravatar image

Installato. Funziona tutto alla perfezione, sia win che ubuntu. Il dual boot avviene da uefi come mi aspettavo. Mille grazie!

(12 Feb '14, 14:49) lucamigliore lucamigliore's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×776
×263
×136
×97

domanda posta: 11 Feb '14, 19:40

domanda visualizzata: 5,053 volte

ultimo aggiornamento: 12 Feb '14, 14:49

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.