Ciao a tutti, sono da poco passato ad Ubuntu 13.10 e mi trovo benissimo, ma da nuovo utente sono portato a pastrocchi vari.
Ho disinstallato wine (credo anche con autoremove) e non riesco più ad installarlo.
Ho provato diverse vie anche da terminale con la nuova 1.7 ma mi dà sempre lo stesso errore:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 wine1.7 : Dipende: wine1.7-i386 (= 1:1.7.12-0ubuntu1~saucy1)
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

Sapete che posso fa'? Grazie

Allego l'output del comando sudo apt-get update.

chiesto 14 Feb '14, 08:36

Marcello's gravatar image

Marcello
20113

modificato 15 Feb '14, 11:34

dadexix86's gravatar image

dadexix86 ♦♦
16.9k716161

1

@Marcello: comincia con l'eseguire il comando
sudo apt-get update
poi copia tutto l'output e incollalo su pastebin, dopodiché modifichi la tua domanda aggiungendo il link a pastebin.

(14 Feb '14, 09:54) enzotib ♦♦ enzotib's gravatar image
1

@Marcello: vedo che wine 1.7 non è nei repo ufficiali, e tu hai un PPA, quindi questa può essere l'origine dei problemi. Come mai hai bisogno della 1.7?

(14 Feb '14, 12:00) enzotib ♦♦ enzotib's gravatar image

ciao Enzo, io avevo provato ad installare la 1.4 prima da U.S.C., poi da Synaptic e terminale incappando sempre nello stesso problema.Ho provato a vedere se con la 1.7 cambiava musica.. Ho installato anche, non dai repo ufficiali,le nuove versioni di adunanza e vlc. Ho fatto un po' di pulizia con apt-get --purge autoremove e con gtkorphan

(14 Feb '14, 17:57) Marcello Marcello's gravatar image

Prova a dare da terminale:

sudo apt-get install wine wine1.7 wine1.7-i386
coll. permanente

ha risposto 14 Feb '14, 11:51

nico's gravatar image

nico
9833416

Ciao Nico, ecco l'esito: http://pastebin.ubuntu.com/6932220/ Anche con la 1.4 mi restituiva lo stesso identico messaggio..cambiava solo il 4 al posto del 7

(14 Feb '14, 18:18) Marcello Marcello's gravatar image

Correggo: oltre alle versioni cambiano leggermente anche le dipendenze

(14 Feb '14, 18:28) Marcello Marcello's gravatar image
1

Il tuo sistema è a 32 o 64 bit?

(14 Feb '14, 23:41) nico nico's gravatar image

Tipo OS 64-bit AMD Athlon(tm) 64 X2 Dual Core Processor 5600+ x 2 Memoria 2,9 GiB

(15 Feb '14, 04:08) Marcello Marcello's gravatar image
1

Eh, il problema sta nel fatto che wine1.7-i386 è un pacchetto a 32 bit e quindi si porta dietro diverse dipendenze per quell'architettura. Puoi provare ad installare prima la dipendenza che crea il problema e vediamo che succede, dai da terminale "sudo apt-get install libgphoto2-6:i386".

(15 Feb '14, 11:21) nico nico's gravatar image

Eccomi, allora provato e la risposta mi sembra sempre uguale http://pastebin.ubuntu.com/6947909/

(17 Feb '14, 10:36) Marcello Marcello's gravatar image

Mh... Aldilà di tutti i problemi che possono derivare dall'avere tutti quei repository esterni abilitati, per installare pacchetti a 32 bit su una 64 bit devi aggiungere l'architettura al sistema pacchetti, in modo da abilitare quello che si chiama multiarch (come ad esempio bisogna fare per Skype).

dpkg --add-architecture i386
coll. permanente

ha risposto 15 Feb '14, 11:45

dadexix86's gravatar image

dadexix86 ♦♦
16.9k716161

modificato 15 Feb '14, 12:47

1

@dadexix86: crazynetwork è un mirror ufficiale, quindi è OK

(15 Feb '14, 12:16) enzotib ♦♦ enzotib's gravatar image
1

@enzotib ho provato a googlare per info ma non le ho trovate, puoi linkare un elenco di mirror ufficiali?

(15 Feb '14, 12:30) dadexix86 ♦♦ dadexix86's gravatar image
1

@dadexix86: la lista dei mirror disponibili in Software e aggiornamenti dovrebbe essere quella in /usr/share/python-apt/templates/Ubuntu.mirrors

(15 Feb '14, 12:39) enzotib ♦♦ enzotib's gravatar image
1

Ah, perfetto, grazie mille! :D

(15 Feb '14, 12:46) dadexix86 ♦♦ dadexix86's gravatar image
1
(15 Feb '14, 12:51) enzotib ♦♦ enzotib's gravatar image

Rieccomi :) sono quasi certo che la versione di Ubuntu che ho è presa dal sito ufficiale.Enzo ho provato con dpkg e mi ha risposto: dpkg: errore: impossibile creare il file nuovo "/var/lib/dpkg/arch-new": Permesso negato così nella mia "ignoranza" ho aggiunto un sudo al comando e non mi ha risposto nulla. Ho provato a reinstallare wine 1.4 e la risposta è sempre la solita. Aggiungo che ho skype perfettamente funzionante e che prima wine 1.4 mi funzionava.

(17 Feb '14, 10:47) Marcello Marcello's gravatar image

Scusate enzotib e dadexix86, credo di aver fatto un po' di confusione con i nomi..ma la sostanza della mia comunicazione non cambia

(17 Feb '14, 11:21) Marcello Marcello's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×63

domanda posta: 14 Feb '14, 08:36

domanda visualizzata: 4,399 volte

ultimo aggiornamento: 17 Feb '14, 12:19

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.