Ciao a tutti, ho backtrack 5r3 gnome 64bit e ho questo problema:

sudo apt-get install synaptic
Reading package lists... Done
Building dependency tree... Done
Package unrar is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package synaptic has no installation candidate

Come posso risolvere? Ho già provato sudo apt-get update ma nulla! Vi posto la /etc/apt/sources.list

deb http://all.repository.backtrack-linux.org revolution main microverse non-free testing
deb http://64.repository.backtrack-linux.org revolution main microverse non-free testing
deb http://source.repository.backtrack-linux.org revolution main microverse non-free testing

chiesto 12 Lug '13, 23:25

xxandreaxx's gravatar image

xxandreaxx
447911

modificato 13 Lug '13, 00:01

rpadovani's gravatar image

rpadovani ♦♦
3.1k51351

premetto che non conosco la distribuzione, volevo evidenziare: quando apri il terminale la riga dove tu inizi a scrivere termina con " # " oppure con " $ " , vedi: http://scx010c075.blogspot.it/2012/01/installing-synaptic-and-software-center.html

(13 Lug '13, 00:40) dxgiusti dxgiusti's gravatar image

@dxgiusti: visto che questa non è una risposta, perché non fornisce supporto, deve essere inserito come commento. Questa volta te l'ho modificato io, ma cerca di starci attento, per favore :)

Ciao,
R.

(13 Lug '13, 00:50) rpadovani ♦♦ rpadovani's gravatar image

@dxgiusti: termina con # root@bt:~# Più o meno e così comunque termina con #

(13 Lug '13, 01:18) xxandreaxx xxandreaxx's gravatar image

terminando con il cancelletto sei già root, quindi installa senza il sudo: apt-get install synaptic

(13 Lug '13, 12:09) dxgiusti dxgiusti's gravatar image

Il problema non è sicuramente usare sudo come utente root, lo puoi fare quante volte vuoi, prova a scrivere "sudo sudo sudo ls", vedrai che funziona :)

Il problema è che nelle fonti indicate non c'è un pacchetto chiamato synaptic. Non conosco molto backtrack, quelle sono le uniche fonti disponibili?

Se proprio synaptic non dovesse esserci in nessuna delle fonti ufficiali potresti provare a usare un .deb di debian o ubuntu.

La cosa migliore se vuoi provare con un deb da un altra distro è cercare di procurarti i lfile deb e installarlo con "dpkg -i nome-file.deb" ma esiste anche un altra soluzione, più rischiosa.

Ricordo anni fa, ai tempi delle prime ubuntu, quando la differenza con debian era molto poca, alcuni aggiungevano al sources.list le fonti di debian per colmare alcune mancanze di pacchetti.

Naturalmente questo NON va fatto su una ubuntu moderna in quanto la differenza con debian ora è molto alta.

Backtrack su quale distro è basata? Se ha un ramo di sviluppo tutto suo non ti conviene neanche provarci, ma se ogni rilascio viene risincronizzato con la distro originale, come avviene per altri fork di debian, allora puoi inserire nel sources.list le fonti originali, installare synaptic e poi rimuovere le fonti dal sources, per evitare che al primo aggiornamento ti trovi pacchetti misti.

Mi raccomando, informati bene sull'origine della distro prima di tentare questa cosa, non mi assumo responsabilità se metti sources di altre distro incompatibili e/o lanci un upgrade.

coll. permanente

ha risposto 13 Lug '13, 14:26

Marco's gravatar image

Marco
1.5k4930

Ma il problema e che non riesco ad usare il comando dpkg -i che mi da un errore È le repo non so dove trovare me lo potete dire voi?

(13 Lug '13, 16:54) xxandreaxx xxandreaxx's gravatar image

che errore ti da?

(13 Lug '13, 18:02) Marco Marco's gravatar image

Mi. Dice Errore were encountered while processing: chrome.deb

(13 Lug '13, 18:27) xxandreaxx xxandreaxx's gravatar image

Backtrack in buona sostanza usa repo ubuntu + altri repo suoi , il problema si risolve leggendo il sources.list e vedendo che mancano i repo di ubuntu

coll. permanente

ha risposto 13 Lug '13, 15:13

Gioakkino's gravatar image

Gioakkino
47226

Ottima informazione +1

(13 Lug '13, 15:43) Marco Marco's gravatar image

Scusate non sono molto esperto mi potete dire voi che repo devo mettere dentro sources.list

(13 Lug '13, 16:50) xxandreaxx xxandreaxx's gravatar image

Questo dovresti chiederlo al supporto di backtrack e non qui in quanto io non posso sapere su quale relase di ubuntu poggi il tuo BT

(13 Lug '13, 16:55) Gioakkino Gioakkino's gravatar image

Backtrack era basata su ubuntu 10.04 (di cui, se non sbaglio, non è più supportata la versione desktop), dico era perché la distribuzione ha cambiato nome e anche base (è passata a debian e adesso si chiama Kali Linux. Quindi se ti serve una disto per il pentesting e vuoi continuare ad usare una derivata di ubuntu ti consiglio di passare a Backbox (che, oltre ad essere un progetto italiano, è ben aggiornata, leggera e fornita di tutto ciò che necessita a chi lavora e/o si diletta nell'ambito della sicurezza informatica), oppure puoi passare a Kali.

coll. permanente

ha risposto 13 Lug '13, 20:03

nico's gravatar image

nico
9833416

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×6

domanda posta: 12 Lug '13, 23:25

domanda visualizzata: 1,367 volte

ultimo aggiornamento: 13 Lug '13, 20:03

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.