Buongiorno gente,

ho due pc di cui il primo in dual boot windows8 e ubuntu 12.10 e un fisso con windows 8. Volevo rendere dignitoso anche il secondo mettendo anch'esso in dual boot con ubuntu.

Il problema è che al termine dell'installazione ( riprovata più volte), al tentativo di accesso al pc, mi ritrovo sempre nel grub rescue(che insinua che manca un file system)

Ho provato a seguire più guide, per tentare di risolvere sia da terminale con il ripristino del grub, sia direttamente dalla rescue. Con il primo non da errori in fase di risoluzione ma al riavvio il problema non cambia.

Tramite rescue arrivo sempre al comando: grub rescue> insmod (hd0,msdos4)/boot/grub/linux.mod

che mi da un errore insinuante che il file linux.mod non è stato trovato.

Aiutatemi please, non so più dove sbattere la testa

chiesto 21 Feb '14, 09:50

Pigreco91's gravatar image

Pigreco91
6224

1

Windows 8... UEFI?

(21 Feb '14, 10:13) dadexix86 ♦♦ dadexix86's gravatar image

Entrando nel Boot Sequence, su una delle due scelte (che è quella che riporta anche l'immagine del cd) ho la dicitura UEFI quindi penso sia un sistema UEFI.

P.s.: grazie per la risposta rapidissima

(21 Feb '14, 10:28) Pigreco91 Pigreco91's gravatar image
2

Ok, perché per UEFI c'è una procedura apposita per l'installazione :)

(21 Feb '14, 11:07) dadexix86 ♦♦ dadexix86's gravatar image
1

Grazie mille, adesso provo ad applicarla e vi aggiorno

(21 Feb '14, 11:17) Pigreco91 Pigreco91's gravatar image

Guarda qui se può esserti utile, soprattutto la parte finale che parla del ripristino di Grb:

http://chiedi.ubuntu-it.org/questions/12182/installazione-ubuntu-in-dual-boot-con-windows-8-uefi-e-secure-boot

Siamo sicuri che stai usando la 64 bit vero? perché la 32 bit non ha la funzionalità UEFI.

coll. permanente

ha risposto 21 Feb '14, 13:29

enzoge's gravatar image

enzoge
4.7k253988

Eureca, il problema era proprio il sistema di boot UEFI, seguendo la procedura che dadexix86 mi hai linkato ho risolto.

Grazie mille per l'aiuto a entrambi

(21 Feb '14, 14:57) Pigreco91 Pigreco91's gravatar image

Sisi stavo usando una versione 64 bit.

Grazie per la risposta

(21 Feb '14, 14:57) Pigreco91 Pigreco91's gravatar image

Le risposte non servono per chiedere chiarimenti o comunicare i risultati di qualcosa, ma tutto questo può essere scritto tramite i commenti.

Inoltre ho aggiunto una risposta con il mio suggerimento, per favore accettala.

(21 Feb '14, 15:05) dadexix86 ♦♦ dadexix86's gravatar image

Per UEFI c'è una procedura apposita per l'installazione :)

coll. permanente

ha risposto 21 Feb '14, 15:04

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

E' sopraggiunto un problema, quando adesso da Grub cerco di entrare in windows 8 mi da:

errore: impossibile trovare il comando "drivemap" errore: invalid efi file path

Sapete risolvermi anche questo problema? :-)

(22 Feb '14, 01:21) Pigreco91 Pigreco91's gravatar image

Ma Ubuntu funziona?

Purtroppo le conoscenze di Windows su questo forum sono molto limitate, ti conviene rivolgerti al supporto Microsoft :)

(22 Feb '14, 01:38) dadexix86 ♦♦ dadexix86's gravatar image

Mi viene da pensare che il problema stia nel posizionamento di Grub, che non si trova nella partizione EFI.

In questo caso, mi permetto di suggerire la parte finale della risposta presente nella pagina che ho linkato qui sopra.

Ossia:

  • avviare il PC con la Live di secure Remix in modalità prova e con Boot Legacy;
  • usare Gparted per vedere dov'è la partizione EFI;
  • collegarsi ad Internet;
  • avviare il programma Boot-Repair e posizionare Grub dove c'è EFI;
  • posizionato Grub, chiudere Segure Remix e riavviare il PC passando prima dal Bios per tiattivare la modalità UEFI.
(22 Feb '14, 07:28) enzoge enzoge's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×211
×13

domanda posta: 21 Feb '14, 09:50

domanda visualizzata: 1,627 volte

ultimo aggiornamento: 22 Feb '14, 07:28

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.