Salve a tutti, ho da poco aggiornato ubuntu 12.04 a 13.10, ma il software center non si apre più, nemmeno provando a reinstallare. Provando ad avviare da terminale esce questo errore:

2013-07-13 11:13:51,865 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 429, in __init__
    self.useful_cache = UsefulnessCache(True)
  File "/usr/share/software-center/softwarecenter/backend/reviews/__init__.py", line 91, in __init__
    self._retrieve_votes_from_server()
  File "/usr/share/software-center/softwarecenter/backend/reviews/__init__.py", line 105, in _retrieve_votes_from_server
    user = get_person_from_config()
  File "/usr/share/software-center/softwarecenter/utils.py", line 638, in get_person_from_config
    cfg = get_config()
  File "/usr/share/software-center/softwarecenter/config.py", line 180, in get_config
    _software_center_config = SoftwareCenterConfig(filename)
  File "/usr/share/software-center/softwarecenter/config.py", line 38, in __init__
    super(SoftwareCenterConfig, self).__init__()
TypeError: must be type, not classobj

cosa potrei fare per risolvere? grazie in anticipo.

chiesto 13 Lug '13, 11:45

otrebla's gravatar image

otrebla
10111

modificato 18 Ago '13, 22:13

pietroalbini's gravatar image

pietroalbini ♦♦
3.1k2947

Io uso synapic molto più leggero ma se proprio non puoi fare a meno della versione più accattivante vai al sito app ubuntu: https://apps.ubuntu.com/

P.S. poi come dice @Nico la 13.10 è ancora in sviluppo cmq provando la io non ho riscontrato il tuo problema...

(15 Lug '13, 01:49) davide davide's gravatar image

Il bug in questione credo sia questo, ed è stato fixato ieri. Abilita i repo proposed, aggiorna e il problema dovrebbe risolversi.

Ti ricordo che saucy è una versione in fase di sviluppo e quindi errori del genere sono frequenti, in ambito produttivo è consigliabile l'uso di una versione stabile.

coll. permanente

ha risposto 13 Lug '13, 21:37

nico's gravatar image

nico
9833416

Ciao! Se hai dei temi particolari installati prova a disinstallarli. Anche io avevo questo problema ma alla fine mi è venuto in mente di cambiare il tema e ha funzionato.

coll. permanente

ha risposto 14 Lug '13, 22:28

jackthesmoker95's gravatar image

jackthesmoker95
10

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×115

domanda posta: 13 Lug '13, 11:45

domanda visualizzata: 2,075 volte

ultimo aggiornamento: 18 Ago '13, 22:13

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.