Salve a tutti, ho deciso di diventare utente linux così ho installato per la prima volta ubuntu 13.10 su una partizione dell'hard disk con windows 7; dopo l'installazione di ubuntu 13.10 mi ha chiesto il classico riavvio, solo che all'accensione del pc non mi fa scegliere uno tra i due sistemi operativi ma mi apre direttamente windows 7. potreste aiutarmi?

chiesto 02 Mar '14, 03:05

robertolinux's gravatar image

robertolinux
40112

sono riuscito ad installarlo correttamente, ma all'avvio del pc entro nel bios per dirgli di tornare in windows e mi dice "reboot and select proper boot device". ho fatto qualche casino? in caso prima di partizionare feci un backup di tutto quindi non dovrei aver perso nulla. sareste gentilissimi se mi aiutaste perchè il pc non ha neanche un mese e non voglio far casini; grazie in anticipo

(02 Mar '14, 05:08) robertolinux robertolinux's gravatar image

@robertolinux: Le risposte non servono per chiedere chiarimenti o comunicare i risultati di qualcosa, ma tutto questo può essere scritto tramite i commenti.

(02 Mar '14, 11:07) enzotib ♦♦ enzotib's gravatar image

Dai qualche notizia in più, es.:

  • come hai unstallato, se da DVD o da penfìdrive:
  • se il tuo computer ha EFI e Secure Boot.
(03 Mar '14, 09:27) enzoge enzoge's gravatar image

ho installato da dvd, non conosco ne EFI ne secure boot quindi non so dirle

(09 Mar '14, 12:54) robertolinux robertolinux's gravatar image

Accedi da Live e posta su pastebin l'output di

sudo fdisk -l
(09 Mar '14, 13:01) dadexix86 ♦♦ dadexix86's gravatar image

per accedere da live devo inserire il cd?

(09 Mar '14, 13:27) robertolinux robertolinux's gravatar image

CD, DVD, chiavetta, quello che preferisci :)

(09 Mar '14, 13:30) dadexix86 ♦♦ dadexix86's gravatar image
(09 Mar '14, 13:42) robertolinux robertolinux's gravatar image

Partizionamento GPT, quindi direi che hai UEFI :)

Per installare con UEFI devi utilizzare la guida apposita :)

(09 Mar '14, 13:45) dadexix86 ♦♦ dadexix86's gravatar image

si ma il problema non è come installare linux, visto che l'ho installato correttamente, il prolema è che dopo l'installazione di linux (sulla partizione) non mi fa accedere a windows dandomi l'errore postato in precedenza, ovvero "reboot and select proper boot device"

(09 Mar '14, 13:48) robertolinux robertolinux's gravatar image

Quindi quando provi a selezionarlo da GRUB? Posta (su pastebin) la configurazione di GRUB, contenuta nel file /boot/grub/grub.cfg.

È strano, perché in genere quel messaggio avviene quando provi ad avviare da un disco che non ha un bootloader. Ma se tu hai installato Ubuntu correttamente con UEFI avvii Windows da GRUB, col dual boot e quell'errore non ha senso.

(09 Mar '14, 14:03) dadexix86 ♦♦ dadexix86's gravatar image

no da GRUB non seleziono nulla, ora il bios l'ho impostato in modo tale che all'avvio parte linux, mentre se come impostazione metto di far fare il boot dalla partizione dove vi era installato windows(e che dovrebbe esserci visto che non l'ho disintallato) mio da l'errore postato prima. volevo sapere, come posso accedere alla configurazione di grub? chiedo scusa ma sono utente linux da poco :)

(09 Mar '14, 14:29) robertolinux robertolinux's gravatar image

Ma il bootloader dove l'hai installato?

Non basta che ci sia il sistema per far sì che venga avviato, c'è bisogno che il BIOS trovi il bootloader :)

Se hai installato su due dischi diversi, in teoria dovresti averne 2. GRUB che è stato installato con Ubuntu e il bootloader di Windows.

La mia ipotesi, al momento, è che con GRUB hai sovrascritto quello di Windows.

(09 Mar '14, 14:35) dadexix86 ♦♦ dadexix86's gravatar image

.....quindi? xD ipotetica soluzione? a parte prendere a martellate il pc xD

(09 Mar '14, 14:41) robertolinux robertolinux's gravatar image

Inizia a postarmi le informazioni che ti ho chiesto, coadiuvandole con info su dove (partizione, ecc) hai installato Ubuntu :)

(09 Mar '14, 14:47) dadexix86 ♦♦ dadexix86's gravatar image

non so come accedere alla configurazione di GRUB :(

(10 Mar '14, 16:18) robertolinux robertolinux's gravatar image

Te l'ho detto sopra, è nel file /boot/grub/grub.cfg.

(10 Mar '14, 16:28) dadexix86 ♦♦ dadexix86's gravatar image

se metto tale directory nel terminale mi dice file o directory non esistente

(10 Mar '14, 16:45) robertolinux robertolinux's gravatar image

Scusami, è vero, hai installato con UEFI.
Francamente non so dove vengano salvate le impostazioni del bootloader con UEFI, aspettiamo qualcuno meno ignorante di me :)

(10 Mar '14, 23:40) dadexix86 ♦♦ dadexix86's gravatar image

@dadexix86, @robertolinux, non so se posso essere d'aiuto ma a me risulta che in presenza della partizione EFI il bootloader debba essere installato nella stessa EFI, quella formattata fat32 (quasi sempre la sda2).

Oltre al manuale ufficiale, mi permetto di suggerire la lettura di questa risposta:

http://chiedi.ubuntu-it.org/questions/12182/installazione-ubuntu-in-dual-boot-con-windows-8-uefi-e-secure-boot

che spesso è stata d'aiuto.

coll. permanente

ha risposto 11 Mar '14, 11:27

enzoge's gravatar image

enzoge
4.6k203987

modificato 11 Mar '14, 11:29

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,595

domanda posta: 02 Mar '14, 03:05

domanda visualizzata: 1,164 volte

ultimo aggiornamento: 11 Mar '14, 11:29

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.