Salve a tutti, mi rendo conto che la domanda sia un po' noiosa, ma ho davvero uno strano problema con i driver della mia scheda grafica.

Ho sempre utilizzato i driver Nvidia, ma un giorno accendo il pc e la risoluzione è sballata.
Provo tutte le versioni dei driver Nvidia e ottengo solo che l'interfaccia grafica non si avvia più.
Provo e riprovo con entrambe le partizioni, una con ubuntu 13.10 e l'altra con elementary os (basata su ubuntu 12.04).

Allora penso che sia la scheda grafica a stare partendo.

Cambio la scheda e il problema è il medesimo.
Provo a cambiare lo slot della pci ma il problema è sempre lo stesso.

La cosa strana è che con i driver open (i nouveau, per intenderci) il problema non si presenta.
Insomma, funziona tutto bene, anche la risoluzione è corretta, ma è ovvio che le prestazioni non sono le stesse.

Se ad esempio provo a giocare a Braid tutto funziona fluidamente (non è un gioco molto pesante) ma dopo tipo 10-15 minuti il pc si spegne di colpo.

Non ho alcuna partizione con Windows per testare se con esso la scheda funzioni, e non vorrei proprio metterlo dato che non saprei che farmene ed è una noia cercare antivirus ecc..
Qualcuno ha mai avuto problemi simili? Di solito mi sono sempre arrangiato ma questa volta non riesco proprio a venirne fuori, mi pare strano anche che il problema sia hardware, dato che con i nouveau funziona tutto.

Le schede video Nvidia che ho provato sono 1. Geforce 9600gt da 1 GB 2. Geforce GTX 650 da 2 GB

Grazie per l'aiuto.

chiesto 05 Mar '14, 21:20

moriserre's gravatar image

moriserre
75247

modificato 05 Mar '14, 22:11

dadexix86's gravatar image

dadexix86 ♦♦
16.9k716161

ciao, con scheda GeForce GT220 (su Ubuntu 12.04.4 con kernel 3.11.0-17-generic) ho il tuo medesimo problema, penso di averle provate tutte, ma non riesco a venirne a capo...

(06 Mar '14, 14:34) Ignix Ignix's gravatar image

Ciao, grazie della risposta. Ho provato ad installare Chakra, una distribuzione linux che nulla ha a che fare con Ubuntu, purtroppo il problema non è cambiato. Ciò significa che il problema non è Ubuntu ma altro. A questo punto si tratta o di una compatibilità con linux in generale (strano però che fino a qualche settimana fa tutto andasse bene), oppure un problema alla scheda madre. Per caso hai una partizione con Windows per capire se il problema si presenta anche con un differente SO?

(06 Mar '14, 21:19) moriserre moriserre's gravatar image

Spesso le risoluzioni video a disposizione sono di gran lunga inferiori a quelle offerte con il driver open source.

Il driver compilato da NVIDIA sembra molto debole nel rilevare efficacemente questa informazione dal monitor e si affida alle informazioni aggiuntive in xorg.conf, per risolvere questo problema procedere come segue:

Digitare in una finestra di terminale il seguente comando:

xrandr --addmode S-video 123x456

sostituire il valore «123x456» inserendo la risoluzione che si desidera per il proprio schermo ad esempio 800x600, 1024x768, etc..

Fonte

coll. permanente

ha risposto 06 Mar '14, 21:11

lillo8919's gravatar image

lillo8919
2464815

Ciao, ti ringrazio e proverò subito, anche se ho qualche dubbio, più che altro perché fino a poco tempo fa tutto funzionava bene, poi un giorno ho avviato il pc e la risoluzione era sballata in entrambe le partizioni. Farò a breve anche questa prova, ma comincio a pensare che possa esserci qualche problema nella scheda madre.

(06 Mar '14, 21:23) moriserre moriserre's gravatar image

Ok... Cmq per la mia geforce 610M la guida funziona... Facci sapere se funziona anche per le tue!

(06 Mar '14, 21:26) lillo8919 lillo8919's gravatar image

Ok, provo subito. Installo i driver Nvidia e poi inserisco la striga che mi hai postato nel terminale. Hai qualche consiglio su che driver installare per la geforce 650 gtx?

(06 Mar '14, 21:30) moriserre moriserre's gravatar image

Non conosco la scheda in particolare cmq per le gtx il mio parere è quello di cercare di usare sempre driver proprietari e affrontare eventuali bug con la wiki che ti ho citato sopra, senza nulla togliere ai driver open, anzi.

(06 Mar '14, 21:42) lillo8919 lillo8919's gravatar image

Caspita, ho cercato di installare i driver più idonei scaricandoli direttamente dal sito nvidia, in questo caso si trattava dei 331.49, ma mi si è bloccata l'installazione e piantato il pc, al riavvio ho tentato di reinstallare i driver da terminale ma ho avuto diversi problemi, sembrava tutto ok ma poi settando la risoluzione mi diceva che non riusciva a trovare quel tipo di risoluzione (o qualcosa di simile), ad ogni modo non sono riuscito a risolvere per ora e sono nell'altra partizione con chakra. Nemmeno qui, con kernel 3.12, i driver funzionano. Dramma. Temo proprio che il problema sia hardware. Magari nei prossimi giorni provo a installare windows e vedere se li va tutto correttamente. Intanto ti ringrazio per l'aiuto.

coll. permanente

ha risposto 06 Mar '14, 23:01

moriserre's gravatar image

moriserre
75247

Non credo sia un problema hardware... Avresti reazioni più violente secondo me... Cmq se hai possibilità prova e se effettivamente fosse così... In forno con le patate (:

(06 Mar '14, 23:30) lillo8919 lillo8919's gravatar image

:) OK! Allora brasato all'Nvidia con patate novelle! A breve riproverò, anche se ogni volta aggiungo problemi e ho già reinstallato tutto diverse volte. ti ringrazio ancora e intanto ti saluto.

coll. permanente

ha risposto 06 Mar '14, 23:37

moriserre's gravatar image

moriserre
75247

Ti prego di usare i commenti per favore, le risposte servono solo a comunicare soluzioni cmq ok... Facci sapere come va. Ciao

(06 Mar '14, 23:40) lillo8919 lillo8919's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×105
×52

domanda posta: 05 Mar '14, 21:20

domanda visualizzata: 2,322 volte

ultimo aggiornamento: 06 Mar '14, 23:40

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.