2
1

Mi compare un messaggio d'errore quando tento di aggiornare i pacchetti. Qualcuno può aiutarmi ad interpretarlo?
Ve lo posto e vi ringrazio in anticipo: http://paste.ubuntu.com/7135318/

 W: Si è verificato un errore nel verificare la firma. Il repository non è aggiornato e verranno usati i file indice precedenti. Errore GPG: http://it.archive.ubuntu.com saucy-updates Release: Le seguenti firme non erano valide: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

W: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/dists/saucy-updates/Release

W: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.

chiesto 22 Mar '14, 11:08

fuch690's gravatar image

fuch690
54339

modificato 23 Mar '14, 11:31

alevipri's gravatar image

alevipri
5.5k2479

@fuch690 le risposte vanno utilizzate solo per fornire soluzioni alla domanda, per tutto il resto utilizza i Commenti.

(22 Mar '14, 11:59) alevipri alevipri's gravatar image

pardon, ma non mi faceva postare un commento così lungo

(22 Mar '14, 12:19) fuch690 fuch690's gravatar image
3

Modifico il titolo della domanda, così altri che otterranno l'errore BADSIG sapranno dove cercare le soluzioni :)

(22 Mar '14, 14:42) alevipri alevipri's gravatar image
1

Intendi della domanda, vero? :P

(22 Mar '14, 14:47) dadexix86 ♦♦ dadexix86's gravatar image

ahahah si scusate, errore di distrazione :) correggo subito!

(22 Mar '14, 14:53) alevipri alevipri's gravatar image

L'errore in cui sei incappato è BADSIG (errore nelle chiavi di sicurezza, necessarie per scaricare dai repository i programmi e gli aggiornamenti), proviamo a risolverlo in questo modo. Apri il Terminale e digita i comandi seguenti, uno alla volta:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update

A questo punto, se tutto è andato bene, non dovresti più ottenere l'errore BADSIG.

Ora controlla che i tuoi repository siano corretti confrontandoli con questa risposta: http://chiedi.ubuntu-it.org/questions/15893/problema-installazione-programmi-su-ubuntu

coll. permanente

ha risposto 22 Mar '14, 11:57

alevipri's gravatar image

alevipri
5.5k2479

modificato 22 Mar '14, 12:46

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

ho provato il primo metodo e mi dice che non trova nessuna chiave affidabile, e invece sul metodo postato dall' autore della domanda non apre aver risolto il mio problema :( provo a togliere al spunta ai proposed da aggiornamenti software?

(22 Mar '14, 12:07) fuch690 fuch690's gravatar image
1

ok facciamo le cose per bene, dai il comando da terminale:

sudo apt-get update

copia TUTTO qui: http://paste.ubuntu.com/ clicca "Paste!" e metti il link alla pagina in un commento qui sotto. Vediamo di avere una visuale completa sull'errore (mi sa che ce n'è più di uno).

(22 Mar '14, 12:13) alevipri alevipri's gravatar image
(22 Mar '14, 12:18) fuch690 fuch690's gravatar image

allora, prima di tutto aggiorno la Domanda che hai posto con il nuovo messaggio d'errore, usare ancora quello vecchio non serve a nessuno :)

(22 Mar '14, 12:26) alevipri alevipri's gravatar image

hai ragione si vede che sono un novellino XD

(22 Mar '14, 12:28) fuch690 fuch690's gravatar image

Prova nuovamente con i comandi che ti ho dato, vediamo se risolvi il problema

(22 Mar '14, 12:38) alevipri alevipri's gravatar image

sudo cd /var/lib/apt comando non trovato

(22 Mar '14, 12:40) fuch690 fuch690's gravatar image

@alevipri non ho mai capito perché ma cd non può essere dato con sudo ;)

Ho modificato i codici nella risposta, ora potrebbe andar bene :)

(22 Mar '14, 12:44) dadexix86 ♦♦ dadexix86's gravatar image

:O lesson learned, grazie mille!! :)

(22 Mar '14, 12:48) alevipri alevipri's gravatar image

@alevipri @dadexix86 vi ringrazio , apre abbiate risolto il problema, scusate il ritardo ma il pc quando si scalda molto rallenta tanto, a proposito di questo altro problema sapete dove posso postare la questione?

(22 Mar '14, 14:08) fuch690 fuch690's gravatar image
1

Se il problema è risolto per favore accetta la risposta che ti ha aiutato a risolverlo :)

Per l'altro problema, apri un'altra discussione.

(22 Mar '14, 14:10) dadexix86 ♦♦ dadexix86's gravatar image

per il momento di ringrazio, seiete stati tutti molto gentili

(22 Mar '14, 14:14) fuch690 fuch690's gravatar image
1

@fuch690 accetta la risposta solo se hai risolto il problema :)

(22 Mar '14, 14:15) alevipri alevipri's gravatar image

pare abbiate risolto, bravi ragazzi, risposta eccettata

(22 Mar '14, 14:31) fuch690 fuch690's gravatar image

Ogni tanto succede, con i server locali, che ci sia qualche problema di questo tipo, dovuto magari a connessioni lente o non troppo stabili tra l'utente e il server (e spesso la colpa non è di nessuno dei due).

Il mio consiglio per risolvere i due errori che ti si sono presentati è quello di modificare i server ufficiali di Ubuntu da cui scarichi i software con quelli internazionali.

Per farlo, vai in Ubuntu Software Center → Modifica → Sorgenti Software e selezioni "Server Principale".

coll. permanente

ha risposto 22 Mar '14, 12:39

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

1

giusto, anche un semplice cambio di server più risolvere il problema!

(22 Mar '14, 12:42) alevipri alevipri's gravatar image

Il problema deriva dai ppa che hai aggiunto .. puoi risolverlo cancellando i file contenuti in /etc/apt/sources.list.d/

coll. permanente

ha risposto 22 Mar '14, 11:11

Paolo-'s gravatar image

Paolo-
14317

ti ringrazio ora provo, e complimenti per la velocità. ho cancellato tutta la lista file, ma non mia fa salvare poichè dice che ho permessi insufficienti. :(

(22 Mar '14, 11:20) fuch690 fuch690's gravatar image

dai questo comando al terminale → sudo rm -rf /etc/apt/sources.list.d/*

(22 Mar '14, 11:27) Paolo- Paolo-'s gravatar image

dato, ritentato l'aggiornamento e altro giro di errori...

(22 Mar '14, 11:37) fuch690 fuch690's gravatar image

@fuch690 la risposta va accettata quando risolvi il problema

(22 Mar '14, 11:39) alevipri alevipri's gravatar image

posta il nuovo errore ...

(22 Mar '14, 11:46) Paolo- Paolo-'s gravatar image

eh si ok, ma non ho ancora risolto purtroppo

(22 Mar '14, 11:46) fuch690 fuch690's gravatar image

appunto ;)

(22 Mar '14, 11:47) alevipri alevipri's gravatar image

@Paolo-, questo non centra il problema dell'utente. Il repository problematico è saucy-updates, quindi tra quelli ufficiali e presenti di default in Ubuntu. Cancellare i repository esterni aggiunti potrebbe risolvere altri problemi (ma dovrebbero essere cancellati con ppa-purge, in modo da cancellare anche i software installati da lì), ma non il BADSIG di un repository che resterà comunque attivo :)

(22 Mar '14, 12:35) dadexix86 ♦♦ dadexix86's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,715
×277
×170
×1

domanda posta: 22 Mar '14, 11:08

domanda visualizzata: 1,411 volte

ultimo aggiornamento: 23 Mar '14, 11:31

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.