Ciao a tutti da poco ho installato in dual boot con windows 8 la distro 13.10 di ubuntu e come nella 12.04 lts il PC si surriscalda moltissimo fino ad arrivare a 90 gradi, accertati con un programma per la temperatura. Non so da cosa possa dipendere come scheda video utilizzo in coppia sia quella integrata della cpu, una Intel HD 3000 con una radeon HD 7450m che con windows non danno problemi, inoltre anche consumo della batteria é elevato. Da cosa può dipendere?

chiesto 25 Mar '14, 11:34

stardust's gravatar image

stardust
20457

Ciao, stando al Wiki di Ubuntu-it " l'ultima versione del driver proprietario [Amd Catalyst] permette la gestione della grafica ibrida di AMD/ATI".

Per installare i driver proprietari segui questa guida

(25 Mar '14, 11:42) alevipri alevipri's gravatar image

Quindi può dipendere dalla mancanza di driver? Appena posso controllo e vedo come va. Grazie

(25 Mar '14, 11:47) stardust stardust's gravatar image

Scusami non sono stato molto preciso, diciamo che i driver radeon opensource (presenti di default in Ubuntu) non gestiscono la temperatura delle schede grafiche Amd/Ati nella maniera migliore, tanto meno il consumo. Con la prossima versione di Ubuntu (14.04 LTS) la situazione dovrebbe migliorare parecchio, stando ai benchmark del Phoronix, ma staremo a vedere.

Per il momento, il modo migliore per gestre la grafica ibrida Intel/Amd è installare i driver proprietari della Amd. Una volta installati riavvia il pc e apri "Catalyst Control Center" per eseguire il switch tra una grafica Intel e Amd

(25 Mar '14, 11:58) alevipri alevipri's gravatar image

A ok, scusa una domanda la 14.04 esce ad aprile giusto?

(25 Mar '14, 12:04) stardust stardust's gravatar image

Le risposte non servono per chiedere chiarimenti o comunicare i risultati di qualcosa, ma tutto questo può essere scritto tramite i commenti :)

Comunque si, la 14.04 esce il 17 Aprile

(25 Mar '14, 12:07) alevipri alevipri's gravatar image

Comunque prova con i driver proprietari, dobbiamo sapere se il problema era proprio quello o c'è altro.

(25 Mar '14, 12:10) alevipri alevipri's gravatar image
1

Ok grazie tante :) riscriverò non appena avrò installato i driver :)

(25 Mar '14, 12:12) stardust stardust's gravatar image

Ho provato a mettere i driver di AMD ma come risultato ho ottenuto che dopo il login lo schermo diventa nero e nn accade più nulla si blocca li, il puntatore del mouse si muove ma nulla più, ed ora sto re installando ubuntu, cosa può essere accaduto?

(25 Mar '14, 22:03) stardust stardust's gravatar image
1

non era necessario reinstallare Ubuntu, si poteva rimuovere i driver da terminale e saresti tornato alla situazione precedente :)

Comunque, avevi installato i driver tramite "Driver aggiuntivi" vero?

(25 Mar '14, 23:26) alevipri alevipri's gravatar image

Sono andato dove mi hai detto tu e ho selezionato il driver amd... Nn sapevo come fare a rimuoverlo da terminale ci ho provato ma nn ci sono riuscito XD :P

(26 Mar '14, 05:55) stardust stardust's gravatar image

maledettissimi driver proprietari della AMD, anche a me all'inizio davano problemi, sono riuscito ad installartli solo dopo il terzo tentativo.

Ora, le opzioni che hai a disposizione sono queste:
1) fai lo switch tra i driver opensource (ma i driver open radeon scaldano da paura e consumano tantissimo)
2) disabiliti la scheda AMD e utilizzi solo quella integrata Intel (soluzione che funziona, ho provato su un portatile di un amico)
3) riprovi ed installi i driver proprietari della AMD e fai lo switch.

E' tutto scritto qui

(26 Mar '14, 09:31) alevipri alevipri's gravatar image

Personalmente ti consiglio di riprovare ad installare i driver proprietari come ti avevo indicato all'inizio (soluzione 3), quindi riavvia (non spegnere) e vedi se funziona.

Se non funzionasse, allora da schermata nera digita la combinazione Ctrl+Alt+F1 quindi esegui il login (inserisci nome utente e password) e digita i comandi:

sudo apt-get remove --purge fglrx fglrx-amdcccle

sudo apt-get remove --purge fglrx-updates fglrx-amdcccle-updates

ti verrà chiesta la password, quindi riavvia con:

sudo reboot

e sei tornato alla situazione iniziale :)

(26 Mar '14, 09:36) alevipri alevipri's gravatar image

Se proprio non vogliono funzionare, allora passa alla soluzione 2 e appena esce Ubuntu 14.04 ci riproviamo :)

Facci sapere cosa hai deciso di fare e come va...

(26 Mar '14, 09:37) alevipri alevipri's gravatar image

Più tardi magari mentre tornò a casa vedo non so cosa accadrà XD, comunque per ora il PC utilizza la HD 3000 e non la radeon

(26 Mar '14, 10:23) stardust stardust's gravatar image

ah, dimenticavo, prima di fare tutto controlla che Ubuntu sia aggiornato!

(26 Mar '14, 11:10) alevipri alevipri's gravatar image

Faccio sudo apt-get update ??

(26 Mar '14, 11:17) stardust stardust's gravatar image

Ti consiglio di farlo da "Gestore aggiornamenti" :)

Se invece vuoi usare il terminale, i comandi sono (uno alla volta):

sudo apt-get update

sudo apt-get upgrade

quindi un buon

sudo reboot

per riavviare (se aggiorna il kernel bisogna riavviare)

(26 Mar '14, 11:24) alevipri alevipri's gravatar image

Per completare l'aggiornamento e prima del reboot non dimentichiamo anche

sudo apt-get dist-upgrade

altrimenti rischia di essere incompleto ;)

(26 Mar '14, 12:03) dadexix86 ♦♦ dadexix86's gravatar image
1

Ok la dist-upgrade non la ricordavo XD

(26 Mar '14, 12:05) stardust stardust's gravatar image
1

vero, spesso lo ignoro questo comando anche se è importante :)

(26 Mar '14, 12:09) alevipri alevipri's gravatar image

Scusami l'off-topic ma che ne dici ubuntu touch ha una buona gestione come android o é ancora in fase di sviluppo? Quando mi scade la garanzia sul mio nexus 5 volevo provarlo

(26 Mar '14, 12:16) stardust stardust's gravatar image

c'è gente che ne sa molto più di me su questo argomento, crea una nuova domanda e sicuramente qualcuno saprà risponderti

qui concentriamoci sul problema del pc e anche io la smetto di divagare, altrimenti i commenti si fanno troppo lunghi :)

(26 Mar '14, 12:19) alevipri alevipri's gravatar image

Ok grazie appena riesco a fare qualcosa al PC ti faccio sapere ora sono a lezione e torno a casa sta sera.

(26 Mar '14, 12:22) stardust stardust's gravatar image

Allora ieri sera ho fatto l'update e poi ho selezionato i driver di AMD però ha fatto la stesso cosa dell'altra volta funziona tutto tranne la UI dopo aver fatto l'accesso vedevo solo il puntatore del mouse. Per caso ho premuto stampa e funzionava quindi il problema rimane a mio avviso quello dei driver probabilmente errati oggi provo a installarli manualmente scaricandoli dal sito. Sapresti dirmi come ritornare indietro nelle impostazioni dalla shell?

(27 Mar '14, 08:44) stardust stardust's gravatar image

ciao, se vuoi tornare alla situazione iniziale (prima di installare i driver Amd) segui la procedura che ti avevo scritto in un commento qui sopra.

La scheda "Driver aggiuntivi" quante versioni di driver proprietari ti propone? In genere sono presenti, per le nuove schede grafiche Amd, due driver: fglrx e fglrx-update. Hai già provato con entrambi?

(27 Mar '14, 12:16) alevipri alevipri's gravatar image

Se hai provato solo con uno dei due allora adesso proviamo con l'altro:
1) rimuovi i driver che hai installato da terminale come scritto nel commento sopra e riavvia;
2) Driver aggiuntivi --> installa l'altra versione dei driver proprietari
3) riavvia

Se ancora non ti carica Unity, disinstalla anche questi (sempre come scritto nel commento precedente)

(27 Mar '14, 12:17) alevipri alevipri's gravatar image

Le ho provate entrambi come ho già detto prima voglio provare a installarli tramite shell non vorrei che quelli presenti nel PC non siano quelli giusti

(27 Mar '14, 12:22) stardust stardust's gravatar image

tramite shell intendi dire scaricandoli dal sito della Amd e facendo l'installazione manuale? Si può fare, basta che prima rimuovi quelli che hai installato come ti ho scritto prima.

(27 Mar '14, 12:59) alevipri alevipri's gravatar image

ho messo off la scheda video esterna e per ora la temperatura rimane stabile sui 60 cosa abbastanza accettabile XD grazie di tutto se avrò altri problemi riscrivero presto XD

(27 Mar '14, 19:52) stardust stardust's gravatar image

la temperatura si abbassa bloccando la seconda scheda ma ad ogni riavvio torna attiva come prima

(28 Mar '14, 09:09) stardust stardust's gravatar image

come hai disattivato la scheda Amd?

(29 Mar '14, 13:14) alevipri alevipri's gravatar image

Con vgaswitcheroo ma nn rimane off dopo il riavvio

(29 Mar '14, 13:17) stardust stardust's gravatar image

il problema comunque continua a sussistere aspetto la 14 lts

(29 Mar '14, 14:25) stardust stardust's gravatar image

@stardust ho convertito il commento in risposta, dato che hai risolto (ottimo!) :)
Appena puoi accetta la risposta, cliccando il segno di spunta "v" alla sua sinistra.

(20 Apr '14, 10:32) alevipri alevipri's gravatar image

Ciao ieri sera ho installato finalmente la 14.04 e ho installato i driver di AMD e finalmente funzionano nn sparisce la schermata dopo il login e il PC appena avviato misura 40 gradi al max :D finalmente si é risolto tutto grazie tante a presto :)

coll. permanente

ha risposto 18 Apr '14, 18:07

stardust's gravatar image

stardust
20457

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×32

domanda posta: 25 Mar '14, 11:34

domanda visualizzata: 1,187 volte

ultimo aggiornamento: 20 Apr '14, 10:32

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.