Io apro il terminale e inserisco il comando

dpkg -i nomedelfile.deb

e mi esce

dpkg: error processing nomedelfile.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 nomedelfile.deb

ho Backtrack 5 r3

Vi prego, rispondete
T-T

Edit

@Marco ho fatto come hai detto tu ma dà questo problema adesso:

root@bt:~/Desktop# dpkg -i google-chrome-stable_current_amd64.deb
Selecting previously deselected package google-chrome-stable.
(Reading database ... 281081 files and directories currently installed.)
Unpacking google-chrome-stable (from google-chrome-stable_current_amd64.deb) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on gconf-service; however:
  Package gconf-service is not installed.
 google-chrome-stable depends on libasound2 (>= 1.0.23); however:
  Version of libasound2 on system is 1.0.22-0ubuntu7.
 google-chrome-stable depends on libgconf-2-4 (>= 2.31.1); however:
  Package libgconf-2-4 is not installed.
 google-chrome-stable depends on libgcrypt11 (>= 1.4.5); however:
  Version of libgcrypt11 on system is 1.4.4-5ubuntu2.1.
 google-chrome-stable depends on libgdk-pixbuf2.0-0 (>= 2.22.0); however:
  Package libgdk-pixbuf2.0-0 is not installed.
 google-chrome-stable depends on libgtk2.0-0 (>= 2.24.0); however:
  Version of libgtk2.0-0 on system is 2.20.1-0ubuntu2.1.
 google-chrome-stable depends on libnspr4 (>= 1.8.0.10); however:
  Package libnspr4 is not installed.
 google-chrome-stable depends on libnss3 (>= 3.12.6); however:
  Package libnss3 is not installed.
 google-chrome-stable depends on libstdc++6 (>= 4.6); however:
  Version of libstdc++6 on system is 4.4.3-4ubuntu5.1.
 google-chrome-stable depends on libx11-6 (>= 2:1.4.99.1); however:
  Version of libx11-6 on system is 2:1.3.2-1ubuntu3.
dpkg: error processing google-chrome-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for man-db ...
Processing triggers for menu ...
Processing triggers for python-support ...
Errors were encountered while processing:
 google-chrome-stable

chiesto 19 Lug '13, 22:49

xxandreaxx's gravatar image

xxandreaxx
447911

modificato 20 Ago '13, 18:38

enzotib's gravatar image

enzotib ♦♦
14.0k112186


L'errore è abbastanza chiaro, No such file or directory, ovvero il file nomedelfile.deb non esiste, o almeno non nella cartella da cui lanci dpkg.

Assicurati di essere nella cartella giusta e di digitare correttamente il nome del file.

Per cambiare directory devi usare il comando cd /percorso/della/directory/corretta.

Per verificare se il file deb si trova nella directory corrente usa il comando ls *deb e vedi nell'output se compare il nome del file che cerchi.

coll. permanente

ha risposto 20 Lug '13, 00:51

Marco's gravatar image

Marco
1.5k4930

modificato 20 Ago '13, 16:28

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Dovresti usare i commenti per le risposte, non è un forum. A parte questo, se leggi cosa c'è scritto dice:

google-chrome-stable depends on XXXXX however .....

In pratica, il pacchetto che vuoi installare richiede il software XXXXX ma alcuni non sono installati e altri sono installati con una versione troppo vecchia.

Per risolvere devi installare tutti i pacchetti segnalati come mancanti e aggiornare quelli troppo vecchi.

Una domanda: Hai verificato se google chrome è disponibile nei repository di backtrack? Prova ad usare apt-get install per installarlo, se c'è ti risparmi molta fatica.

(20 Lug '13, 01:08) Marco Marco's gravatar image
1

Ora il nome di Backtrack e' http://www.kali.org/ e se backtrack era basata su Ubuntu 10.04 ora dovresti aggiornare la distribuzione o installare una release successiva.

Non sono sicuro, fai riferimento al forum al sito di backtrack, ma e' logico pensare che essendo Ubuntu 10.04 non più manutenuto anche backtrack, lo sia.

E da questi presupposti nascono i tuoi problemi di dipendenze dei pacchetti nell'installazione.

(20 Lug '13, 14:18) marcobra marcobra's gravatar image

@marcobra giusta osservazione, non ricordavo che backtrack fosse diventata kali.

(20 Lug '13, 22:24) Marco Marco's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×168
×16
×6

domanda posta: 19 Lug '13, 22:49

domanda visualizzata: 1,869 volte

ultimo aggiornamento: 20 Ago '13, 18:38

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.