Buongiorno, sono nuovo del forum e spero di trovare una buon'anima che mi possa aiutare.

Con ubuntu 14.04 LTS continuo ad avere il problema della tastiera che credo sia impostata in inglese o cos'altro.

Premetto che ho già controllato le impostazioni "classiche" (chiedo venia ma sono alle prime armi con Linux). La tastiera risulta essere impostata in italiano, lo è prima del login ed è in italiano accedendo con account "ospite".

L'unico modo per utilizzarla correttamente consiste nello switcharla in altra impostazione e poi rimetterla in ita (dal simbolino a fianco dell'orologio) o dare ogni volta il comando setxkbmap it.

Ho creato anche il file "tastiera.desktop" ed inserito lo stesso in applicazioni all'avvio con il suddetto comando (exec....) ma nulla da fare.

Pare che le impostazioni utente caricate dopo il login indichino l'utilizzo di una tastiera differente ma non so proprio dove andare a scovarle.

Grazie anticipatamente a chi mi volesse aiutare.

p.s. Ho già cercato in giro per i forum ma le soluzioni indicate sono quelle già provate senza riultato

chiesto 02 Mag '14, 12:42

ttg159's gravatar image

ttg159
452612

modificato 03 Mag '14, 13:51

alevipri's gravatar image

alevipri
5.5k1479

Io ho avuto un problema simile e ho risolto così: Sono andato nelle impostazioni di sistema, poi su tastiera. Nella finestra che si apre ho cliccato in basso la voce "impostazioni disposizione" e in sorgenti input ho selezionato e rimosso la tastiera inglese lasciando solo quella italiana.

(02 Mag '14, 14:00) gnumark gnumark's gravatar image

stesso problema. bug?

(03 Mag '14, 13:39) blu blu's gravatar image

ciao a tutti

anche io avevo lo stesso problema, ho seguito questa semplice guida e si è risolto tutto

mibware.blogspot.it/2014/05/howto-risoluzione-problema-layout.html

ciao Tommaso

coll. permanente

ha risposto 05 Ago '14, 09:46

tommaso%20gamaleri's gravatar image

tommaso gama...
552

@tommaso-gamaleri: ha poco senso scrivere una risposta per un problema già risolto, tra l'altro proponendo una pagina presa da un anonimo blog.

(05 Ago '14, 09:50) enzotib ♦♦ enzotib's gravatar image

chiedo scusa, ma non mi sembrava che il problema fosse risolto. Nessuna delle indicazioni fornite (anche quella del 02 Mag, 14:00) faceva il caso mio. Confesso anche che non mi sono informato sulla netiquette riguardo le fonti da citare, ma anche se era un anonimo blog forniva la risposta giusta quindi ho pensato che fosse utile pubblicarla. In ogni caso faccio tesoro dell'osservazione e per la prossima volta farò più attenzione.

(05 Ago '14, 10:02) tommaso gama... tommaso%20gamaleri's gravatar image

@tommaso-galameri: tolgo il voto negativo, perché mi accorgo ora che, nonostante la risposta di @fabio sia stata accettata, e questo segnala la soluzione del problema, nei commenti poi si legge che è una soluzione parziale, quindi aveva senso fornire una possibile alternativa.
Contesto però il fatto di pubblicare un link ad un blog semisconosciuto, meglio a questo punto fare propri i comandi e scriverli direttamente nella risposta senza fare riferimento al blog, assumendosene la responsabilità.

(05 Ago '14, 10:10) enzotib ♦♦ enzotib's gravatar image

ok, grazie. Allora in futuro farò sicuramente così. Per questo messaggio mi consigli quindi di modificarlo? posso farlo anche retroattivamente o è meglio lasciare questa discussione a titolo di esempio per altri e aggiungere un nuovo commento?

(05 Ago '14, 10:14) tommaso gama... tommaso%20gamaleri's gravatar image

@tommaso-galameri: tecnicamente puoi modificarlo, ma a questo punto è meglio lasciar stare.

(05 Ago '14, 10:16) enzotib ♦♦ enzotib's gravatar image

Salve ragazzi, ad ogni buon conto un ringraziamento @tommaso-gamaleri che ha dato la soluzione definitiva al mio problema, levandomi una piccola seccatura quotidiana. Il suo animus era collaborativo, nel pieno spirito di un forum come questo. Ti ringrazio e ti saluto. Andrea

(19 Ago '14, 11:38) ttg159 ttg159's gravatar image

@ttg159: a questo punto puoi anche selezionare questa risposta come accettata, invece dell'altra, e magari anche assegnargli un voto positivo.

(19 Ago '14, 11:51) enzotib ♦♦ enzotib's gravatar image

Salve...mi sono appena iscritta.Grazie...grazie grazie...non capisco nulla di ubuntu...mi avete salvato la vita...ho fatto come ha suggerito @tommaso e ho risolto.

(08 Ott '14, 12:57) vittoria vittoria's gravatar image

@vittoria: benvenuta su Chiedi. Siamo lieti che questo servizio sia stato utile, però nel futuro non utilizzare le risposte, queste devono essere utilizzate solo dagli utenti che vogliono proporre una soluzione al problema posto nella domanda principale a inizio pagina. Usa invece i commenti, cliccando sul link aggiungi commento.

(08 Ott '14, 13:12) enzotib ♦♦ enzotib's gravatar image

Salve, anche io ho fatto in quel modo, rimuovendo nelle impostazioni la tastiera inglese e lasciando solo quella italiana, ma spesso continua a cambiarmi, e senza avviso di errori, la tastiera. Per il momento io ho risolto cliccando sulla "it" in alto a destra e selezionando la tastiera italiana anche se è l'unica

coll. permanente

ha risposto 02 Mag '14, 14:51

fabio's gravatar image

fabio
503

Grazie mille per le risposte, innanzitutto.

Non mi ero accorto che fosse sufficiente un click su simbolo in alto, è sicuramente molto più comodo dei miei metodi.

L'aggiunta, la selezione e la successiva rimozione di altra tastiera (ripristinando quella italiana) ho già provato a farle ma non funziona.

Sarei curioso di capire a che punto (tra l'inserimento della pwd di login e la presentazione dell'ambiente "desktop") avviene il caricamento dell'impostazione sbagliata.

A questo punto diventa quasi superfluo, ma se a qualcuno dovesse interessare, faccio presente che la macchina ha personalizzazioni compiz e ubuntu tweak. Viene processato qualche file di inizializzazione che prevale sulle impostazioni di sistema??

Mi scuso per l'inappropriatezza dei miei termini ma conosco ancora poco linux ed il nome dei suoi oggetti.

(02 Mag '14, 18:40) ttg159 ttg159's gravatar image

@ttg159: non usare le risposte, usa i commenti e leggi le FAQ.

(02 Mag '14, 19:04) enzotib ♦♦ enzotib's gravatar image

@ttg159 direi che, se con il metodo suggerito da @fabio si risolve, puoi accettare la sua risposta come corretta (cliccando il simbolo di spunta posto a sinistra della risposta stessa).

Se poi qualcun'altro troverà la soluzione risolutiva, sarai sempre in tempo a spostare la spunta sulla risposta risolutiva ;)

(03 Mag '14, 13:53) alevipri alevipri's gravatar image

Ok, @alevipri, la chiudo così, il problema si può considerare semi-risolto.

Ho cercato in rete indicazioni su cosa processa il s.o. all'avvio ma si trovano guide troppo specifiche o troppo superficiali (mi rimane la curiosità tipica di chi è abituato a smanettare..).

Se qualcuno mi desse un'indicazione su dove documentarmi gli sarei molto grato.

Ringrazio tutti per il prezioso aiuto. Ciao.

(03 Mag '14, 21:21) ttg159 ttg159's gravatar image

Ciao!

Ho letto della risoluzione parziale al tuo problema.

Dai questo comando da terminale e vedi se ti sistema:

sudo dpkg-reconfigure keyboard-configuration

Se non ti setta al prossimo riavvio leggi questa risposta gia' accettata che ho dato qualchew giorno fa proprio qui.

Spero ti aiuti a risolvere definitivamente!

Un saluto!

Questo il link.

coll. permanente

ha risposto 05 Ago '14, 19:48

Juan's gravatar image

Juan
1.5k2632

modificato 05 Ago '14, 19:50

Grazie mille Juan, applicando la soluzione suggerita da Tommaso ho risolto il problema, custodirò il tuo suggerimento per futuri ed eventuali e, sicuramente, servirà anche ad altri. Un saluto. Andrea

(19 Ago '14, 11:42) ttg159 ttg159's gravatar image

con il comando sudo dpkg-reconfigure keyboard-configuration riesco a riconfigurare la tastiera ma ad ogni riavvio è di deconfigurata. grazie per qualsiasi aiuto

coll. permanente

ha risposto 06 Ago '16, 11:12

francofassio's gravatar image

francofassio
202

modificato 06 Ago '16, 11:13

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,598
×434
×80

domanda posta: 02 Mag '14, 12:42

domanda visualizzata: 45,433 volte

ultimo aggiornamento: 06 Ago '16, 11:13

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.