Ciao a tutti, ho un problema con la scheda video intel gma 900 e ubuntu 12.04, quando testo la scheda con glxgears i risultati dimostrano che non si superano i 60 FPS. Questi valori non sono corretti visto che con le precedenti versioni di ubuntu riuscivo ad ottenere valori di quasi 400 fps. Qualcuno ha idea di come potrei risolvere il problema?

ps: L'accelerazione video e' abilitata e la scheda e correttamente riconosciuta.

chiesto 21 Lug '13, 12:15

tenacious--d's gravatar image

tenacious--d
36335

modificato 19 Ago '13, 08:31

enzotib's gravatar image

enzotib ♦♦
14.0k112186


Finalmente ho trovato la soluzione !Il problema di avere un framerate basso è dovuto a Vsync, un'impostazione video che può essere abilitata o disabilitata. Vsync sincronizza i frame rate in base alla frequenza di aggiornamento del monitor. Quando l'opzione VSync è abilitata il frame rate non supera la frequenza di aggiornamento del monitor. (esempio: su un pc con un monitor con una frequenza di aggiornamento di 60 MHZ il framerate non andra oltre i 60 FPS ). Per risolvere il problema bisogna aggiungere le seguenti linee al file ~/.drirc , queste linee disabilitano la sincronizzazione vsync:

<device screen="0" driver="dri2">
      <application name="Default">
          <option name="vblank_mode" value="0" />
      </application>
  </device>

Il file modificato sarà cosi :

<driconf>
  <device screen="0" driver="dri2">
      <application name="Default">
          <option name="vblank_mode" value="0" />
      </application>
  </device>
  <device screen="0" driver="i915">
      <application name="Default">
          <option name="force_s3tc_enable" value="true" />
          <option name="no_rast" value="false" />
          <option name="always_flush_cache" value="false" />
          <option name="stub_occlusion_query" value="false" />
          <option name="always_flush_batch" value="false" />
          <option name="bo_reuse" value="1" />
          <option name="texture_tiling" value="true" />
          <option name="early_z" value="false" />
          <option name="allow_large_textures" value="2" />
          <option name="fragment_shader" value="false" />
      </application>
  </device>
</driconf>

Dopo questa modifica sono passato da un fps di 60 a un fps di 400.

Ciao.

coll. permanente

ha risposto 25 Lug '13, 20:11

tenacious--d's gravatar image

tenacious--d
36335

modificato 25 Lug '13, 20:28

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×185
×128
×32

domanda posta: 21 Lug '13, 12:15

domanda visualizzata: 1,274 volte

ultimo aggiornamento: 19 Ago '13, 08:31

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.