Ho tentato di installare alcuni fonts nel sistema seguendo pedissequamente le istruzioni trovate in un blog. Ho digitato

sudo nautilus /usr/share/fonts

nel terminale e in quella cartella ne ho incollata una piena dei miei fonts. Ho quindi fatto riconoscere al sistema i nuovi fonts digitando

sudo fc-cache -fv

Al primo tentativo è andato tutto bene, entrambi i programmi da me più utilizzati (GIMP e Libreoffice) riportavano regolarmente i font in elenco.

Successivamente, seguendo la medesima procedura, ho aggiunto ulteriori font nella medesima cartella, facendoli sempre riconoscere col comando sudo fc-cache -fv. Ma questa volta i font non vengono individuati e anzi, il GIMP autocrasha nel momento in cui cerco di inserire un qualunque testo su un'immagine, senza restituire alcun messaggio di errore.

Qualcuno di voi ha idea da dove nasca questo conflitto e se sia possibile porvi rimedio? Sarei contento anche solo di ripristinare il sistema alla situazione antecedente, senza i font che ho installato, in modo da non avere grane col GIMP. Grazie

(N.B: Sicuramente c'erano un sacco di font Microsoft, erano più di 500).

Anje76 - Ubuntu 13.10 64bit

chiesto 16 Mag '14, 16:18

anje76's gravatar image

anje76
2012

modificato 16 Mag '14, 16:46

dadexix86's gravatar image

dadexix86 ♦♦
16.9k716161

Quali sono i font?

Dai di nuovo

sudo fc-cache -fv

e riporta l'output su un Pastebin.

(16 Mag '14, 16:47) dadexix86 ♦♦ dadexix86's gravatar image

Tutti i font di windows più una lunga serie di font scaricati da vari siti (principalmente dafont.com).

http://pastebin.ubuntu.com/7473415/

(16 Mag '14, 17:05) anje76 anje76's gravatar image

la cartella FONT è stata qualla copiata per prima, dove ho successivamente aggiunto ulteriori font. Inoltre ho copiato un'ulteriore cartella MIEIFONT con i medesimi font, per vedere se cambiava qualcosa.

(16 Mag '14, 17:09) anje76 anje76's gravatar image

Quale versione di fontconfig usi?

fc-cache -V
(16 Mag '14, 17:15) dadexix86 ♦♦ dadexix86's gravatar image

E posta anche (su pastebin) l'output a terminale di

gimp --verbose

quando crasha :)

(16 Mag '14, 17:17) dadexix86 ♦♦ dadexix86's gravatar image

Rileggi il mio comando: è -V, non -v...

(16 Mag '14, 17:33) dadexix86 ♦♦ dadexix86's gravatar image

Posta l'output di Gimp dal comando che dai (incluso) a quando crasha.

(16 Mag '14, 17:34) dadexix86 ♦♦ dadexix86's gravatar image

Chiedo venia, i caratteri erano piccolissimi. fontconfig version 2.10.93

Non so cosa sia successo, ho riprovato adesso a dare il comando gimp --verbose con GIMP non ancora avviato e.. incredibile, si è avviato, ora non crasha e vede tutti i caratteri. In compenso Libreoffice continua a non vederli.

questo è l'output (sperando di avere seguito correttamente la procedura) http://pastebin.ubuntu.com/7473619/

(16 Mag '14, 17:56) anje76 anje76's gravatar image

Perché inventi i comandi? Chi ti ha detto di lanciarlo con sudo?

È molto pericoloso utilizzare sudo se non sai cosa stai facendo. Evita il più possibile di farlo.

Riporta il tutto lanciandolo normalmente.

(16 Mag '14, 17:58) dadexix86 ♦♦ dadexix86's gravatar image

credevo l'avessi omesso per brevità. La situazione è questa: Se lo avvio con quel comando del terminale pare che funzioni, in realtà crasha lo stesso, dopo qualche minuto. http://pastebin.ubuntu.com/7473686/

(16 Mag '14, 18:15) anje76 anje76's gravatar image

Ti dice quali sono i font problematici. Prova a rimuoverli e riprovare :)

(16 Mag '14, 18:34) dadexix86 ♦♦ dadexix86's gravatar image

PS: metti sempre la stringa con cui lo lanci, per favore :)

(16 Mag '14, 18:34) dadexix86 ♦♦ dadexix86's gravatar image

Grazie per la disponibilità. Ho provato a rimuovere i font DejaVu Sans e Sakkal Majalla, ma GIMP crasha ugualmente. Ho rimosso entrambe le cartelle FONT e MIEIFONT, contenenti tutti i font che avevo copiato, fatto riconoscere tutto col sudo fc-cache -fv, ma nulla si è risolto. Faccio un ultimo tentativo reinstallando GIMP, vediamo se cambia qualcosa.

(17 Mag '14, 18:08) anje76 anje76's gravatar image

Niente da fare, crasha ancora anche dopo una seconda reinstallazione con tutti i componenti aggiuntivi. Che debba ricompilare il kernel?

(17 Mag '14, 18:20) anje76 anje76's gravatar image

In genere la reinstallazione su Linux non serve a nulla. Hai provato cancellando le cartelle di configurazione di GIMP nella tua home?

(18 Mag '14, 23:36) dadexix86 ♦♦ dadexix86's gravatar image

Sì, rimosso pacchetti e configurazioni, eliminato i file, reinstallato gimp: il problema persiste. Devo aver fatto un danno al di sopra delle mie (scarse) capacità di comprensione. Ieri, preso dalla disperazione e frustrazione ho reinstallato Ubuntu passandoci sopra. E da ora starò alla larga da qualunque font.

(19 Mag '14, 11:48) anje76 anje76's gravatar image

Peccato! Sarebbe stato interessante capire dove stava il problema :S

(19 Mag '14, 11:50) dadexix86 ♦♦ dadexix86's gravatar image

C'è un modo per ringraziarti della disponibilità che hai mostrato?

(19 Mag '14, 12:07) anje76 anje76's gravatar image

Ma figurati, è un piacere! :)

(19 Mag '14, 12:09) dadexix86 ♦♦ dadexix86's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×13
×3

domanda posta: 16 Mag '14, 16:18

domanda visualizzata: 734 volte

ultimo aggiornamento: 19 Mag '14, 12:09

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.