ciao, e' possibile eseguire soltanto gli aggiornamenti di sicurezza da riga di comando?

grazie

chiesto 07 Giu '14, 16:55

sacarde's gravatar image

sacarde
7011117


Se non ho capito male la domanda la risposta è :

da terminale:

sudo apt-get update
sudo apt-get dist-upgrade

Ciao

coll. permanente

ha risposto 07 Giu '14, 17:15

infounder's gravatar image

infounder
1052

modificato 07 Giu '14, 20:28

enzotib's gravatar image

enzotib ♦♦
14.0k112186

grazie...

ma con quei comandi aggiorna tutto il sistema...

io volevo aggiornare "solo" gli aggiornamenti di sicurezza

appena mi collego ho:

741 packages can be updated. 294 updates are security updates.

(07 Giu '14, 17:26) sacarde sacarde's gravatar image

ok, ho creto il file ... quindi gli aggiornamenti di sicurezza dici che vengono "tutti" dai repo:

deb http://security.ubuntu.com/ubuntu precise-security

?

cosi aggiornando da quei repo mi da:

277 upgraded, 0 newly installed, 0 to remove and 30 not upgraded

grazie

(07 Giu '14, 20:41) sacarde sacarde's gravatar image

per l'altro comando ho un errore:

sudo apt-get -s dist-upgrade | grep "^Inst" | grep -i securi | awk -F " " {'print $2'} | xargs apt-get install

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

grazie

(07 Giu '14, 20:44) sacarde sacarde's gravatar image

@sacarde: non usare le risposte, usa i commenti.
@infounder: invece le tue potevano anche rimanere come risposte separate, dato che erano soluzioni diverse.

(07 Giu '14, 20:48) enzotib ♦♦ enzotib's gravatar image

@sacarde, mi sà che sono un pò più bravo nel smanettare Ubuntu che seguire le regole delle risposte/commenti eheheheh , ari-faccio ammenda :-)

(07 Giu '14, 21:14) infounder infounder's gravatar image

prova così :

sudo cp /etc/apt/sources.list/ etc/apt/security.sources.list dovresti modificare in modo da contenere solo repository di sicurezza, quindi:

sudo apt-get upgrade-o Dir::Etc::SourceList=/etc/apt/security.sources.list Ciao

coll. permanente

ha risposto 07 Giu '14, 21:34

infounder's gravatar image

infounder
1052

questo mi ritorna da installare:

277 upgraded, 0 newly installed, 0 to remove and 30 not upgraded. Need to get 363 MB of archives.

(08 Giu '14, 11:11) sacarde sacarde's gravatar image

Sono stato appena rimproverato del fatto che non ho usato i commenti. Ma poichè tu hai fatto la stessa cosa ti rispondo da qui. Se il problema è stato risolto assegna un punteggio ;-)

Ciao

coll. permanente

ha risposto 07 Giu '14, 20:47

infounder's gravatar image

infounder
1052

si, si... il comando va bene

quello che lo presuppone e' che tutti gli aggiornamenti di sicurezza provengano "tutti" dai repo: http://security.ubuntu.com/...

p.s. come si fa per assegnare i punti ?

(07 Giu '14, 20:53) sacarde sacarde's gravatar image

ahaha credo sia sufficiente cliccare su manina su , mi sono iscritto oggi ...

(07 Giu '14, 20:59) infounder infounder's gravatar image
  • sulla "manina" non lo accetta

  • su "assegna punti".... quali sono i minimi e i massimi ?

(07 Giu '14, 21:15) sacarde sacarde's gravatar image

per votare una domanda Accanto alla domanda, sono presenti dei pollici rivolti uno verso l'alto e uno verso il basso, con un numero al centro che rappresenta la somma dei voti positivi e negativi. Per votare positivamente una domanda, cliccare il pollice rivolto verso l'alto. In questo modo chi ha posto la domanda guadagnerà 10 punti karma. Per votare negativamente una domanda, cliccare il pollice rivolto verso il basso. In questo modo chi ha posto la domanda perderà 1 punto karma. In caso di errore nella votazione, si ha un giorno per rimuovere il proprio voto.

(07 Giu '14, 21:33) infounder infounder's gravatar image

credevo si valutasse la risposta/e

(08 Giu '14, 13:56) sacarde sacarde's gravatar image

@sacarde: inoltre se la risposta ha risolto il problema dovresti accettarla, cliccando sul segno di spunta sotto il voto. Questo serve anche ad indicare che il post può considerarsi risolto.

(08 Giu '14, 14:34) enzotib ♦♦ enzotib's gravatar image

oppure puoi provare con questa semplice riga di comando :

apt-get -s dist-upgrade | grep "^Inst" | grep -i securi | awk -F " " {'print $2'} | xargs apt-get install Ciao

coll. permanente

ha risposto 07 Giu '14, 21:34

infounder's gravatar image

infounder
1052

questo mi ritorna:

303 upgraded, 6 newly installed, 0 to remove and 447 not upgraded. Need to get 511 MB of archives.

(08 Giu '14, 11:11) sacarde sacarde's gravatar image

suppongo che questa stringa ti ritorni perché gli aggiornamenti sono settati per essere scaricati tutti i giorni. effettivamente se non capisco male la stringa che hai postato, dovrebbe aver aggiornato solo la sicurezza (cioè quello di cui avevi posto il problema)

Ciao

(08 Giu '14, 15:56) infounder infounder's gravatar image

non ho ancora eseguito gli aggiornamenti...

  • la domanda era: gli aggiornamenti di sicurezza... vengono soltanto dai repo di sicurezza ?

  • che vuol dire la riga (quella complicata) ? su cosa si basa il filtro?

grazie

(08 Giu '14, 16:30) sacarde sacarde's gravatar image

la tua domanda era : ""e' possibile eseguire soltanto gli aggiornamenti di sicurezza da riga di comando?"" La risposta è "SI" e ti ho fornito i comandi. Con quei comandi il sistema aggiorna solo la sicurezza tralasciando tutto il resto. Se vuoi aggiornare anche il resto rileggi la prima risposta che ti ho dato.

Ti auguro un buon week end

(08 Giu '14, 16:39) infounder infounder's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×5

domanda posta: 07 Giu '14, 16:55

domanda visualizzata: 807 volte

ultimo aggiornamento: 08 Giu '14, 16:39

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.