Salve a tutti, prima che si presentasse il mio problema ho:

-aggiornato driver nvidia (sudo apt-get install etc..) -rimosso i driver nvidia (sudo apt-get remove) -rimosso i vecchi kernel (sudo apt-get remove) (forse era meglio purge??)

ho kubuntu con disco cryptato con il software presente in kubuntu. accendo il notebook (asus s56c) inserisco la pass per decriptare

compare dopo poco la scritta failed to mount premi s o m etc... se premo 1 volta S poi la seconda volta attendo e si avvia il mio desktop..

sembrerebbe tutto ok.. invece i contenuti dei contenitori "vista cartelle" sono buggate si vedono chiaramente errori grafici e non saprei desciverli meglio

Riesco ad avviare il terminale, non posso usare il mouse, non posso usare la rete wifi non esiste nemmeno l'interfaccia wlan0 e insomma sono un po fregato..

vorrei correggere l'fstab ma ho paura perchè non conosco come il sistema si comporta durante il boot e non so dove mettere le mani.

(ps ho anche ricostruito il xconf o come si chiama infatti il desktop a parte i bug è visulaizzato correttamente)

ad ogni modo il comando

df -h restituisce:

/dev/mapper/kubuntu-root ... /
none ...                     /sys/fs/cgroup
udev ...                     /dev
tmpfs ...                    /run
none ...                     /run/lock
none ...                     /run/shm
none ...                     /run/user

allora risultato di blkid:

/dev/sda1: UUID="aaaa-aaaa"  TYPE="vfat"
/dev/sda2: UUID="aaaaaaaa-aaaa-aaaa-aaaaaaaaaaaa"  SECT_TYPE="ext2" TYPE="ext4"
/dev/sda3: UUID="aaaaaaaa-aaaa-aaaa-aaaaaaaaaaaa" TYPE="crypto_LUKS"
/dev/sdb2: UUID="aaaaaaaaaaaaaaaa"  TYPE="nfts"
/dev/mapper/sda3_crypt: UUID="aaaaaa-aaaa-aaaa-aaaa-aaaa-aaaa-aaaa TYPE="LVM2_member"
/dev/mapper/kubuntu-root: UUID="aaaaaaaa-aaaa-aaaa-aaaa-aaaaaaaaaaaa TYPE="ext4"
/dev/mapper/kubuntu-swap_1: UUID="aaaaaaaa-aaaa-aaaa-aaaa-aaaaaaaaaaaa TYPE="swap"

fdisk -l > /dev/null

WARNING: GPT detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.
WARNING: GPT detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/mapper/sda3_crypt doesn't contain a valid partition table
Disk /dev/mapper/kubuntu-root doesn't contain a valid partition table
Disk /dev/mapper/kubuntu-swap_1 doesn't contain a valid partition table

Ecco l'output di "sudo parted -l"

Numb Start End Size FileSys flags
1 1049kb 200MB 199MB fat32 boot
2 200MB  465MB 256MB ext2
3 456MB  500GB 500GB

.....
.... eccetera (parte del disco di win8)
....

Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/kubuntu-swap_1: 7999MB
Sector Size (logical/physical): 512B/4095B
Partition Table: Loop

1 0.00B 7999MB 7999MB linux-swap(v1)

Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/kubuntu-swap_1: 492GBMB
Sector Size (logical/physical): 512B/4095B
Partition Table: Loop

1 0.00B 492GB 492GB ext4

**Error: /dev/mapper/sda3_crypt: unrecognised disk label**

utilizzo l'ultima release di kubuntu..


GIORNATA DI LAVORO 2 SENZA RISULTATI ANCORA

Ciao a tutti.. allora io oggi sono messo come ieri.. anzi ho peggiorato. Ho installato bubblebee nella speranza che i driver nvidia facessero un miracolo..

Ho aggiornato il kernel alla 3.10.3

Se prima riuscivo a decriptare il disco a saltare il mount di un disco che falliva (tasto s) e attendendo alla schermata successiva riuscivo ad accedere ai file anche se la schermata non era regolare e mancavano driver touchpad e wifi.. Ora appena entro nel grub compare solo l'opzione linux 3.8.0-26-generic (che comunque non ho eliminato) e si blocca l'avvio appena scritto: Loading initial ramdisk ...

ho scaricato una versione di supergrub2 e installata su usb con unetbootin ma per adesso non sono ancora riuscito ad avviare perchè mancano dei file in boot/x86-64efi/...

chiesto 27 Lug '13, 17:42

SebaBerni's gravatar image

SebaBerni
64114

modificato 12 Ago '13, 12:45

rpadovani's gravatar image

rpadovani ♦♦
3.1k51351

Ma tutti questi problemi sono iniziati dopo che hai aggiornato i driver nvidia? Che release di ubuntu usi?

(27 Lug '13, 22:00) nico nico's gravatar image

fdisk, come detto, non supporta GPT. Devi usare parted o gdisk (che è come fdisk ma con supporto alle GPT). Per il fatto di avere un HD criptato non so aiutarti, dato che il pc lo uso solo io ho sempre cercato di evitare tutti i problemi che ne derivano :)

(27 Lug '13, 22:34) dadexix86 ♦♦ dadexix86's gravatar image

Io non capisco come sia possibile che escano fuori tutti questi problemi in una sola volta se dici di aver solo aggiornato e poi rimosso i driver nvidia. Tra l'altro sui notebook asus con grafica ibrida a meno che non usi bumblebee la scheda nvidia non fa proprio nulla, perché di default viene usata quella intel. Tu dici che il mouse non funziona più, non ti vede più la scheda wifi e ti da errore di mount del disco. Boh, l'output di blkid è parecchio strano. Se vuoi un consiglio, fai prima a formattare che tentare di trovare una soluzione.

(27 Lug '13, 22:42) nico nico's gravatar image

SE QUALCUNO HA tempo per aiutarmi mi mandi una mail r4z3n6x6x6xatgmaildotcom

(28 Lug '13, 21:43) SebaBerni SebaBerni's gravatar image

Dopo alcuni giorni chiudo.. mi arrendo immagino che possa essere lunga da seguire una persona solo via mail per risolvere un tale caos.. concludo con i miei pensieri:

alla prossima reinstallazione i driver grafici non li tocco + il kernel nemmeno se l'installazione non mi aggiorna grub e nemmeno funziona più con il vecchio kernel non ha senso..

sinceramente sono un po deluso.. un sistema deve essere affidabile non si può restare senza pc per un aggiornamento.

coll. permanente

ha risposto 29 Lug '13, 21:05

SebaBerni's gravatar image

SebaBerni
64114

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×181
×97
×84
×4

domanda posta: 27 Lug '13, 17:42

domanda visualizzata: 1,520 volte

ultimo aggiornamento: 12 Ago '13, 12:45

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.