Ho fatto l'installazione di ubuntu un po' alla leggera, non conoscendo cosa fossero Secure Boot e UEFI (anche ora non ne so approfonditamente), e quindi senza disabilitare nulla di tutto ciò. Ho comunque un backup dei dati, perciò se dovesse essere l'unica soluzione non avrei problemi a formattare e reistallare da zero.

Ora arriviamo al problema: Ubuntu funziona alla perfezione, ma Windows non è più accessibile dal grub. O meglio: nel grub appare la voce "Windows Boot Manager", ma è locata in sdb, una SSD da 16 giga che in teoria dovrebbe funzionare come una specie di cache per il mio computer (anche qua ne so poco, purtroppo). Quando scelgo questa opzione mi dà subito errore e non parte nulla. Guardando le guide già presenti su questo sito ho letto che consigliao di usare "linux-secure-remix", ma è questo il mio caso? E se sì, cosa devo fare di preciso?

Grazie dell'aiuto.

chiesto 21 Lug '14, 16:56

brisvag's gravatar image

brisvag
18114

Qual è di preciso l'errore che ti viene dato?

(21 Lug '14, 17:12) dadexix86 ♦♦ dadexix86's gravatar image

cannot load image...

(21 Lug '14, 17:34) brisvag brisvag's gravatar image

Ma Windows l'hai ristretto da dentro Windows, prima di installare Ubuntu, sì? O.ò

Se no, è chiaro che dia problemi. Reinstalla Windows, riducilo e poi segui le guide :)

(21 Lug '14, 17:35) dadexix86 ♦♦ dadexix86's gravatar image

Sì, ovviamente prima dell'installazione ho partizionato il disco come si deve. Attualmente ho 10 partizioni: 7 utilizzate da windows, 3 per linux (swap, /, e /home).

(21 Lug '14, 17:48) brisvag brisvag's gravatar image

Ma l'hai partizionato da Windows o da Ubuntu?

Perché devi partizionarlo da Windows.

Comunque direi che quell'errore è un errore di Windows, non dipende dal GRUB. Ti conviene chiedere al supporto Microsoft.

(21 Lug '14, 17:54) dadexix86 ♦♦ dadexix86's gravatar image

Da windows ho ridotto la partizione di windows e creato 300 giga di spazio libero. Dopodichè dal live di ubuntu ho partizionato lo spazio libero in 3 parti come ho scritto prima...

(21 Lug '14, 18:04) brisvag brisvag's gravatar image

Dopo che hai partizionato Windows, hai riavviato ed andava?

Il GRUB dove l'hai installato? Non è che Windows aveva qualche pezzo del bootloader dove hai poi installato GRUB?

(21 Lug '14, 18:06) dadexix86 ♦♦ dadexix86's gravatar image

Si, prima di fare l'installazione di ubuntu windows funzionava anche dopo la riduzione di spazio. Non sono sicuro di dove ho installato il grub: era nell'opzione in basso nell'editor di partizioni del disco live? C'era un menù a tendina che permetteva di scegliere tutte le varie partizioni o il disco in generale. Se si tratta di questo, io ho scelto il disco in generale "dev/sda" come era consigliato. Se invece non era quela opzione, non so rispondere :/

(21 Lug '14, 18:13) brisvag brisvag's gravatar image
1

Allora, se sto capendo bene, hai installato in modalità BIOS su un computer UEFI.

Reinstalla Ubuntu in modalità UEFI, questo è possibile che risolva i problemi.

(21 Lug '14, 18:17) dadexix86 ♦♦ dadexix86's gravatar image

Quindi cosa dovrei fare? Formattare le 3 partizioni di linux, rifare l'installazione e modificare questa opzione da qualche parte? In tal caso, dove si trova? :)

(21 Lug '14, 18:19) brisvag brisvag's gravatar image

È tutto spiegato sulla guida apposita :)

(21 Lug '14, 18:21) dadexix86 ♦♦ dadexix86's gravatar image

Ok, grazie mille :)

(21 Lug '14, 18:22) brisvag brisvag's gravatar image

@dadexix86: se l'installazione è stata fatta così, potrebbe tentare di risolvere con il boot repair come spiegato qui.

(21 Lug '14, 18:27) enzoge enzoge's gravatar image
1

È quello che pensavo di fare (nel frattempo infatti stavo masterizzando l'iso su un cd), e se non dovesse funzionare proverò con il consiglio di dadexix86!

(21 Lug '14, 18:36) brisvag brisvag's gravatar image

Il mio sistema non riesce a fare boot da CD! lo seleziono come prima opzione per il boot, esce nuovamente il logo "samsung" e poi mi restitusce il grub come niente fosse... :/

(21 Lug '14, 18:44) brisvag brisvag's gravatar image

Usa una chiavetta, è molto meglio. E hai impostato il BIOS per l'avvio Legacy o UEFI?

(21 Lug '14, 18:45) dadexix86 ♦♦ dadexix86's gravatar image

Non ho impostato nulla di diverso da prima, non so nemmeno dove trovare questa opzione :/ Ad ogni modo penso che Il problema non si risolverà in nessuno dei due modi che mi avete proposto, perchè verso il fondo della guida di cui mi avete passato il link c'era una serie di modi per verificare il tipo di installazione di ubuntu. Inserendo:

dmesg | grep "EFI v"

in un terminale ho ricevuto questo output:

[ 0.000000] efi: EFI v2.31 by Phoenix Technologies Ltd.

il che teoricamente vuol dire che ubuntu è installato correttamente in modalità UEFI. Oppure ho capito male?

(21 Lug '14, 18:50) brisvag brisvag's gravatar image

Guarda anche di disabilitare il Secure Boot.

(21 Lug '14, 18:50) enzoge enzoge's gravatar image
1

EDIT: scusami errore mio, lì dice che basta l'ultima.

(21 Lug '14, 18:54) dadexix86 ♦♦ dadexix86's gravatar image

Penso che il problema stia nel fatto che il grub non sia dove dovrebbe essere.

(21 Lug '14, 18:54) enzoge enzoge's gravatar image

La live di Secure Remix sul mio PC si avvia con il Secure Boot disabilitato ed in modalità Legacy come il ripristino di Windows.

(21 Lug '14, 19:01) enzoge enzoge's gravatar image

@brisvag: per favore per le comunicazioni non usare le risposte, usa i commenti.

(21 Lug '14, 19:07) enzoge enzoge's gravatar image

Ho disabilitato il secure boot, impostando "os mode selection" in modo che ci fossero sia uefi che csm (non vorrei sbagliare sigla, non ricordo bene quale fosse scusate :/)... Ora finalmente ha loggato da cd!

Se faccio il boot repair come da guida alla fine mi dice che effettivamente il mio ubuntu e stato installato in modalit' legacy, e che potrei voler continuare dopo aver cambiato in modalit' uefi... a questo punto quindi lo devo ignorare e proseguire con il boot-repair, giusto?

scusate ma la live ha la tastiera inglese e non ho voglia di cambiare xD

(21 Lug '14, 19:09) brisvag brisvag's gravatar image

Se ti dice che è installato Legacy, passalo a UEFI.

(21 Lug '14, 19:13) dadexix86 ♦♦ dadexix86's gravatar image

Ma quindi devo formattare la partizione di ubuntu e reinstallarlo da zero seguendo la guida http://wiki.ubuntu-it.org/Installazione/UEFI? o e' possibile come dici tu 'passarlo' a UEFI?

(21 Lug '14, 19:20) brisvag brisvag's gravatar image

Mi sono accorto di aver detto una cavolata, scusate. Non dice che ubuntu e' installato come legacy, ma che il boot del mio pc e' impostato in modalita' legacy... immagino che questo sia modificabile da bios semplicemente, o sbaglio?

(21 Lug '14, 19:23) brisvag brisvag's gravatar image
1

Se è impostato in Legacy, un sistema UEFI non parte (e viceversa).

Secondo quanto detto da @ilgallinetta dovrebbe essere possibile passarlo da Legacy a UEFI seguendo la guida sopra :)

(21 Lug '14, 19:25) dadexix86 ♦♦ dadexix86's gravatar image

@brisvag: è difficile, per poterti aiutare dandoti delle certezze bisognerebbe essersi trovati nelle tue stesse condizioni. Qui ora si tratta di fare dei ragionevoli tentativi che possono essere fatti solo partendo dal presupposto che tu hai tutte le copie per il ripristino a nuovo del sistema.

Per intuizione posso dirti che se metti il pc in modalitè UEFI Secure Remix non si avvia, pertanto al tuo posto procederei mettendo Grub nella partizione EFI, generalmente sda2 e poi, fatta la riparazione, rimetterei il pc in UEFI, lasciando il secure boot disabilitato.

(21 Lug '14, 19:28) enzoge enzoge's gravatar image

Sembra invece che la soluzione fosse molto più semplice, anche se non me la spiego molto... Ho riavviato per entrare nel bios e modificare le opzioni del boot. Ho quindi lasciato "Secure boot" su "disabled", per poi mettere "os mode selection" su solo "UEFI"... Poi giusto per provare ho scelto Windows Boot Manager nel grub e ora vi sto scrivendo da windows... Per quanto ne so forse funzionava anche con l'opzione prima, e forse l'unica cosa da fare era disabilitare il secure boot!

(21 Lug '14, 19:34) brisvag brisvag's gravatar image

Possibile! Ubuntu va ancora?

(21 Lug '14, 19:36) dadexix86 ♦♦ dadexix86's gravatar image

Si @dadexix86, sono d'accordo con te. Prima ripara il con il Boot Repair in modalità legacy e una volta riparato passa alla modalità UEFI. A me così ha sempre funzionato, se non funziona, probabilmente c'è dell'altro dovuto ai troppi tentativi ed in questo caso, megli reinstallare tutto.

(21 Lug '14, 19:38) enzoge enzoge's gravatar image

Sì, ora sono su ubnutnu di nuovo e funziona perfettamente! Direi che il problema è risolto allora... grazie mille dell'aiuto!

(21 Lug '14, 19:41) brisvag brisvag's gravatar image

Ok, allora per favore scrivi una risposta e accettala, così che la domanda venga segnata come risposta :)

(21 Lug '14, 19:43) dadexix86 ♦♦ dadexix86's gravatar image

@brisvag: no non è così perchè con il Secure Boot in funzione Ubuntu non parte, parte solo Windows e questo non era davvero il tuo caso.

Per evitare che altri possano essere tratti in inganno, preferisco immaginare che tu sia stato più distratto nella riparazione del boot, anzi, ne sono quasi certo. :)

(21 Lug '14, 19:44) enzoge enzoge's gravatar image

scusate ho lo stesso identico problema e non riesco a risolvere , mi date una mano grazie anticipate .

(21 Gen '17, 11:42) odrareg odrareg's gravatar image

La soluzione alla fine è stata piuttosto semplice: bastava disabilitare il Secure Boot da bios, impostando "os mode selection" su solo "UEFI". In questo modo sono riuscito ad entrare sia in windows8 che in ubuntu senza problemi.

coll. permanente

ha risposto 21 Lug '14, 20:19

brisvag's gravatar image

brisvag
18114

modificato 21 Lug '14, 20:33

@brisvag: una risposta, per di più accettata, presuppone la spiegazione di ciò che si deve fare per risolvere il problema e sopratutto, che quanto suggerito funzioni. Pertanto, per favore correggila scrivendo ciò che hai fatto, diversamente da quanto ti è stato suggerito, per risolvere il problema posto con la domanda.

(21 Lug '14, 20:28) enzoge enzoge's gravatar image

Ah, ok, d'accordo :)

(21 Lug '14, 20:31) brisvag brisvag's gravatar image

@brisvag, scusa se te lo dico ma le cose non possono essere andate come dici nella risposta perché se fosse dipeso dal Secure Boot attivo serebbe successo che:

l'installazione di Ubuntu 14.04 non si sarebbe neppure avviata;
contrariamente a quanto dici nella domanda, il Secure Boot avrebbe permesso l'avvio di Windows e non quello di Ubuntu.

Credo invece:

che tu abbia installato Ubuntu in modalità Legacy con il Secure Boot disabilitato, cosa che attiverebbe l'uso del solo Ubuntu;
che tu abbia riparato il boot posizionando Grub con l Boot Repair di Sicure Remix;
che dopo l'uso di Boot Repair (che avviene in modalità Legacy) tu abbia riattivato la modalità UEFI.

Quanto affermi nella domanda e nella risposta si contraddice e potrebbe dipendere solamente dal fatto che: o hai un computer particolare che con il Secure Boot attivo abilita Ubuntu e disabilita Windows8, o non ricordi esattamente la sequenza delle operazioni che hai svolto. Credo che risposte così sia meglio non darle, e tantomeno accettarle.

(22 Lug '14, 07:25) enzoge enzoge's gravatar image

@brisvag: naturalmente è possibile che io non abbia capito ne la domanda ne la risposta, cose che magari ad altri risultano chiare, le trovano corrette. In questo caso se mi fate sapere dove sbaglio, mi scuso e vi ringrazio anticipatamente.

(22 Lug '14, 07:39) enzoge enzoge's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,662
×136

domanda posta: 21 Lug '14, 16:56

domanda visualizzata: 1,420 volte

ultimo aggiornamento: 23 Gen '17, 06:43

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.