Salve a tutti! Premetto che sono un nuovo utente e sto utilizzando Linux Mint 14 Mate ma dato che Ubuntu e Mint si assomigliano ho preferito fare qui la domanda visto che è un forum molto frequentato.

Allora da giorni sto cercando di installare rpm ma mi restituisce sempre dipendenze non soddisfatte dando "sudo apt-get install rpm"

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
rpm : Dipende: librpm2 (>= 4.9.0) ma non sta per essere installato
Dipende: librpmbuild2 (>= 4.9.0) ma non sta per essere installato
Dipende: librpmsign0 (>= 4.9.0) ma non sta per essere installato
Dipende: rpm-common (= 4.9.1.1-1ubuntu0.2) ma la versione 4.10.0-4ubuntu0.2 sta
per essere installata
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

Devo dire che qualche mese fa avevo modificato il file sources.list sostituendo 'quantal' con 'precise' visto che ogni volta che davo apt-get update restituiva Error 404: not found

Consigli?

Grazie in anticipo!

chiesto 03 Ago '14, 20:17

Plinto's gravatar image

Plinto
10111

@Plinto: per regolamento qui si trattano solo argomenti riferiti ad Ubuntu e alle sue derivate.

(03 Ago '14, 20:57) enzoge enzoge's gravatar image

@ilgallinetta: chiedo scusa per aver violato il regolamento; ma davvero non potete darmi una mano in fondo la norma a cui ti riferisci è solo per evitare discussioni che sfociano in insulti o comunque qualcosa che possa disturbare gli utenti di questo forum.

(03 Ago '14, 21:51) Plinto Plinto's gravatar image

non va perchè semplicemente, è come se te vorresti installare un .exe di windows su ubuntu e derivate, prova a cercare l equivalente cioè il .deb o provare a convertire l rpm in deb con il programma "spero di ricordare bene" "alien"

Ciao

(03 Ago '14, 23:06) Davide_74 Davide_74's gravatar image

L'errore è probabilmente dovuto al fatto che tu hai mischiato i repository di precise (12.04) con quelli di quantal (14.04).
Quello che ricevevi era normale, in quanto Ubuntu 12.10 ha terminato il supporto da tempo, e quindi i repository sono stati rimossi.

Per poter continuare ad usarlo dovevi cambiare i repository in quelli presenti su old-releases.ubuntu.com, in modo da poter continuare ad usare apt.
Dopo averli cambiati prova a vedere se funziona tutto, ma in caso ci siano conflitti bisognerà o cercare di risolverli o reinstallare.

coll. permanente

ha risposto 03 Ago '14, 23:26

pietroalbini's gravatar image

pietroalbini ♦♦
3.1k2947

Ciao! Prima di tutto grazie, ma come devo fare per cambiare i repository da quel sito?

(04 Ago '14, 10:30) Plinto Plinto's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×90

domanda posta: 03 Ago '14, 20:17

domanda visualizzata: 981 volte

ultimo aggiornamento: 04 Ago '14, 10:30

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.