Ciao a tutti, ho questo problema quando faccio apt-get upgrade, come potrei risolvere?

    Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libdbusmenu-qt2:i386 : Dipende: libqtcore4:i386 (>= 4:4.7.0~beta1) ma non è installato
 libqt4-dbus:i386 : Dipende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.8+elementary5~ubuntu0.2.1) ma non è installato
 libqt4-declarative:i386 : Dipende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.8+elementary5~ubuntu0.2.1) ma non è installato
 libqt4-network:i386 : Dipende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.8+elementary5~ubuntu0.2.1) ma non è installato
 libqt4-script:i386 : Dipende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.8+elementary5~ubuntu0.2.1) ma non è installato
 libqt4-sql:i386 : Dipende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.8+elementary5~ubuntu0.2.1) ma non è installato
 libqt4-sql-mysql:i386 : Dipende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.8+elementary5~ubuntu0.2.1) ma non è installato
 libqt4-xml:i386 : Dipende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.8+elementary5~ubuntu0.2.1) ma non è installato
 libqt4-xmlpatterns:i386 : Dipende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.8+elementary5~ubuntu0.2.1) ma non è installato
 libqtgui4:i386 : Dipende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.8+elementary5~ubuntu0.2.1) ma non è installato
 libqtwebkit4:i386 : Dipende: libqtcore4:i386 (>= 4:4.8.0~) ma non è installato
 qt-at-spi:i386 : Dipende: libqtcore4:i386 (>= 4:4.8.0) ma non è installato
 skype:i386 : Dipende: libqtcore4:i386 (>= 4:4.7.0~beta1) ma non è installato
 sni-qt:i386 : Dipende: libqtcore4:i386 (>= 4:4.7.3-1ubuntu3~) ma non è installato
E: Dipendenze non trovate. Riprovare usando -f.

chiesto 04 Ago '14, 01:13

Skar3's gravatar image

Skar3
924411

modificato 04 Ago '14, 01:14


Ciao!

Che distro usi?

In generale basta dare, come indicato dal terminale (-f)

Apri il teminale e dai questi 2 comandi (Puoi fare copia incolla)

sudo apt-get clean && sudo apt-get autoclean && sudo apt-get autoremove && sudo apt-get install -f

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

Controlla che non "scriva" più problemi ed in caso hai risolto ;)

Juan

coll. permanente

ha risposto 04 Ago '14, 13:29

Juan's gravatar image

Juan
1.5k2632

modificato 04 Ago '14, 15:26

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Ciao, uso Elementary OS (Ubuntu 12.04), niente, sempre stessi errori, tutto nasce dal fatto che ho disinstallato skype, ora quando provo a reinstallarlo succede tutto questo

(04 Ago '14, 13:36) Skar3 Skar3's gravatar image

Cancella la cartella di .skype nella home ~/.skype Cancella il file skype in /usr/bin/skype (ovviamente con sudo) Prova a ridare sudo apt-get install -f poi sudo apt-get update cosa ti dice il terminale? Come hai disinstallato skype?

(04 Ago '14, 13:41) Juan Juan's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×32

domanda posta: 04 Ago '14, 01:13

domanda visualizzata: 1,320 volte

ultimo aggiornamento: 04 Ago '14, 15:26

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.