Hello World.

Vado a spiegare il mio problema:

Ho comprato un ssd samsung 840 evo, prima di fare la migrazione (con software samsung allegato) ho formattato la partizione contenente Ubuntu 14.04 e quella contenente un'altra distro linux (usavo grub 2.02 per entrambe sebbene l'altra distro di default avesse grub legacy), poi ho fatto un ripristino di fabbrica al pc (os nativo windows 7, modello: ASUS A55V).

La migrazione è andata bene... Windows funziona perfettamente, così mi decido a installare le altre due distro linux come fatto in precedenza con disco rigido meccanico prima kali senza installare il suo grub e poi ubuntu con la prospettiva di fare un update di grub da ubuntu per trovare e mettere in lista tutti e tre gli OS... sottolineo che quando l'ho fatto in precedenza è filato tutto liscio.

Appena installato kali e prima di installare ubuntu noto una voce di boot dal BIOS di nome "ubuntu". Lì per lì ho pensato che reinstallato ubuntu quella voce sarebbe andata sovrascritta dal nuovo grub così, dopo due tentativi falliti di eliminarla dal BIOS, decido di ignorarla e procedere installando ubuntu.

Risultato: parte solo windows boot loader e se faccio partire dal BIOS la voce ubuntu mi viene fuori la BASH-like da cui non riesco a far partire niente.

Ho già seguito questa guida ma diversi comandi mi restituiscono errore

EDIT:

Durante l'installazione ubuntu mi ha chiesto (non l'aveva mai fatto prima... e l'ho installato su almeno sei macchine diverse) di creare una partizione BOOT Reserved perchè il mio hard disk è partizionato GPT... io l'ho fatto, dico la verità, seguendo quello che mi ha chiesto ubuntu (farla da 1 MB) senza sapere cosa volesse dire esattamente... mea grandissima culpa in questo

chiesto 06 Ago '14, 17:54

lillo8919's gravatar image

lillo8919
2464815

modificato 06 Ago '14, 18:09

1

@lillo8919: cortesemente potresti foenire qualche dettaglio in più sul PC e sul suo Bios, se UEFI o no e se sì, perché prima hai installeto Ubuntu in Legacy?

(06 Ago '14, 18:40) enzoge enzoge's gravatar image

ciao, sì certo

ASUS A55V, Bios American Megatrends version 305 (no UEFI), intel core i7 a 2,30 GHz, memoria 4+4 gb... l'ssd è da 500 gb...

in che senso in Legacy?

(06 Ago '14, 18:53) lillo8919 lillo8919's gravatar image

ok... credo sia colpa del partizionamento GPT che conserva tutte le info di boot in una partizione normale piuttosto che in una non formattata o nascosta... ma allora perchè il fantasma del vecchio GRUB mi perseguita?

(07 Ago '14, 12:32) lillo8919 lillo8919's gravatar image

Dando il comando da cd live

fdisk -l

Mi segna come partizione di boot sda4, partizione in cui era installato ubuntu sul disco meccanico ma che ora non esiste più...

(07 Ago '14, 16:52) lillo8919 lillo8919's gravatar image

Sempre da cd live ho provato

 find /boot/grub/stage1

Come output ho sda1... ma non è possibile, sda1 è la partizione di ripristino windows... A questo punto non capisco più niente... proverei a reinstallare ma ho il sospetto che non servirebbe a niente finché ho quella voce nel BIOS che non riesco a togliere con l'opzione elimina voce del suddetto

(07 Ago '14, 18:07) lillo8919 lillo8919's gravatar image

Usa Boot Repair per riparare i problemi di boot con UEFI (che devi installare in quanto hai partizionato in GPT).

(07 Ago '14, 21:29) dadexix86 ♦♦ dadexix86's gravatar image

@dadexix86 ho fatto come hai detto e funziona tutto, grazie (se trasformi in risposta il tuo commento, la accetto)...

@ilgallinetta grazie mille anche a te... grazie al tuo commento mi sono accorto di una mia mancanza tecnica importante... pensavo che EFI e Legacy fossero lo stessa cosa, infatti li chiamavo entrambi EFI... pollicione in su per te :)

(09 Ago '14, 14:02) lillo8919 lillo8919's gravatar image

Usa Boot Repair per riparare i problemi di boot con UEFI (che devi installare in quanto hai partizionato in GPT).

coll. permanente

ha risposto 09 Ago '14, 14:04

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

modificato 09 Ago '14, 14:06

grazie ancora... ero disperato... mi sentivo condannato ad utilizzare solo win :)

(09 Ago '14, 14:15) lillo8919 lillo8919's gravatar image

Prego, alla prossima! :)

(09 Ago '14, 14:19) dadexix86 ♦♦ dadexix86's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×27

domanda posta: 06 Ago '14, 17:54

domanda visualizzata: 1,731 volte

ultimo aggiornamento: 09 Ago '14, 14:19

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.