Salve, dopo aver installato ubuntu 13.04 tramite unetbootin a fianco a win xp home (preinstallato)all'avvio non mi chiede quale sistema avviare e, dopo circa 20 secondi in cui il monitor mi dice "Mod non ottimale, Modalita' consigliata 1280x1024 60 Hz" parte in automatico ubuntu. Voglio tornare a Xp come faccio? Aiuto sono disperato!

chiesto 30 Lug '13, 14:24

mikiamomiki's gravatar image

mikiamomiki
9111

modificato 29 Ago '13, 12:10

rpadovani's gravatar image

rpadovani ♦♦
3.1k51351


Usare unetbootin non è la procedura indicata per fare dual boot, ti bastava seguire le indicazioni nel normale installer di ubuntu.

Per risolvere il ruo problema comunque devi reinstallare il bootloader di XP (ntldr) inserendo il disco di installazione ed entrando nella console di ripristino.

Una volta li digita i seguenti comandi:

bootcfg /rebuild

fixboot

fixmbr

Riavvia e dovrebbe partire.

Tieni presente che questo non disinstallerà ubuntu. Se vuoi accedere ad entrambi gli OS invece di reinstallare il bootloader di XP devi reinstallare quello di ubuntu, grub, che ti permetterà di accedere ad entrambi gli OS. Il come fare questo dipende da come hai installato il sistema. Meglio se ci scrivi come è partizionato il disco.

coll. permanente

ha risposto 30 Lug '13, 14:42

Marco's gravatar image

Marco
1.5k4930

Grazie Marco, ora procedo con il tuo prezioso consiglio e vedo cosa riesco a fare.

(30 Lug '13, 14:49) mikiamomiki mikiamomiki's gravatar image

ho seguito alla lettera il consiglio e ora mi dice "A disk read error occurred" sto iniziando a preoccuparmi sul serio...

(30 Lug '13, 15:19) mikiamomiki mikiamomiki's gravatar image

scusami ma come hai ripristinato l'avvio di xp?

(30 Lug '13, 15:22) dxgiusti dxgiusti's gravatar image

ho inserito un disco di installazione xp dalla console di ripristino ho scelto R ho scelto a quale installazione di windows accedere dopodiche' ho eseguito i 3 comandi che mi sono stati consigliati all'inizio...e adesso la situazione e' ancora peggio di prima.

(30 Lug '13, 15:35) mikiamomiki mikiamomiki's gravatar image

con il disco di avvio di xp, apri la prompt di comando e dopo C:> scrivi: fixmbr, al termine sempre dopo C:> scrivi: fixboot, quindi terminato:C:>exit. ora riavviando partirà solo xp. se non succede la situazione è più grave di quella rappresentata. non so perchè ma non mi prende lo splash anche se lo digito. quindi nella prompt sarà: C:splash alto sx>

(30 Lug '13, 15:44) dxgiusti dxgiusti's gravatar image

ho fatto esattamente cosi' ragazzi non ditemi che non c'e' soluzione...e l'errore e' sempre lo stesso.

(30 Lug '13, 15:56) mikiamomiki mikiamomiki's gravatar image

quello è il modo. allora da ubuntu con gparted, fai una schermata del tuo disco e postala, almeno sappiamo di cosa parlare.

(30 Lug '13, 16:09) dxgiusti dxgiusti's gravatar image

e come faccio se appena dopo il boot la schermata si blocca con l'orribile frase "a disk read error occurred press ctrl+alt+del to restart"?

(30 Lug '13, 16:18) mikiamomiki mikiamomiki's gravatar image

usa una live di ubu

(30 Lug '13, 16:28) dxgiusti dxgiusti's gravatar image

mi e' rimasta la sola possibilita' dell'avvio di ubuntu da usb con unetbootin, a questo punto quale voce mi conviene scegliere tra le varie: - try ubuntu - install ubuntu o altro? Grazie per la pazienza...

(30 Lug '13, 16:29) mikiamomiki mikiamomiki's gravatar image

se non sbaglio con unetbootin all'avvio alla prima schermata dai invio e basta. caricherà il sistema in live

(30 Lug '13, 16:30) dxgiusti dxgiusti's gravatar image

non mi e' concesso di postare immagini in quanto non ho abbastanza crediti...ho eseguito gparted e la situazione mi sembra disastrosa. Provo a scrivere il risultato.

(30 Lug '13, 16:35) mikiamomiki mikiamomiki's gravatar image

hai cancellato xp? posta il risultato ( copia/incolla) di : fdisk -l

(30 Lug '13, 16:39) dxgiusti dxgiusti's gravatar image

Partition: /dev/sda1, File System: ntfs(boot),status: not mounted; Partition: /dev/sda3 file system: extended, status: busy (a least one logical partition is mounted); Partition: /dev/sda5, file system: ext4, status: not mounted; Partition: /dev/sda6, file system: linux-swap, status: active; Partition: /dev/sda2, file system: fat32, status: not mounted; Spero sia abbastanza comprensibile, io in origine avevo solo due partizioni: la sda1 con xp e sda2 per il ripristino, tutte le altre le ha fatte ubuntu...

(30 Lug '13, 16:56) mikiamomiki mikiamomiki's gravatar image

direi che hai tutto in ordine.proviamo a riscrivere il grub. sempre da ubu in live, guarda : http://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino, e ricordati che il tuo ubu è in dev/sda5

(30 Lug '13, 17:04) dxgiusti dxgiusti's gravatar image

Partition: /dev/sda5, file system: ext4, status: not mounted; questa??

(30 Lug '13, 17:09) mikiamomiki mikiamomiki's gravatar image

si il tuo ubuntu abita in dev/sda5, il resto della scritta è quanto rilevava gparted ( partizione non montata )ed è giusto.

(30 Lug '13, 17:12) dxgiusti dxgiusti's gravatar image

Non capisco questo: montare il resto dei dispositivi con il comando:

sudo mount --bind /dev /mnt/dev sudo mount --bind /proc /mnt/proc sudo mount --bind /sys /mnt/sys

(30 Lug '13, 18:28) mikiamomiki mikiamomiki's gravatar image

Risolto drasticamente:

  1. da live Ubuntu su USB ho lanciato GParted e ho cancellato le partizioni create da Linux;
  2. ho riavviato il PC ed ho caricato le impostazioni di default del BIOS;
  3. ho riavviato con il disco di Windows XP e tramite la console di ripristino ho prima fatto un chkdsk, corretti gli errori ho rifissato l'MBR con fixboot e fixmbr.


Ora Windows XP finalmente si avvia e funziona correttamente. Resta da riallocare la partizione cancellata con GParted, ma questo non è un problema.

Grazie a tutti per l'aiuto in particolar modo a dxgiusti.
Spero di trovare nuovamente supporto nel caso in cui decidessi di riprovarci con Linux. :-)

coll. permanente

ha risposto 30 Lug '13, 22:04

mikiamomiki's gravatar image

mikiamomiki
9111

modificato 29 Ago '13, 14:33

enzotib's gravatar image

enzotib ♦♦
14.0k112186

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×270

domanda posta: 30 Lug '13, 14:24

domanda visualizzata: 3,704 volte

ultimo aggiornamento: 29 Ago '13, 14:33

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.