Salve a tutti, ho installato aMule versione 2.3.1-11 su sistema Ubuntu 14.04 64-bit per qualche giorno tutto ha funzionato bene ora invece quando tento di avviarlo dopo avere caricato la lista server si chiude subito. Per la precisione il terminale mi segnala questo:

@Hall-9000:~$ amule
 2014-08-08 14:02:55: Initialising aMule 2.3.1 compiled with wxGTK2 v2.8.12
 2014-08-08 14:02:55: Checking if there is an instance already running...
 2014-08-08 14:02:56: No other instances are running.
 2014-08-08 14:02:56: ListenSocket: Ok.
 2014-08-08 14:02:56: Caricamento file incompleto da: /home/alessio/.aMule/Temp
 2014-08-08 14:02:56: Tutti i PartFile caricati.
amule: ../../src/XlibInt.c:245: _XPrivSyncFunction: asserzione "dpy->synchandler == _XPrivSyncFunction" non riuscita.
Annullato

Come si risolve? Grazie, ciao.

chiesto 08 Ago '14, 14:13

Hall-9000's gravatar image

Hall-9000
29224

modificato 08 Ago '14, 15:24

enzotib's gravatar image

enzotib ♦♦
14.0k112186

@Hall-9000: il sistema è completamente aggiornato? Vorrei vedere l'output dei comandi

sudo apt-get update 
sudo apt-get -s dist-upgrade

Metti questi output su http://pastebin.ubuntu.com e metti il link risultante in un commento.

(08 Ago '14, 15:32) enzotib ♦♦ enzotib's gravatar image
(08 Ago '14, 17:13) Hall-9000 Hall-9000's gravatar image

P.s. Dopo gli aggiornamenti scaricati e l'esecuzione dei comandi che mi hai chiesto il problema persiste

(08 Ago '14, 17:18) Hall-9000 Hall-9000's gravatar image

@Hall-9000, come vedi hai dei pacchetti da aggiornare, anche se non credo che siano quelli il problema, però prima di fare altro proverei ad aggiornare.
Poi vedo che hai dei PPA, quindi vorrei vedere l'output di

cat /etc/apt/sources.list
cat /etc/apt/sources.list.d/*.list

e poi anche l'output di

apt-cache policy amule

sempre su pastebin.

(08 Ago '14, 17:19) enzotib ♦♦ enzotib's gravatar image

L'applicazione aggiornamenti softwere mi dice che il sistema è aggiornato, posso controllare se è tutto aggiornato in modo più sicuro? Ecco gli output http://paste.ubuntu.com/7989864/ e http://paste.ubuntu.com/7989873/

(08 Ago '14, 18:08) Hall-9000 Hall-9000's gravatar image

L'aggiornamento completo puoi farlo con

sudo apt-get dist-upgrade

però per il resto, a parte un uso eccessivo di PPA, che io personalmente non userei, non vedo niente di strano.

(08 Ago '14, 18:18) enzotib ♦♦ enzotib's gravatar image

Ora è sicuramente tutto aggiornato ma il problema rimane. Cosa sono i PPA e cosa intendi per un loro uso eccessivo? P.s. votare dove? Grazie, ciao.

(08 Ago '14, 18:28) Hall-9000 Hall-9000's gravatar image

@Hall-9000: PPA significa Personal Package Archive, e sono quei repository aggiunti che non fanno parte dell'installazione base. Tu ne hai diversi:

  • GEncFSM
  • Google Earth
  • JDownloader
  • Pkg_Games
  • Ubuntu Tweak
  • Java

Non dico che siano questi il problema, ma tranne alcuni che possono essere considerati abbastanza stabili e compatibili con il sistema, in generale i PPA possono riservare brutte sorprese sulla stabilità del sistema, e come norma generale bisognerebbe limitarsi a quelli realmente indispensabili. Poi è una questione di opinioni.

(08 Ago '14, 18:44) enzotib ♦♦ enzotib's gravatar image

@Hall-9000: poi non ho capito la domanda sul "votare".
Detto ciò non trovo nessun bug di amule con queste caratteristiche in giro, quindi non so che altro consigliarti.

(08 Ago '14, 18:45) enzotib ♦♦ enzotib's gravatar image

Ho capito cosa dici riguardo ai PPA, ti ho chiesto del votare perchè sulle mails di notifica dei commenti ricevuti alla fine c'è sempre un "ricordati di votare sul sito". Grazie, ciao.

(08 Ago '14, 19:11) Hall-9000 Hall-9000's gravatar image

@Hall-9000: io ho fatto solo commenti per capire meglio, senza fornire una soluzione. Se avessi fornito una probabile soluzione avrei scritto non un commento ma una risposta, e quella avresti potuto votarla positivamente o negativamente, e magari anche accettarla come risolutiva. In questo caso non c'è niente da votare.

(08 Ago '14, 19:27) enzotib ♦♦ enzotib's gravatar image

Capito grazie, ciao

(08 Ago '14, 19:30) Hall-9000 Hall-9000's gravatar image

Ciaoa tutti scusate l' intromissione. @hall-9000 hai scritto nella tua domanda che prima funzionava, puoi ricordare se ha smesso dopo un aggiornamento oppure dopo che hai installato qualcosa etc...?

(08 Ago '14, 19:31) Juan Juan's gravatar image

Prova:

  • Cancellare il file mulelock interno alla cartella di ~/.amule/mulelock
    Vedi se parte, oppure:

  • copia le cartelle Temp e Incomig altrove, poi dai da terminale: sudo apt-get purge --remove amule && sudo apt-get install amule

(08 Ago '14, 20:03) Juan Juan's gravatar image

@Juan, il primo tentativo è inutile, perché se leggi bene non si ferma per il lock.
L'altro tentativo effettivamente vale la pena di farlo.

(08 Ago '14, 20:21) enzotib ♦♦ enzotib's gravatar image

Juan ricordo che ha smesso apparentemente senza motivo, non ho installato niente di nuovo e gli aggiornamenti li ho fatti dopo come consigliato da enzotib. Ho provato con la seconda alternativa proposta ma il problema è rimasto, ancora si avvia e si chiude subito dopo.

(09 Ago '14, 11:54) Hall-9000 Hall-9000's gravatar image

Che DE usi? Forse unity? Se puoi, magari lo hai gia' installato, prova con Gnome per vedere se ti da gli stessi problemi. Non ti dico di installarlo se non ce l' hai gia' solo per testare, te lo scrivo perche ho letto un po di problemi simili e molti dipendevano da unity, che poi ti abbia funzionato prima ok. Ma forse un aggiornamento o altro deve esser stato fatto. Oppure e' andato in vacanza :)

(09 Ago '14, 14:02) Juan Juan's gravatar image

Si forse il mulo ha deciso che la carretta se la potevano tirare da soli e se ne è andato! :) Battute a parte ho unity Gnome non lo ho e non penso che farò la prova, comunque io non sono un programmatore ma secondo me il problema è evidente in questi due passaggi dello script che ho postato nella domanda: 2014-08-08 14:02:56: Caricamento file incompleto da: /home/alessio/.aMule/Temp e amule: ../../src/XlibInt.c:245: _XPrivSyncFunction: asserzione "dpy->synchandler == _XPrivSyncFunction" non riuscita. Forse qualcuno più esperto capisce dov'è il problema. Grazie, ciao.

(09 Ago '14, 15:18) Hall-9000 Hall-9000's gravatar image

Auguri! Ciao!

(09 Ago '14, 15:28) Juan Juan's gravatar image

Secondo me il problema sta tutto e solo nel fatto che l'ultima versione di aMule è del novembre 2011.

Il sito è down da tempo indeterminato e non credo che tornerà mai più up. Molti sono migrati dalla rete Donkey ad altre reti.

È normale che nasca qualche incompatibilità tra software così vecchi e sistemi operativi nuovi. È possibile che questa incompatibilità sia stata generata dall'update di alcune librerie esterne su cui aMule si appoggia.

Potresti chiedere al forum temporaneo di supporto (anche lì, più che temporaneo sembra temporaneamente definitivo) [...]

(09 Ago '14, 15:35) dadexix86 ♦♦ dadexix86's gravatar image

[...] Potresti inoltre "risolvere" sulla 12.04.

Nota che la libreria in questione non è più menzionata in nessun pacchetto della 14.04

 $ apt-file search -i XlibInt
 bubbros: /usr/share/games/bubbros/display/pythonxlibintf.py
 fltk1.3-doc: /usr/share/doc/fltk1.3-doc/HTML/Xlibint_8h_source.html
 libx11-dev: /usr/include/X11/Xlibint.h
(09 Ago '14, 15:35) dadexix86 ♦♦ dadexix86's gravatar image

Io non è che lo usassi molto aMule ma ogni tanto mi faceva comodo, quali sono le altre rete a cui ti riferisci e qual'è adesso il mezzo più diffuso per p2p?

(09 Ago '14, 16:45) Hall-9000 Hall-9000's gravatar image

@Hall-9000: non è un argomento di cui parlare qui, una breve ricerca su internet può darti tutte le risposte.

(09 Ago '14, 16:51) enzotib ♦♦ enzotib's gravatar image

Ops, hai ragione! ;)

(09 Ago '14, 17:36) Hall-9000 Hall-9000's gravatar image

Potresti provare a rinominare la cartella .aMule nella tua home e vedere se per qualche strano caso torna a funzionare?

(10 Ago '14, 11:25) dadexix86 ♦♦ dadexix86's gravatar image

Potrei ma è inutile perchè come mi hai fatto notare te il problema penso proprio che sia quella libreria che nella versione attuale manca. Forse non è solo questo il motivo, visto che comunque funzionava, ma di sicuro rinomiare la cartella è inutile. Griazie, ciao.

(11 Ago '14, 12:19) Hall-9000 Hall-9000's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×14

domanda posta: 08 Ago '14, 14:13

domanda visualizzata: 1,306 volte

ultimo aggiornamento: 11 Ago '14, 12:19

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.