Ciao a tutti, La situazione è un po' ingarbugliata spero di di spiegarmi il meglio possibile...

Mi è stato dato un portatile Samsung Ultrabook serie 5 NP530U3C dove c'era installato Ubuntu 14.04 sulla ExpressCache (SSD) da 24GB (più una partizione NTFS dati da 500 GB) per provare a reinstallare in dual boot Win8 e Ubuntu. Il proprietario, non riuscendo a far partire cd/usb per la live di ubuntu o per l'installer di win8 (penso che avendo installato direttamente sulla express cache il boot bypassasse direttamente ad ubuntu), smanettando con il terminale e nautilus, ha cancellato inavvertitamente files del boot, pensando che riavviando e non trovando nulla gli leggesse finalmente cd/dvd o usb.

Risultato: all'avvio il boot legge ma non fa partire ne cd/dvd ne usb ed entra direttamente nell'interfaccia GRUB minimal BASH-like....

Ho controllato il BIOS ed è impostato tutto correttamente per l'avvio di un'eventuale installazione di UBUNTU (Fast Boot disattivato e priorità all'USB o CD/DVD esterno).

Ho provato a smontare il portatile, per togliere l'SSD (penso infatti il problema sia li - mi è capitato altre volte di risolvere così quando il problema era in un HDD), ma da quanto ho capito la ssd è integrata e saldata alla scheda madre... e dal BIOS non è possibile disattivare il device.

Come ultima spiaggia c'è solo l'interfaccia del GRUB2 ma (Causa poca esperienza e ignoranza) non avrei idea se sia possibile avviare da lì la live di ubuntu via USB o DVD. E' possibile quindi dalla sola interfaccia Grub2 riuscire a rimediare?

chiesto 15 Ago '14, 11:34

alessandro-ungaro's gravatar image

alessandro-u...
10111

È strano che parta la USB o il DVD, ma il BIOS è UEFI o Legacy?

(15 Ago '14, 14:23) dadexix86 ♦♦ dadexix86's gravatar image

Posso impostare il BIOS in modalità boot UEFI, CMS o entrambe (disattivando sempre il secure boot). In nessuno dei casi mi fa partire il boot da USB o DVD. Dimenticavo... riesco ad accedere al Setup del BIOS solo da GRUB2 digitando fwsetup, non c'è modo di entrare altrimenti con i tasti funzione nella schermata classica iniziale.

(15 Ago '14, 17:05) alessandro-u... alessandro-ungaro's gravatar image

Hai provato con boot-repair? Sevuoi provarlo lancialo live scaricando la iso dal sito ufficiale.

(15 Ago '14, 18:23) Juan Juan's gravatar image

Purtroppo il problema è che "sembra" che all'avvio il boot non riesca "a fare in tempo" a leggere USB o DVD che sia, rendendo impossibile il lancio di qualsiasi tool. Entra nel giro di 4 secondi diretto nel GRUB. Non so se poi ci sia un comando dal GRUB che mi consenta di far partire un USB con una Live... come scrivevo a dadexix86, addirittura non riesco in nessun modo ad entrare nel BIOS con i tasti funzione, ma solo dal GRUB digitando fwsetup.

(15 Ago '14, 19:00) alessandro-u... alessandro-ungaro's gravatar image

Hai ragione sono io che sono distratto oggi :) Ho detto una cosa senza alcun senso eheh perdonami!! Cmq ci pensero' se mi viene in mente qualcosa scrivo. Buon Ferragosto!!

(15 Ago '14, 19:17) Juan Juan's gravatar image

Figurati :D grazie comunque!

(15 Ago '14, 19:18) alessandro-u... alessandro-ungaro's gravatar image

Quindi il BIOS non ha modalità Legacy? O.ò

Quale scheda madre monti?

(15 Ago '14, 23:20) dadexix86 ♦♦ dadexix86's gravatar image

Ha la modalità cms con la quale ubuntu partiva tranquillamente. Dopo la cancellazione da quanto ho capito dei file di boot all'avvio entra diretto in grub (l'interfaccia minimale con riga . In una precedente installazione su hdd funzionava tutto perfetto. Poi ha avuto la genialità di reinstallare sulla express cache (ssd). Da li rendendosi conto di alcuni problemi ha provato a formattare. Non riuscendo più a far partire la live da USB o DVD, ha smanettato cancellando con nautilus file di boot ed modificando altro. Il risultato è che prima almeno su ubuntu ci entrava .

(16 Ago '14, 07:54) alessandro-u... alessandro-ungaro's gravatar image

Ora invece l'unica cosa eh carica il boot è l'interfaccia minimale di grub2. Le ho provate tutte . Penso rimanga forse solo qualche soluzione da riga di comando da grub (che ignoro), anche perché fisicamente è impossibile togliere la ssd express cache dalla scheda madre. (Dopo controllo che scheda madre e bios è montato. Non ho la disponibilità del portatile in questo momento)

(16 Ago '14, 07:55) alessandro-u... alessandro-ungaro's gravatar image

@alessandro-u... Il BIOS ha possibilita' di avvio da lan? Potresti tentare di connettere un altra macchina tramite cavo lan cross e vedere se riesci a ripristinare i files da li. Non so se sia possibile ma e' l' unica chance che mi viene in mente e che tentare non costa nulla. Ma per farlo devi farti qualche ricerca sul come... ;)

(16 Ago '14, 15:31) Juan Juan's gravatar image

si mi sembra si possa fare. appena provo vi faccio sapere!!

(16 Ago '14, 16:02) alessandro-u... alessandro-ungaro's gravatar image

Spero riesci e' l' unica soluzione che mi e' venuta in mente ;) Ciao e si, fammi sapere...

(16 Ago '14, 16:36) Juan Juan's gravatar image

News con l'avvio da LAN?

(18 Ago '14, 12:05) dadexix86 ♦♦ dadexix86's gravatar image

Ciao @dadexix86, gliel ho consigliato gia' un commento piu' su ;) Era l' unica soluzione che mi e' venuta in mente... Speriamo vada!!

(18 Ago '14, 13:27) Juan Juan's gravatar image

@Juan Sì, ma visto che era ieri chiedevo se aveva provato e se aveva news in merito :)

(18 Ago '14, 13:30) dadexix86 ♦♦ dadexix86's gravatar image

Ah ok scusami mancava la "s" al tuo new(s), pensavo fosse un new commento hahah Anche io sono curioso... :)

(18 Ago '14, 13:33) Juan Juan's gravatar image

Sì, un errore che ho corretto appena me ne sono accorto :)

(18 Ago '14, 13:34) dadexix86 ♦♦ dadexix86's gravatar image

no, niente da fare ... provato in diversi modi ma nulla.

(18 Ago '14, 15:23) alessandro-u... alessandro-ungaro's gravatar image

Il manuale della scheda madre dice qualcosa in merito all'avvio da USB?

(18 Ago '14, 15:35) dadexix86 ♦♦ dadexix86's gravatar image

Se provi a schiacciare qualche tasto di funzione per entrare in modalità provvisoria di Windows (tipo f8 o f5... non quella del bios...) ci entra? anch'io recentemente ho avuto problemi con il boot causa ssd ma ho notato che riuscivo comunque ad entrare in modalità provvisoria di win, magari da li si riesce a fare qualcosina....

(18 Ago '14, 16:23) lillo8919 lillo8919's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,598
×191
×170
×34

domanda posta: 15 Ago '14, 11:34

domanda visualizzata: 5,767 volte

ultimo aggiornamento: 18 Ago '14, 16:23

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.