1
1

Ciao a tutti! Ho appena comprato un DELL XPS15 9530 e ci ho installato Ubuntu 14.04 in dual boot con Windows 8; l'unico problema è che la batteria, che con Windows 8 dura 5 ore utilizzandolo e con lo schermo disativato 11, con Ubuntu mi dura al massimo 3 ore. Qualcuno conosce un pogramma da installare che possa gestire la batteria decentemente?

chiesto 03 Set '14, 11:52

Michi-Pine's gravatar image

Michi-Pine
244202632

Hai una doppia scheda video, magari ATI + Intel?

(03 Set '14, 15:15) dadexix86 ♦♦ dadexix86's gravatar image

Potresti per favore finalmente l'hardware del computer in questione, così da darti suggerimenti mirati?

(04 Set '14, 14:54) dadexix86 ♦♦ dadexix86's gravatar image

Scusa ma non avevo visto il commento. Il pc comunque è quello con 1 TB di HD: http://www.dell.com/uk/p/xps-15-9530/pd

(04 Set '14, 15:38) Michi-Pine Michi-Pine's gravatar image

No, ho installato i driver proprietari della Nvidia, non so se siano compresi...

(04 Set '14, 23:13) Michi-Pine Michi-Pine's gravatar image

Io ti consiglio bumblebee, poi vedi tu :)

(04 Set '14, 23:18) dadexix86 ♦♦ dadexix86's gravatar image

Ok provo ad installarlo e ti faccio sapere...

(07 Set '14, 23:40) Michi-Pine Michi-Pine's gravatar image

Ho scoperto di averlo già installato, perchè è compreso nei driver proprietari Nvidia; il problema è che quando switcho da Intel a Nvidia, mi chiede la password e messa quella esce un popup in cui c'è un divieto senza nulla scritto sopra e tutto rimane com'è...

(09 Set '14, 13:17) Michi-Pine Michi-Pine's gravatar image

Nei driver dei repo è compreso prime, non bumblebee.
Quali driver hai isntallato tu?

(09 Set '14, 14:09) dadexix86 ♦♦ dadexix86's gravatar image

Proprietario Nvidia testato

(09 Set '14, 14:44) Michi-Pine Michi-Pine's gravatar image

Hai installato bumblebee o prime?

coll. permanente

ha risposto 04 Set '14, 16:47

dadexix86's gravatar image

dadexix86 ♦♦
16.9k716161

Finalmente il pc ha una durata della batteria decente (sulle sei ore circa). Alla fine la soluzione più efficacie è stata bumblebee, che permette di switchare tra le due schede grafiche. Ringrazio tutti per l'aiuto

(12 Set '14, 14:54) Michi-Pine Michi-Pine's gravatar image

Unico problema è che non mi fa tornare alla scheda grafica Nvidia, perchè quando la seleziono mi chiede la password e poi esce un pop-up con un divieto, senza nessuna scritta sopra e poi non cambia nula... Il programma che utilizzo è Nvidia X Server Settings

(12 Set '14, 14:58) Michi-Pine Michi-Pine's gravatar image

Nessuno sa come risolvere questo problema?

(13 Set '14, 15:08) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine, dato che il problema è diverso ed anche per mettere meglio in evidenza la questione, è assai meglio che scrivi un'altra domanda con questo specifico problema.

(13 Set '14, 15:10) enzotib ♦♦ enzotib's gravatar image

Potresti postare l'output di

optirun glxinfo
optirun glxspheres

Così vediamo le varie problematiche?

(13 Set '14, 15:12) dadexix86 ♦♦ dadexix86's gravatar image
(13 Set '14, 15:48) Michi-Pine Michi-Pine's gravatar image

Installa mesa-utils e poi ridallo

sudo apt-get install mesa-utils
(13 Set '14, 16:37) dadexix86 ♦♦ dadexix86's gravatar image

il primo comando: http://paste.ubuntu.com/8336053/ e il secondo mi dà lo stesso errore di prima

(13 Set '14, 18:58) Michi-Pine Michi-Pine's gravatar image

Manca tutto il pezzo iniziale a quell'output, guarda ad esempio il mio.

(come regola generale è sempre buona norma postare anche il comando dato oltre all'output)

(13 Set '14, 19:04) dadexix86 ♦♦ dadexix86's gravatar image

Scusa, non avevo notato. Ecco l'output: http://paste.ubuntu.com/8336314/

(13 Set '14, 19:41) Michi-Pine Michi-Pine's gravatar image

La scheda viene attivata senza problemi...

Posta il comando che hai dato per lanciare il gestore nvidia che ti ha dato errore.

(13 Set '14, 20:20) dadexix86 ♦♦ dadexix86's gravatar image

il comando è "sudo nvidia-settings"

(14 Set '14, 00:45) Michi-Pine Michi-Pine's gravatar image

Quel comando non attiva la scheda video dedicata, quindi il programma non può vederla :)

Ogni volta che vuoi lavorare sulla dedicata devi usare optirun.

Purtroppo nvidia setting deve essere lanciato su un'istanza diversa del Server X quando viene usato con optirun (in sostanza da quel che ho capito può esserci solo un desktop per scheda video, ma non ne sono certo). Il comando per lanciarlo è

optirun -b none nvidia-settings -c :8

NB: non ha bisogno di sudo.

(14 Set '14, 01:50) dadexix86 ♦♦ dadexix86's gravatar image

Stesso errore che mi dava prima...

(14 Set '14, 22:53) Michi-Pine Michi-Pine's gravatar image

Metti per favore input e output?:)

(14 Set '14, 23:02) dadexix86 ♦♦ dadexix86's gravatar image

Ti posto l'output del terminale, che non è troncato, dà solo Errore: e poi è vuoto: http://paste.ubuntu.com/8349340/

(15 Set '14, 12:04) Michi-Pine Michi-Pine's gravatar image

Prima di installare bumblebee avevi disinstallato e purgato prime?

Posta

sudo lshw
optirun sudo lshw

e prova se linkando come spiegato qui risolvi il problema di vdpau

ln -s /usr/lib/vdpau/libvdpau_nvidia.so.1 /usr/lib/libvdpau_nvidia.so
(15 Set '14, 12:53) dadexix86 ♦♦ dadexix86's gravatar image

Primo comando: http://paste.ubuntu.com/8350181/ e secondo comando: http://paste.ubuntu.com/8350195/. Linkare non è servito a nulla, però io ho eseguito solo il comando suggritomi da te e non ho guardato il link mandatomi.

(15 Set '14, 14:45) Michi-Pine Michi-Pine's gravatar image

E dopo il comando e il riavvio l'errore è sempre lo stesso?

(15 Set '14, 17:08) dadexix86 ♦♦ dadexix86's gravatar image

Identico...

(15 Set '14, 22:08) Michi-Pine Michi-Pine's gravatar image

Rispondi per favore all'altra mia domanda? Avevi rimosso e purgato prime prima di installare bumblebee?

(15 Set '14, 23:11) dadexix86 ♦♦ dadexix86's gravatar image

Ah no. Scusa ma non avevo letto.
Ho aperto una nuova discussione sul'argomento qui

(16 Set '14, 12:00) Michi-Pine Michi-Pine's gravatar image

per prima cosa, se non l'hai ancora fatto, verifica se ci sono driver propietari da installare

sudo software-properties-gtk

e vedi alla scheda Driver Aggiuntivi, se trovi dei driver consigliati per il tuo Hardware

Prova anche a installare indicator-cpufreq per la gestione della frequenza del processore, in modo da poter impostare l'utilizzo della cpu su "risparmio energetico" o "su richiesta"

sudo apt-get install indicator-cpufreq

una volta installato, lo cerchi nella dash e lo avvii, lo trovi poi nel pannello e si imposta automaticamente all'avvio.

altra cosa che potrebbe essere utile, modificare la gestione della batteria, che di default è sul "tempo" e impostarla sulla "percentuale"

sudo apt-get install dconf-tools

e poi avvia dconf-editor, Alt+F2 e scrivi dconf-editor seguito da invio e segui il percorso org-->gnome-->settings-daemon-->plugins-->power e togli la spunta a use-time-for-policy

inoltre, nella stessa scheda (power) potresti anche modificare le voci percentage-critical e percentage-low che sono impostate molto basse e seguendo quei criteri, la batteria viene sempre portata al minimo, prima di segnalare lo scaricamento e questo potrebbe rovinarla

queste due ultime impostazioni hanno effetto se, come ti dicevo, togli la spunta a use-time-for-policy

coll. permanente

ha risposto 03 Set '14, 12:11

anonimo01's gravatar image

anonimo01
(sospeso)

Avevo già selezionato i driver proprietari ed ho settato use-time-for-policy e gli altri due parametri, ma indicator-cpufreq non parte e se lo do da terminale mi dice " (indicator-cpufreq:6644): WARNING : Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.", cosa posso fare?

(03 Set '14, 12:32) Michi-Pine Michi-Pine's gravatar image

Scusa, lo avevo già installato. Ora che ho fatto tutto ti farò sapere se la situazione è migliorta. Intanto grazie

(03 Set '14, 12:45) Michi-Pine Michi-Pine's gravatar image

Un pacchetto utile è powertop, che aiuta ad individuare cos'è che consuma più energia.
Per esempio si può lanciare il comando

sudo powertop --calibrate --html

per avere un report in formato HTML nella directory corrente.
Inoltre per impostare all'avvio i valori suggeriti da powertop puoi mettere il coda al file /etc/rc.local, prima della riga con exit 0, il seguente comando:

powertop --auto-tune

Attenzione, che questo pacchetto potrebbe impostare la autosospensione di qualche device USB quando non è utilizzati, e questo potrebbe portare allo spiacevole inconveniente di disabilitare anche un mouse USB che sta fermo per un po' e che non supporta in modo corretto la funzionalità di autosuspend.
Se succede questo allora bisognerà aggiungere un'altra riga del tipo

echo  auto >/sys/bus/usb/devices/usb1/power/control

subito dopo la riga indicata prima, e dove il nome del file dipende dal device interessato dal problema.

Un altro pacchetto che potrebbe essere utile per risparmiare energia sui portatili è laptop-mode-tools, anche se pare che nei kernel recenti non dovrebbe essere più necessario, ma una prova potrebbe valere la pena.
La descrizione è la seguente:

Strumenti per il risparmio energetico con alimentazione da batteria/rete
La modalità laptop è una funzionalità del kernel Linux che permette al
proprio laptop di salvare una quantità considerevole di energia, spegnendo
il disco rigido per periodi di tempo più lunghi. Questo pacchetto contiene
gli script in spazio utente necessari per abilitare la modalità laptop.
.
Include il supporto per abilitare automaticamente la modalità laptop
quando il computer funziona con le batterie. Supporta anche varie altre
funzionalità di gestione dell'energia, come l'avviare e il fermare i
demoni a seconda della modalità di uso dell'energia, l'ibernazione
automatica se il livello di carica delle batterie è troppo basso e la
regolazione dell'annerimento del terminale e dello schermo di X.
.
Poiché i laptop-mode-tools fanno uso della funzionalità "Laptop Mode" del
kernel Linux sono utilizzati per risparmiare energia anche su computer
desktop e server.

Anche questo pacchetto imposta di default la autosospensione dei device USB quando non sono utilizzati.
Per ovviare a questa cosa è sufficiente aprire con privilegi di amministratore il file /etc/laptop-mode/conf.d/usb-autosuspend.conf, cercare la riga

AUTOSUSPEND_USBID_BLACKLIST=""

e aggiungere l'ID del device tra le virgolette, così come ottenuto da lsusb.

Infine dei suggerimenti banali, disabilitare il bluetooth e/o il wifi quando non si usano.

coll. permanente

ha risposto 03 Set '14, 15:47

enzotib's gravatar image

enzotib ♦♦
14.0k112186

modificato 03 Set '14, 15:51

Ma Powertop serve solo a monitorare le risorse o si possono anche modificare? Perchè non vedo comandi per fare delle modifiche quando lo utilizzo da terminale.

(03 Set '14, 20:42) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine: se premi il tasto TAB più volte, puoi spostarti sulla pagina Regolazioni, in ogni caso quando è in funzione dovrebbe impostare vari settaggi che secondo lui sono migliori, ma questo si perde quando lo spegni. Con --auto-tune restano anche dopo che lo spegni, ma vanno via al reboot, per questo se lo inserisci in /etc/rc.local imposta i settaggi migliori ad ogni boot.
Dovrebbe essere utile far girare il programma mentre il computer è senza batteria per un po' di tempo (almeno un'oretta) in modo che possa raccogliere un po' di informazioni statistiche.

(03 Set '14, 21:07) enzotib ♦♦ enzotib's gravatar image

Anche utilizzando il pc con Powertop la durata della batteria non supera le 3 ore e 30 minuti; potrebbe essere dovuto al fatto che in Windows quando utilizzo la batteria e non la rete elettrica, esso attiva la dissipazione passiva, mentre in Ubuntu il sistema mi tiene sempre la dissipazione attiva?

(04 Set '14, 14:05) Michi-Pine Michi-Pine's gravatar image

@Michi-Pine senza togliere nulla alle risposte gia' avute, in semplicita' aggiungo che l' illuminazione dello schermo e' la cosa che porta piu' via energia, riducila al minimo a seconda della situazione in cui ti trovi e vedrai durera' di piu'.

Ciao

coll. permanente

ha risposto 04 Set '14, 14:30

Juan's gravatar image

Juan
1.5k2632

Spiegati meglio, su windows la batteria 5h-su ubuntu 3h max, visto il portatile e probabile doppia scheda video, non mi sembra tanto male.

(04 Set '14, 14:44) Webber Webber's gravatar image

A me sembra pessimo.
La mia batteria dura ben di più (ma a quanto pare sono un caso rarissimo) con Ubuntu che con Windows.

(04 Set '14, 15:21) dadexix86 ♦♦ dadexix86's gravatar image

Raga, tutto cio' dipende anche da quanto e' stata usata la batteria e come... Dall' hw che si ha etc... Quindi mi sembra tutto abbastanza relativo riguardo ai tempi della durata. Che pero' per ogni caso, anche se differente, si puo' migliorare con accorgimenti vari :)

(04 Set '14, 15:48) Juan Juan's gravatar image

Il pc ce l'ho da due settimane, per questo mi sembra strano duri "poco"...

(04 Set '14, 16:13) Michi-Pine Michi-Pine's gravatar image

Beh, a le volte le batterie devono fare un rodaggio (Passami il termine) e dopo un po cominciano a funzionare meglio. Comunque hai provato ad abbassare la luminosita', che e' comunque la cosa che porta piu' di tutto vie energie?

(04 Set '14, 16:17) Juan Juan's gravatar image

A me funziona più con Ubuntu che con Windows (ho corretto il commento sopra). Non è un problema di durata "assoluta", ma di durata "relativa".

(04 Set '14, 16:55) dadexix86 ♦♦ dadexix86's gravatar image

@Juan: Ovviamente ho abbassato la lumiosità. @dadexix86: Cosa intendi per durata assoluta e relativa?

(07 Set '14, 12:12) Michi-Pine Michi-Pine's gravatar image

Che non importa quanto dura in sé, importa che dura meno rispetto a Windows.

(07 Set '14, 12:32) dadexix86 ♦♦ dadexix86's gravatar image

Ah, sì certo, perchè non ha senso che con uno funzioni di più e con l'altro meno, significa che ci sono dei settaggi sbagliati su Ubuntu

(07 Set '14, 23:39) Michi-Pine Michi-Pine's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,597
×255
×29

domanda posta: 03 Set '14, 11:52

domanda visualizzata: 4,233 volte

ultimo aggiornamento: 16 Set '14, 12:01

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.