Ciao a tutti. Premetto che ho Ubuntu 14.04 in dual boot con Windows 8.1 e tutto è sempre funzionato perfettamente, fino a qualche giorno fa, quando è sparita la voce Windows dal GRUB di Ubuntu. Entrambi i sistemi operativi funzionano perfettamente e nessuna partizione è stata spostata o modificata, quindi non ho proprio idea di quale sia la causa di questa sparizione. Qualcuno sa aiutarmi?

AGGIORNAMENTO: Ho tentato di ripristinare il GRUB da Live CD, ma quando arrivo all'installazione mi dice che non è presente una patizione di boot nella tabella GPG, anche se in realtà sda1 è di boot, e che quindi senza quella non può andare avanti. Ho letto su vai forum che la soluzione potrebbe essere "rubare" un po' di spazio prima di Ubuntu, ma facendo così non si cancella la partizione? Altra opzione a cui ho pensato è di reinstallare il GRUB sull'HD a stato solido che ha dello spazio non allocato, ma non so come creare una partizione con punto di mount /boot...

chiesto 15 Set '14, 22:48

Michi-Pine's gravatar image

Michi-Pine
244212632

modificato 17 Set '14, 13:07

Prova ad aprire il terminale di Ubuntu e digita:

sudo update-grub

al termine riavvia con:

sudo reboot
(15 Set '14, 23:06) alevipri alevipri's gravatar image

Da terminale: sudo gedit /etc/default/grub e aggiungi "#" all'inizio della seguente linea "GRUB_HIDDEN_TIMEOUT=0" (senza virgolette. In pratica deve essere così: # GRUB_HIDDEN_TIMEOUT=0). Salvi il file, chiudi e da terminale sudo update-grub. Al riavvio, apparirà nel menù di grub anche la voce di Windows. Ciao

(15 Set '14, 23:27) Beppe Beppe's gravatar image

@alevipri: avevo già provato, ma non ha funzionato.
@Beppe: era già settato correttamente il parametro, quindi per ora non è cambiato nulla

(16 Set '14, 11:12) Michi-Pine Michi-Pine's gravatar image

ma se non hai più la voce Windows in grub, come lo avvii Windows ?

(16 Set '14, 11:14) anonimo01 anonimo01's gravatar image

Dal BIOS, modificando l'ordine di BOOT delle partizioni, ma è un po' scomodo...

(16 Set '14, 11:22) Michi-Pine Michi-Pine's gravatar image

hai più Hard Disk o uno solo?

(16 Set '14, 11:30) anonimo01 anonimo01's gravatar image

Uno solo con diverse partizioni

(16 Set '14, 11:59) Michi-Pine Michi-Pine's gravatar image

non ho windows 8 e non so se funziona come su 7 ed Xp, prova ad avviare Ubuntu e reinstalla grub su sda, che sarebbe il disco, non una delle partizioni

Avvia Ubuntu e dai

sudo grub-install /dev/sda

e poi fai l'update di grub

sudo update-grub
(16 Set '14, 12:11) anonimo01 anonimo01's gravatar image

Non è cambiato nulla

(16 Set '14, 12:36) Michi-Pine Michi-Pine's gravatar image

posta anche una schermata di gparted

(16 Set '14, 13:38) anonimo01 anonimo01's gravatar image

La trovi qui

(16 Set '14, 14:36) Michi-Pine Michi-Pine's gravatar image

Prova ad andare qui http://ubuntuforums.org/showthread.php?t=1581099 ed anche qui http://opensource-sidh.blogspot.it/2011/06/recover-grub-live-ubuntu-cd-pendrive.html In pratica ti viene spiegato come reinstallare Grub. (dai un'occhiata al bios per disattivare il "Secure Boot") Ciao

(16 Set '14, 17:32) Beppe Beppe's gravatar image

Il secure boot è già disattivato altrimenti sarebbe stato impossibile installare Ubuntu e ancor meno far partire il GRUB; non c'è un modo meno invasivo per ripristinarlo piuttosto che il live CD?

(16 Set '14, 18:00) Michi-Pine Michi-Pine's gravatar image

Io non sò dirti di più, però posta anche la schermata di Gparted, non solo quell'output

(16 Set '14, 18:24) anonimo01 anonimo01's gravatar image

Ho notato che il comando "sudo fdisk -l" non mi dà tutte le partizioni installate, ma solo i due HD, potrebbe essere che Ubuntu non veda la partizione con Windows? Ma se fosse così perchè da un giorno all'altro è sparita?

(16 Set '14, 19:12) Michi-Pine Michi-Pine's gravatar image

Risolto: in realtà Windows 8 era stato spento con la modalità avvio veloce impostata e di conseguenza era come ibernato e il GRUB non lo vedeva. Grazie a tutti comunque!

coll. permanente

ha risposto 28 Set '14, 17:36

Michi-Pine's gravatar image

Michi-Pine
244212632

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,718
×270
×136
×27

domanda posta: 15 Set '14, 22:48

domanda visualizzata: 1,817 volte

ultimo aggiornamento: 28 Set '14, 17:36

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.