Vorrei avanzare Ubuntu dal 12.04 al 14.04. Cerco di aprire il Gestore Aggiornamenti, ma non me lo apre, dandomi questo errore:

**Impossibile inizializzare le informazioni del pacchetto**
Si è verificato un problema irrisolvibile durante l'inizializzazione delle informazioni del pacchetto.
Segnalare questo bug per il pacchetto «update-manager» e includere il seguente messaggio d'errore:
'E:Il pacchetto linux-headers-3.2.0-67 deve essere reinstallato, ma non è possibile trovarne un archivio.'

Grazie a chi mi aiuterà, sono un principiante

chiesto 17 Set '14, 00:45

AleReferee's gravatar image

AleReferee
45237

modificato 19 Set '14, 14:31

enzotib's gravatar image

enzotib ♦♦
14.0k112186

@AleReferee: esegui questo comando in un terminale ed aggiungi l'output ottenuto alla tua domanda:

apt-cache policy linux-headers-3.2.0-67
(17 Set '14, 06:58) enzotib ♦♦ enzotib's gravatar image

Riguardo a problemi di questo tipo ho visto parecchie domande (e purtroppo non altrettante soluzioni), prova a cercare fra i tag o fra le domande impostando aggiornamenti o altro nella casella di ricerca qui in alto, non escluderei che ci possa essere una soluzione già pronta, oltre naturalmente alle risposte che riceverai da chi è più ferrato in materia.

(17 Set '14, 07:43) enzoge enzoge's gravatar image
1

@enzotib

linux-headers-3.2.0-67:
  Installato: 3.2.0-67.101
  Candidato:  3.2.0-67.101
  Tabella versione:
 *** 3.2.0-67.101 0
        100 /var/lib/dpkg/status
(18 Set '14, 01:27) AleReferee AleReferee's gravatar image

@stani scusa sono un principiante non ho capito cosa devo fare

(18 Set '14, 01:30) AleReferee AleReferee's gravatar image

@AleReferee: esegui il seguente comando:

apt-cache policy $(dpkg --get-selections | awk '$2 == "install" { print $1 }') 2>&1 | tee output.txt

dopodiché posta su pastebin il contenuto del file output.txt creato nella tua home, oppure caricalo da qualche parte dove posso scaricarlo, tipo DropBox.

(18 Set '14, 09:33) enzotib ♦♦ enzotib's gravatar image

Ciao @AleReferee, basta che incolli l'output nel riquadro alla voce Content, poi metti un nome alla voce Poster e infine, clicchi su Paste! in basso e ti crea un link nella barra degli indirizzi del browser, quel link lo posti qui

(18 Set '14, 10:25) anonimo01 anonimo01's gravatar image
(18 Set '14, 12:52) AleReferee AleReferee's gravatar image
(18 Set '14, 12:54) AleReferee AleReferee's gravatar image

@AleReferee: la situazione è ben più complicata di quanto apparisse dalle tue informazioni:

  1. tu hai già fatto un avanzamento parziale, in quanto hai già dei pacchetti della 14.04
  2. i pacchetti che ancora sono della 12.04 non sono riconosciuti, questo secondo me perché il sources.list è già stato modificato da precise a trusty

Detto questo, se proprio vuoi cercare di sistemare la situazione, potremmo cercare di fare qualche tentativo, ma non ti assicuro che alla fine funzioni. L'alternativa è fare una installazione pulita della 14.04, naturalmente dopo aver salvato i dati.

(18 Set '14, 13:05) enzotib ♦♦ enzotib's gravatar image

questo che ti dice?

uname -r

@enzotib, magari se è solo quel kernel, si riesce rimuovendolo, tu che dici?

(18 Set '14, 13:37) anonimo01 anonimo01's gravatar image

@stani, i pacchetti presi da trusty sono i seguenti: http://paste.ubuntu.com/8371826/

(18 Set '14, 14:10) enzotib ♦♦ enzotib's gravatar image

boh io una prova la farei

@AleReferee intanto fai un backup dei dati

(18 Set '14, 14:38) anonimo01 anonimo01's gravatar image

@stani : mi dà questo: 3.2.0-67-generic-pae @enzotib il backup l'ho fatto, mi affido a voi... Vi ringrazio moltissimo ;)

(18 Set '14, 18:03) AleReferee AleReferee's gravatar image

prova così se lo rimuove

sudo apt-get purge linux-headers-3.2.0-67

se lo rimuove prova

sudo apt-get update && sudo apt-get upgrade

e fai sapere

(18 Set '14, 18:19) anonimo01 anonimo01's gravatar image

@stani dando il primo comando mi esce: http://paste.ubuntu.com/8373428/

(18 Set '14, 18:25) AleReferee AleReferee's gravatar image

probabilmente la cosa migliore è reinstallare, prova anche

sudo rm /var/lib/dpkg/info/linux-headers-3.2.0-67*
sudo dpkg --remove --force-remove-reinstreq linux-headers-3.2.0-67

e vedi se lo rimuove

(18 Set '14, 18:36) anonimo01 anonimo01's gravatar image

@stani Con il primo comando mi esce: http://paste.ubuntu.com/8374662/ ; con il secondo: http://paste.ubuntu.com/8374665/

(18 Set '14, 21:57) AleReferee AleReferee's gravatar image

mi pare che l'ha rimosso, ora se fai un update e upgrade cosa risponde?

sudo apt-get update

sudo apt-get upgrade
(18 Set '14, 23:14) anonimo01 anonimo01's gravatar image

mi sà che siamo arrivati a un punto morto, ti dice di dare sudo apt-get install -f ma avendo ormai i repo di trusty....

comunque prova

sudo apt-get install -f
(18 Set '14, 23:37) anonimo01 anonimo01's gravatar image

@stani Fatto, ecco cosa mi dà: http://paste.ubuntu.com/8375285/

(18 Set '14, 23:43) AleReferee AleReferee's gravatar image

prova a rimuovere anche questo

sudo sudo dpkg --remove --force-remove-reinstreq linux-generic-pae

e poi

sudo apt-get dist-upgrade

comunque, dall'ultimo output, si vedono qualche decina di kernel vecchi e oltre 1600 pacchetti da aggiornare, il casino mi sembra grosso

(18 Set '14, 23:56) anonimo01 anonimo01's gravatar image

Grazie @stani , arrivo sempre a questo punto: http://paste.ubuntu.com/8375938/

(19 Set '14, 02:02) AleReferee AleReferee's gravatar image

dai si (y) per andare avanti, se si presentano altri messaggi cosi, dai sempre y

(19 Set '14, 08:44) anonimo01 anonimo01's gravatar image

ciao @stani , sono arrivato a questo punto: http://paste.ubuntu.com/8378686/

(19 Set '14, 11:48) AleReferee AleReferee's gravatar image

riavvia e posta

uname -r
(19 Set '14, 11:54) anonimo01 anonimo01's gravatar image

@stani mi dà questo: 3.13.0-35-generic

(19 Set '14, 12:04) AleReferee AleReferee's gravatar image

quello è il kernel di 14.04, giusto, io proverei a dare un

sudo apt-get update && sudo apt-get upgrade

e se non hai errori, dovresti essere a posto,vedi

Inoltre, se va tutto bene, installa ubuntu tweak

http://ubuntu-tweak.com/

avvialo e alla scheda "pulizia" fai le pulizie di sistema, che avrai vari GB di file obsoleti e in cache e rimuovi i vecchi kernel

(19 Set '14, 12:10) anonimo01 anonimo01's gravatar image

@stani questo è il risultato: http://paste.ubuntu.com/8379138/ Ho fatto come hai detto con ubuntu tweak

(19 Set '14, 13:11) AleReferee AleReferee's gravatar image

mi pare tutto a posto edit dai ancora un

sudo apt-get dist-upgrade

che c'è ancora un pacchetto da aggiornare

(19 Set '14, 13:42) anonimo01 anonimo01's gravatar image

Grazie mille @stani sei stato gentilissimo!!

(19 Set '14, 13:48) AleReferee AleReferee's gravatar image

prego, figurati

(19 Set '14, 14:21) anonimo01 anonimo01's gravatar image

ciao @stani scusa se ti disturbo ancora... Ricordo che una volta mi si apriva quasi tutti i giorni il gestore dei pacchetti per farmene aggiornare qualcuno... Da un po' di tempo questo non mi succede più, infatti quando hai risolto il mio problema hai notato la presenza di tantissimi pacchetti vecchi non aggiornati. Adesso, dopo l'aggiornamento che mi hai fatto eseguire, il gestore continua a non aprirsi automaticamente... È normale questo? Non vorrei ritrovarmi tra un po' di tempo ad avere ancora problemi perché ho molti pacchetti non aggiornati, grazie

(27 Set '14, 11:50) AleReferee AleReferee's gravatar image

se dai questi cosa rispondono?

sudo apt-get update

sudo apt-get upgrade
(27 Set '14, 12:22) anonimo01 anonimo01's gravatar image

Ecco qua @stani : http://paste.ubuntu.com/8439592/ http://paste.ubuntu.com/8439595/ Poco fa ho però eseguito manualmente l'aggiornamento dei pacchetti (almeno credo di averlo fatto correttamente)

(27 Set '14, 12:47) AleReferee AleReferee's gravatar image

Ciao @AleReferee, il sistema è aggiornato, non sò, potrebbe essere un problema sul gestore aggiornamenti che non si avvia in automatico, se dici che non si presenta più.

Gli aggiornamenti puoi farli con

sudo apt-get update && sudo apt-get dist-upgrade

che è quello che fa gestore aggiornamenti.

Comunque, è consigliabile aprire un nuova domanda

(27 Set '14, 13:08) anonimo01 anonimo01's gravatar image

@stani ti ringrazio nuovamente ;)

(27 Set '14, 13:59) AleReferee AleReferee's gravatar image

Posta l'output di

cat -n /etc/apt/sources.list

e incolla l'output qui http://paste.ubuntu.com/ e metti il link che ti crea:

Risposta: http://paste.ubuntu.com/8371413/

Questo che ti dice?

uname -r

Risposta: mi dà questo: 3.2.0-67-generic-pae

Prova così se rimuove il pacchetto dell'errore nella tua domanda

sudo apt-get purge linux-headers-3.2.0-67

se lo rimuove prova

sudo apt-get update && sudo apt-get upgrade

Risposta: dando il primo comando mi esce: http://paste.ubuntu.com/8373428/

E: Il pacchetto linux-headers-3.2.0-67 deve essere reinstallato, ma non è possibile trovarne un archivio.

Probabilmente la cosa migliore è reinstallare, prova anche

sudo rm /var/lib/dpkg/info/linux-headers-3.2.0-67*
sudo dpkg --remove --force-remove-reinstreq linux-headers-3.2.0-67

e vedi se lo rimuove.

Risposta: @stani Con il primo comando mi esce: http://paste.ubuntu.com/8374662/ ; con il secondo: http://paste.ubuntu.com/8374665/

dpkg: attenzione: viene ignorato il problema poiché è usata l'opzione --force:
Il pacchetto si trova in uno stato di inconsistenza grave - è
necessario reinstallarlo prima di rimuoverlo.
(Lettura del database... 
dpkg: attenzione: file con l'elenco dei file del pacchetto "linux-headers-    3.2.0-67" mancante, il pacchetto viene considerato senza alcun file attualmente   installato.
(Lettura del database... 1048186 file e directory attualmente installati.)
Rimozione di linux-headers-3.2.0-67...

Mi pare che l'ha rimosso, ora se fai un update e upgrade cosa risponde?

sudo apt-get update
sudo apt-get upgrade

Risposta:
update: http://paste.ubuntu.com/8375133/
upgrade: http://paste.ubuntu.com/8375140/

Mi sa che siamo arrivati a un punto morto, ti dice di dare sudo apt-get install -f, ma avendo ormai i repo di trusty... comunque prova

sudo apt-get install -f

Risposta: fatto, ecco cosa mi dà: http://paste.ubuntu.com/8375285/

dpkg: problemi con le dipendenze impediscono la configurazione di linux-    generic-pae:
linux-generic-pae dipende da linux-headers-generic-pae (= 3.2.0.67.79), ma:
La versione di linux-headers-generic-pae nel sistema è 3.2.0.65.77.
dpkg: errore nell'elaborare linux-generic-pae (--configure):
problemi con le dipendenze - lasciato non configurato
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
    Si sono verificati degli errori nell'elaborazione:
 linux-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)

Prova a rimuovere anche questo

sudo dpkg --remove --force-remove-reinstreq linux-generic-pae

e poi

sudo apt-get dist-upgrade

comunque, dall'ultimo output, si vedono qualche decina di kernel vecchi e oltre 1600 pacchetti da aggiornare, il casino mi sembra grosso

Risposta: arrivo sempre a questo punto: http://paste.ubuntu.com/8375938/

File di configurazione "/etc/grub.d/00_header"
==> Modificato (dall'utente o da uno script) dopo l'installazione.
==> Il distributore del pacchetto ha fornito una versione aggiornata.
Come procedere? Le opzioni sono:
Y o I   : installa la versione del responsabile del pacchetto
N od O  : mantiene la versione attualmente installata
  D     : mostra le differenze tra le versioni
  Z     : avvia una shell per esaminare la situazione
L'azione predefinita consiste nel mantenere la versione attuale.
*** 00_header (Y/I/N/O/D/Z) [predefinito=N] ?

Dài si (y) per andare avanti, se si presentano altri messaggi cosi, dai sempre y

Risposta: sono arrivato a questo punto: http://paste.ubuntu.com/8378686/

Riavvia e posta

uname -r

Risposta: mi dà questo: 3.13.0-35-generic

Quello è il kernel di 14.04, giusto, io proverei a dare un

sudo apt-get update && sudo apt-get upgrade

e se non hai errori, dovresti essere a posto,vedi.
Inoltre, se va tutto bene, installa Ubuntu Tweak, avvialo e alla scheda pulizia fai le pulizie di sistema, che avrai vari GB di file obsoleti e in cache e rimuovi i vecchi kernel.

Risposta: questo è il risultato: http://paste.ubuntu.com/8379138/ . Ho fatto come hai detto con Ubuntu Tweak.

I seguenti pacchetti sono stati mantenuti alla versione attuale:
ubuntu-desktop
I seguenti pacchetti saranno aggiornati:
linux-firmware
1 aggiornati, 0 installati, 0 da rimuovere e 1 non aggiornati.

Mi pare tutto a posto

Edit: dai ancora un

sudo apt-get dist-upgrade

che c'è ancora un pacchetto da aggiornare

Risposta: Grazie mille @stani sei stato gentilissimo!

Prego, figurati

coll. permanente

ha risposto 17 Set '14, 09:20

anonimo01's gravatar image

anonimo01
(sospeso)

modificato 19 Set '14, 18:37

Il problema è che i paste su pastebin.ubuntu.com hanno una vita di al massimo un anno e mezzo, per cui bisognerebbe pensare ad una alternativa.

(19 Set '14, 16:15) enzotib ♦♦ enzotib's gravatar image

@enzotib: secondo te quando funzionerà l'upload delle immagini, potrebbe essere valido fotografare i contenuti di paste o pastebin, con Ksnapshot o altro, per aggiungerli alle risposte?

(19 Set '14, 16:33) enzoge enzoge's gravatar image

@ilgallinetta: credo che dipenda dal sito. Ma le foto mi sembrano una soluzione eccessiva, lasciamo stare per il momento, pensiamoci in generale.

(19 Set '14, 16:39) enzotib ♦♦ enzotib's gravatar image

visto il problema della scadenza dei paste e che in questo caso il problema segnalato dagli output in pratica è qualche riga col pacchetto problematico, si potrebbe aggiungere alla risposta almeno le poche righe, cosi da dare l'idea dei comandi successivi.

ora sono da smartphone, appena sono sul pc vedo di inserirle

(19 Set '14, 16:43) anonimo01 anonimo01's gravatar image

Ciao, ho aggiunto alla risposta i messaggi salienti degli output del terminale

(19 Set '14, 17:47) anonimo01 anonimo01's gravatar image

Personalmente non consiglio mai di fare l'avanzamento di versione in modo automatico con il gestire degli aggiornamenti:

  • perché impiega molto più tempo;
  • perché la nuova versione nel caso di qualche incompatibilità con qualche componente obsoleto potrebbe bloccarsi o non funzionare bene;
  • perché se nella vecchia versione, c'è stato fatto qualche aggiustamento che magari sul momento non ricordi, spesso si blocca.

Nel tuo caso poi, dovresti riparare prima la 12.04 per poi provare a fare l'avanzamento sperando che la nuova versione sia compatibile. É sicuramente più sicuro e veloce, preparare una Live con la quale, in modalità prova, puoi verificare la compatibilità prima di procedere all'installazione effettiva.
Naturalmente dopo aver fatto un bel backup, cosa da fare qualunque sia la scelta fatta relativamente al procedimento per installare la nuova versione.

coll. permanente

ha risposto 19 Set '14, 07:43

enzoge's gravatar image

enzoge
4.6k223987

@ilgallinetta quindi mi consigli di reinstallare ubuntu da capo, un po' come ho fatto la prima volta che l'ho installato? Si sostituisce automaticamente alla vecchia versione o devo fare qualche passaggio particolare? Grazie

(19 Set '14, 11:17) AleReferee AleReferee's gravatar image

@AleReferee: bèh io farei così, ma è certo che devi fare ciò che ritieni meglio.
Per conto mio l'unica cosa certa, che tutti dovremmo fare in presenza di dati da non perdere, è il backup; soprattutto quando si prova a rimediare con comandi da terminale, dove un'errore, un'impostazione sbagliata o anche una distrazione possono farceli perdere o altro.
D'altronde, se hai le copie o non hai dati da salvare e tempo per provare, può essere interessante tentare di risolvere con i comandi di sistema.

(19 Set '14, 12:07) enzoge enzoge's gravatar image

@AleReferee: si l'installazione nuova deve ricoprire/ricopre la vecchia, ma se decidi di fare così, a seconda della tipologia del tuo PC (UEFI o BIOS), puoi seguire questa guida ufficiale o qusest'altra.

(19 Set '14, 12:25) enzoge enzoge's gravatar image

grazie mille @ilgallinetta , pare che si sia sistemato tutto, se ci saranno ancora problemi reinstallerò da capo come dici tu ;)

(19 Set '14, 13:49) AleReferee AleReferee's gravatar image
1

Ma figurati @AleRefeere, anzi sono molto contento che tutto sia andato per il meglio. A tal proposito mi complimento con @stani al quale suggerirei di raccogliere i dati salienti della soluzione in una risposta che tu potrai accettare ed io votare.
In più, dal bianco dei miei capelli, permettetemi di dire di non dimenticare mai di consigliare, prima di qualsiasi comando o suggerimento,il backup. ;)

(19 Set '14, 14:27) enzoge enzoge's gravatar image

ciao @ilgallinetta, la discussione è stata talmente articolata che non saprei che sintesi fare della situazione per inserire una risposta, tu hai qualche idea?

@enzotib tu avresti idea di come sintetizzare il tutto?

(19 Set '14, 15:05) anonimo01 anonimo01's gravatar image

Se mi è consentito io elencherei i comandi suggeriti spiegandone dove possibile il perché, in modo che altri che si trovassero in condizioni similari possano provarci.

(19 Set '14, 15:12) enzoge enzoge's gravatar image
1

@stani, provo a mettere insieme qualcosa partendo dai tuoi commenti.

(19 Set '14, 15:17) enzotib ♦♦ enzotib's gravatar image

Ciao @enzotib, bel lavoro, grazie per lo sbattimento ;)

(19 Set '14, 15:56) anonimo01 anonimo01's gravatar image

@AleReferee: il problema lo hai risolto seguendo le indicazioni di @stani, per cui anche per segnalare la soluzione ad altri con lo stesso problema, dovresti accettare la risposta che @stani e @enzotib hanno preparato raggruppando tutti i commenti. Puoi farlo cliccando sul segno a v sotto le manine.

(20 Set '14, 09:33) enzoge enzoge's gravatar image

@ilgallinetta Fatto... Grazie a tutti

(20 Set '14, 09:45) AleReferee AleReferee's gravatar image
-2

May be the Software is restricted by copyright or legal issues or there is missing of any public key of the application.

coll. permanente

ha risposto 17 Set '14, 07:19

markjonsonus's gravatar image

markjonsonus
181

modificato 17 Set '14, 08:33

enzotib's gravatar image

enzotib ♦♦
14.0k112186

@markjonsonus: you come here to spam your links?

(17 Set '14, 08:33) enzotib ♦♦ enzotib's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×436
×185
×61

domanda posta: 17 Set '14, 00:45

domanda visualizzata: 1,348 volte

ultimo aggiornamento: 27 Set '14, 13:59

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.