Avevo 2 installazioni di Ubuntu 12.04 su due computer diversi. Collegavo il lettore Philips GoGear col cavetto USB e veniva riconosciuto da entrambi come semplice storage e potevo usarlo praticamente come chiavetta USB. Collegavo e via, non un problema.

In entrambi ho eseguito l'avanzamento a 14.04.1 quando è stato il sistema a chiederlo. In uno dei due PC, quello di casa, l'avanzamento si è piantato e (tanto per farla breve) ho dovuto reinstallare da zero formattando la partizione. Nell'altro invece l'avanzamento ha funzionato benissimo.

Nel PC che ha eseguito senza problemi l'avanzamento collego il lettore tramite cavo USB e viene visto come esattamente come prima. Nessun problema. In quello di casa non riesco ad usarlo. Nautilus vede il dispositivo, lo monta, al contrario di prima lo chiama 'MSC Device', mostra nella finestra una icona di disco fisso chiamata 'Internal Storage' ma se ci entro mi da la finestra completamente vuota. Il gestore dischi Disks non lo vede tra i dispositivi. Il gestore dischi GParted non lo vede tra i dispositivi. Comandi:

`kap@Armageddon:~$ sudo lsusb
 Bus 002 Device 005: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth
 Bus 002 Device 004: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
 Bus 002 Device 003: ID 046d:c31c Logitech, Inc. Keyboard K120 for Business
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 05e3:0723 Genesys Logic, Inc. GL827L SD/MMC/MS Flash Card  Reader
 Bus 001 Device 004: ID 0471:2004 Philips (or NXP) 
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo fdisk -l non mostra il dispositivo tra i file system disponibili`

Rhythmbox sembra vedere il dispositivo ma non riconosce i parametri degli mp3 presenti a parte il titolo.

chiesto 18 Set '14, 21:23

lordkap's gravatar image

lordkap
20113

modificato 19 Set '14, 10:31

Purtroppo sembro non riuscire a far funzionare il tag per scrivere i comandi... :(

(18 Set '14, 21:24) lordkap lordkap's gravatar image

Ciao @lordkap, non usare le risposte, usa i commenti, inoltre credo che puoi cancellare l'output di sudo fdisk -l, non credo che serva per il caso in questione.

Non è che avevi impostato qualcosa per rilevarlo? Nel senso che l'installazione su cui l'avanzamento è riuscito te lo rileva senza problemi, mi viene da pensare che avevi fatto qualcosa e che se l'e' portata dietro con l'avanzamento, mentre nell'altra, con una nuova installazione, non lo rileva

(18 Set '14, 21:32) anonimo01 anonimo01's gravatar image

No, semplicemente l'avevo collegato e mi aveva chiesto l'azione che dovevo compiere, così come faccio ora ogni volta che collego il dispositivo al PC che lo vede. Che io scelga o meno l'azione da compiere lui me lo visualizza in nautilus come una chiavetta USB normale. Ho dimenticato di dire che nel PC che non vede il lettore le altre chiavette USB vengono montate senza problemi.

(19 Set '14, 10:30) lordkap lordkap's gravatar image

C'è una novità. L'ho agganciato di nuovo al computer che fino a ieri lo leggeva normalmente e ora lo tratta esattamente come l'altro PC ma con un messaggio:

Error mounting /dev/sdb1 at /media/kap/PHILIPS: Command-line `mount -t "vfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush" "/dev/sdb1" "/media/kap/PHILIPS"' exited with non-zero exit status 32: mount: special device /dev/sdb1 does not exist"

Dev'essere successo qualcosa all'interno del dispositivo.

(19 Set '14, 11:54) lordkap lordkap's gravatar image

Windows 7 vede le cartelle e fa navigare tranquillamente sul dispositivo come fosse una chiavetta USB. Ho provato a usare il Device Manager di Philips ma sembra non riconoscerlo.

(19 Set '14, 17:48) lordkap lordkap's gravatar image

prova un check

sudo dosfsck -a /dev/sdb1

(19 Set '14, 17:57) anonimo01 anonimo01's gravatar image

fsck.fat 3.0.26 (2014-03-07)

open: File o directory non esistente

(22 Set '14, 08:39) lordkap lordkap's gravatar image

Quando mi avvicino col mouse sul menu di sinistra, dove viene identificato come MSC Device, la scritta 'mouseover' che viene mostrata è: mtp://[usb:001,002]/

Non so se possa servire a qualcosa...

(22 Set '14, 08:42) lordkap lordkap's gravatar image

prova a installare Gmtp

sudo apt-get install gmtp

e poi collega il lettore e cerca gmtp nella dash e lancialo, vedi se lo rileva e se ti fa esplorare il dispositivo, clic su "Collegare"

fai qualche prova

(22 Set '14, 09:58) anonimo01 anonimo01's gravatar image

Collegato e ricercato dispositivo tramite gMTP. Al primo tentativo non riconosceva il dispositivo. Ho chiuso il programma e ritentato, ora vede le cartelle e riesce a navigarle ma, quando tento di scaricare un file tramite il tasto 'Download' mi da l'errore: 'Errore durante il recupero di file da un dispositivo MTP.' Viene visto come 'Connesso a ?????????????' (stesso nome che c'è in nautilus).

(22 Set '14, 10:42) lordkap lordkap's gravatar image

prova a installare anche

sudo apt-get install mtp-tools mtpfs

e prova anche a creare una regola udev, per il dispositivo, che dall'output dovrebbe essere questo (è l'unico Philips)

Bus 001 Device 004: ID 0471:2004 Philips (or NXP)

dai

gksu gedit /etc/udev/rules.d/51-philips.rules

e incolla queste

#Philips
SUBSYSTEM=="usb", ATTR{idVendor}=="0471", MODE="0666"

salva il file e chiudilo e poi

sudo chmod a+r /etc/udev/rules.d/51-philips.rules

e poi riprova Gmtp

(22 Set '14, 11:25) anonimo01 anonimo01's gravatar image

Stessa situazione di prima: 'Errore durante il recupero di file da un dispositivo MTP.'

Quando chiudo gMTP mi dice "Dispositivo disconnesso a causa dell'accesso cambiamento metodo"

(22 Set '14, 11:44) lordkap lordkap's gravatar image

Aggiungo un'altro particolare. Agganciato ad un PC con Ubuntu 12.04 il dispositivo viene letto normalmente come storage device e mi fa navigare il contenuto e modificare i file senza problemi. Sono sempre meno convinto che sia un problema del dispositivo, evidentemente dalla 12.04 alla 13.04 è cambiato qualcosa nel modo in cui Ubuntu gestisce questo tipo di dispositivi.

(26 Set '14, 18:36) lordkap lordkap's gravatar image

@lordkap: stacca il dispositivo, apri un terminale, scrivi tail -f /var/log/syslog, poi attacca il dispositivo. Copia su pastebin quello che esce (poi al terminale puoi fermare con Ctrl-C).

(26 Set '14, 18:44) enzotib ♦♦ enzotib's gravatar image

http://pastebin.com/Yapq6m16

Ho agganciato il dispositivo a Sep 26 19:01:37

(26 Set '14, 19:03) lordkap lordkap's gravatar image

@lordkap: facciamo questa prova, rimuoviamo un pacchetto (che non dovrebbe trascinare via nessun altro pacchetto) e rifacciamo la stessa prova. Se è il caso poi lo reinstalliamo:

sudo apt-get purge colord
(26 Set '14, 19:41) enzotib ♦♦ enzotib's gravatar image

@lordkap: dato che non vedo come ultimo messaggio "USB disconnect", è cambiato qualcosa nel comportamento rispetto a prima?

(26 Set '14, 21:07) enzotib ♦♦ enzotib's gravatar image

No, scusa. Avevo dato il CTRL+C prima di disconnettere il dispositivo. Ora ho rifatto: http://pastebin.com/nWVMMEiD

(27 Set '14, 12:32) lordkap lordkap's gravatar image

Nessun'altra idea?

(03 Ott '14, 12:49) lordkap lordkap's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×208
×11

domanda posta: 18 Set '14, 21:23

domanda visualizzata: 1,743 volte

ultimo aggiornamento: 03 Ott '14, 12:49

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.