Dopo vari tentativi preceduti a ricerche su internet non mi rimane che chiedere aiuto.

Inizialmente facendo l'avanzamento da modalità grafica "System > Administration > Update Manager" mi dava un errore:

Could not download all repository indexes
The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.

Poi chiudendo la finestra mi dava quest'altro errore:

An error occurred
The following details are provided:
E: Impossibile aprire il file di blocco /var/lib/apt/lists/lock - open (2: No such file or directory)
E: Unable to lock the list directory

Andando poi in internet ho fatto come dicevano eseguendo i seguenti comandi:

$ sudo apt-get -f install
[sudo] password for : 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
sdparm
Usare "apt-get autoremove" per rimuoverli.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

$ sudo apt-get autoremove
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
sdparm
0 aggiornati, 0 installati, 1 da rimuovere e 0 non aggiornati.
E: Manca la directory di liste /var/lib/apt/lists/partial.

$ sudo apt-get check
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto

$ sudo apt-get update
E: Impossibile aprire il file di blocco /var/lib/apt/lists/lock - open (2: No such file or directory)
E: Impossibile bloccare la directory

AIUTOOOOOO non so piu come fare è da questa mattina che cerco in giro per risolvere ma mi blocco sempre allo stesso punto... cosa sbaglio?! come posso risolvere?!

PS. non sono molto pratico del mondo linux. Conobbi il sistema Ubuntu a scuola e me ne "innamorai" ma quando comincia a lavorare e a staccarmi un bel po dai pc ne persi le poche conoscenze che avevo aquisito.

chiesto 20 Set '14, 19:17

vSASU's gravatar image

vSASU
35236

modificato 22 Set '14, 07:33

enzotib's gravatar image

enzotib ♦♦
14.0k112186


La 10.04 LTS, non ne sono sicuro ma credo non sia più assistita. Ma credo che comunque ti converrebbe in ogni caso scaricare la Live della 12 o della 14 e testarle con la Live in modalità prova, per verificare che con il tuo hardware possano essere installate senza problemi. Altrimenti con l'avanzamento rischieresti di non farcela.

P.s. ricorda di fare il backup.

coll. permanente

ha risposto 20 Set '14, 19:40

enzoge's gravatar image

enzoge
4.7k253987

modificato 20 Set '14, 19:41

il fatto è questo.. avevo spento il pc qualche hanno fa con questa versione e riaccendendola ho provato ad aggiornare ma ho trovato questa sorpresa!

(20 Set '14, 19:50) vSASU vSASU's gravatar image

@vSASU: per cortesia per comunicare qualcosa e per dialogare, non usare le risposte, usa i commenti. Le risposte servono solo per suggerire soluzioni e, quando vengono accettare, diventano un riferimento per tutti coloro che hanno un problema analogo.
Per quanto concerne il tuo problema, essendo a quanto capisco il tuo pc piuttosto vecchiotto, mi sentirei di suggerirti prima la 12.04 e nel caso, siccome le Ubuntu ora, in fatto di hardware sono più esigenti, di provare una dericata come Xubuntu o Lubuntu.
Se vuoi consultare il manuale per l'installazione, lo trovi qui.

(20 Set '14, 20:10) enzoge enzoge's gravatar image

vi ringrazio a tutti ho risolto.. scaricato ed installato la versione 14 per desktop x64 :D

(21 Set '14, 22:26) vSASU vSASU's gravatar image

@ilgallinetta: potresti aiutarmi sul dannato plugin silverlight?! ho seguito le varie guide ma ad ora che sono riuscito ad andare avanti mi blocco quando dovrei accettare la licenza ma non me lo permette dal terminale ne da altre parti... come devo fare?!

(21 Set '14, 22:50) vSASU vSASU's gravatar image

@vSASU: non mettere risolto, ma accetta la risposta migliore. E per altri problemi apri una nuova domanda.

(22 Set '14, 07:32) enzotib ♦♦ enzotib's gravatar image

@vSASU: per cortesia accetta la risposta che ti ha aiutato cliccando la v sotto le manine con i pollici. Altrimenti altri con lo stesso problema non trovano la soluzione.
In quanto a silverlight, se come penso è solo per vedere dirette TV e filmati con Firefox, ti suggerisco di usare Google Chrome.
Però se vuoi approfondire la regola è che devi fare un'altra domanda.

(22 Set '14, 08:07) enzoge enzoge's gravatar image

daccordo indico la risposta che mi ha aiutato. ma senza aggiungere il [risolto]. per quanto riguarda il silverlight è tutto ok vi ringrazio ancora.

(22 Set '14, 19:29) vSASU vSASU's gravatar image

Come ti diceva @ilgallinetta, la cosa migliore è reinstallare da zero Ubuntu 14.04, se il tuo hardware è datato, è meglio Xubuntu 14.04.

Per il tuo problema, comunque, da questo

E: Manca la directory di liste /var/lib/apt/lists/partial

pare che non hai la directory "partial" in "lists", prova a ricrearla

sudo mkdir /var/lib/apt/lists/partial

e poi riprova gli aggiornamenti

sudo apt-get update && sudo apt-get upgrade

aggiornamenti,che per la versione desktop, ormai sono chiusi, visto che scadeva il supporto ad Aprile 2013, ma per la versione server sono ancora attivi (fino ad aprile 2015), quindi per quanto riguarda kernel e qualche altro aggiornamento di sicurezza dovrebbe ancora esserci qualcosa e se funziona tutto, dovrebbe anche proporti l'avanzamento a 12.04

coll. permanente

ha risposto 20 Set '14, 21:01

anonimo01's gravatar image

anonimo01
(sospeso)

modificato 20 Set '14, 21:12

@stani: se la sua versione è la desktop e visto che sono anni che non la usa (quindi con niente da salvare), forse sarebbe meglio una installazione pulita.
Almeno che tu non sia sicuro che aggiornando la desktop con la server, non si trovi con una desktop monca sulla quale poi non riesce a completare l'avanzamento alla 12.04 desktop. Fra l'altro posso sbagliare ma c'è anche il passaggio da OpenOffice a LibreOffice.

(20 Set '14, 21:26) enzoge enzoge's gravatar image

Si, sicuramente, il passaggio è bello grosso tra 10.04 (gnome2) e 12.04 (gnome3) ,boh può provare e vede come va al limite reinstalla da zero una versione supportata.

Per quello che riguarda la versione, lui, ha la desktop e a desktop avanza, dovrebbe avere ancora qualche pacchetto negli aggiornamenti, proprio per il discorso che facevo prima, ma non è che passa a server, aggiornerebbe solo dei pacchetti che sono in comune e ancora supportati per server

Ciao

(20 Set '14, 21:33) anonimo01 anonimo01's gravatar image

Dico così perché essendoci un hardware datato e al riguardo le nuove versioni più esigenti, se prestazioni e stabilità dovessero vacillare, il rischio sarebbe di non capire se è per gli aggiornamenti o per l'hardware.
Certo è che deve decidere @vSASU, ma se avesse tempo, sarebbe interessante provare entrambe le soluzioni.

Ciao e buona serata.

(20 Set '14, 21:53) enzoge enzoge's gravatar image

avrei voluto fare quella prova di ricreare la cartella ma una volta spento e riacceso il pc mi dava una scritta head(..qualcosa..) e a quel punto ho preso scaricato e reinstallato la 14.04.1 x64. dopo 2 giorni sembra andare ancora bene per il mio pc ma credo che il prima possibile avrò bisogno di una nuova ram (fino al minimo richiesto di 3gb in quanto io ne ho solo 2gb) perche a volte non mi risponde come credo dovrebbe.

(22 Set '14, 19:25) vSASU vSASU's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,716
×277

domanda posta: 20 Set '14, 19:17

domanda visualizzata: 1,599 volte

ultimo aggiornamento: 22 Set '14, 19:29

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.