Ho ubuntu 14.04.01 lts a 64 bit e quando installo i headers 3.13.0-35-generic mi dice che il pacchetto ha un altro nome qualcuno di voi sa come si chiama o se c'è un modo per scoprirlo. Mi serve per virtualbox

chiesto 02 Ott '14, 18:17

ValeBera01's gravatar image

ValeBera01
10222


Con il comando

dpkg --get-selections linux-headers\*

puoi elencare tutti i pacchetti che iniziano con quella stringa e che sono installati o sono stati rimossi non completamente.

Con il comando

apt-cache --names-only search linux-header

puoi elencare tutti quelli con quella stringa nel nome e disponibili nei repository.

coll. permanente

ha risposto 02 Ott '14, 18:24

enzotib's gravatar image

enzotib ♦♦
14.0k112186

mi escono tantissime cose da installare con il secondo che mi hai dato, se vuoi ti invio la schermata e mi dici quale dovrei installare

(03 Ott '14, 19:24) ValeBera01 ValeBera01's gravatar image

mi dice così:

linux-headers-3.13.0-24 - Header files related to Linux kernel version 3.13.0
linux-headers-3.13.0-24-generic - Linux kernel headers for version 3.13.0 on 64 bit x86 SMP
linux-headers-3.13.0-24-lowlatency - Linux kernel headers for version 3.13.0 on 64 bit x86 SMP
linux-headers-generic - Generic Linux kernel headers
linux-headers-generic-lts-quantal - Generic Linux kernel headers
linux-headers-generic-lts-raring - Generic Linux kernel headers
linux-headers-generic-lts-saucy - Generic Linux kernel headers
linux-headers-generic-lts-trusty - Generic Linux kernel headers
linux-headers-lowlatency - lowlatency Linux kernel headers
linux-headers-server - Transitional package.
linux-headers-virtual - Transitional package.
linux-headers-generic-pae - pacchetto di transizione
linux-headers-lowlatency-pae - pacchetto di transizione
linux-headers-3.4.0-3-goldfish - Linux kernel headers for version 3.4.0 on Android touch emulation
linux-headers-goldfish - Linux kernel headers for the goldfish kernel.
linux-headers-3.8.10-030810 - Header files related to Linux kernel version 3.8.10
linux-headers-3.8.10-030810-generic - Linux kernel headers for version 3.8.10 on 64 bit x86 SMP
(03 Ott '14, 19:30) ValeBera01 ValeBera01's gravatar image

@ValeBera01: non usare le risposte, usa i commenti.
Il primo output non ti dà le cose da installare, ma quelle già installare.
Il secondo output è strano, non riporta nessun kernel al di sopra del 3.13.0-24, sei sicuro che l'output sia completo?

(03 Ott '14, 19:48) enzotib ♦♦ enzotib's gravatar image

Ho controllato, l'output è completo. Quale dovrei installare dei kernel?

(03 Ott '14, 22:22) ValeBera01 ValeBera01's gravatar image

Così dovresti installare gli headers del kernel in uso

sudo apt-get install linux-headers-$(uname -r)

prova.

EDIT: Da quello che si vede dagli output, hai il sources.list a cui mancano dei repo ufficiali e hai repodi Ubuntu 12.10. Inoltre un repo di skype non raggiungibile. Fai queste cose, prima di tutto assicurati di non avere qualche istanza aperta di Gestore Aggiornamenti o Software Center o Gestore Pacchetti, se ne hai chiudi tutto, poi dai

gksu gedit /etc/apt/sources.list

e cancella tutto, incolla queste

deb http://archive.ubuntu.com/ubuntu/ trusty main universe restricted multiverse
deb-src http://archive.ubuntu.com/ubuntu/ trusty main universe restricted multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main universe restricted multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security main universe restricted multiverse

deb http://archive.ubuntu.com/ubuntu/ trusty-updates main universe restricted multiverse
deb-src http://archive.ubuntu.com/ubuntu/ trusty-updates main universe restricted multiverse

deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

fatta la modifica al file, salvalo e chiudi l'editor di testo.

Poi cancella tutti repo esterni, dai

sudo rm /etc/apt/sources.list.d/*

e al termine dai

sudo rm -r /var/lib/apt/lists/* && sudo apt-get update

se non hai errori dai

sudo apt-get install linux-headers-$(uname -r)

e in caso posta l'output di questi ultimi due comandi

coll. permanente

ha risposto 02 Ott '14, 18:25

anonimo01's gravatar image

anonimo01
(sospeso)

modificato 03 Ott '14, 23:19

Mi dice la stessa cosa che faccio facendo sudo apt-get install linux-headers-3.13.0-35-generic ovvero che il pacchetto ha un altro nome

(03 Ott '14, 19:26) ValeBera01 ValeBera01's gravatar image

@ValeBera01: potresti mostrare l'output esatto del comando?

(03 Ott '14, 19:49) enzotib ♦♦ enzotib's gravatar image

Eccolo:

Lettura elenco dei pacchetti... Fatto  
Generazione albero delle dipendenze        
Lettura informazioni sullo stato... Fatto  
Il pacchetto linux-headers-3.13.0-35-generic non ha versioni disponibili, ma è nominato da un altro  
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto  
oppure è disponibile solo all'interno di un'altra sorgente

E: Il pacchetto "linux-headers-3.13.0-35-generic" non ha candidati da installare
(03 Ott '14, 22:23) ValeBera01 ValeBera01's gravatar image

Potresti avere qualche problema con i repository, quel pacchetto dovrebbe esserci e chiamarsi proprio in quel modo.

Posta gli output di questi da terminale

cat -n /etc/apt/sources.list

e

sudo apt-get update

Incolla gli output qui http://paste.ubuntu.com/ e compila tutti i campi, poi posta qui il link che ti crea nella barra degli indirizzi

(03 Ott '14, 22:29) anonimo01 anonimo01's gravatar image

Ecco il link: http://paste.ubuntu.com/8488279

Gli ho messi entrambi sono separati da un po' di righe vuote

(03 Ott '14, 22:47) ValeBera01 ValeBera01's gravatar image

Ciao @ValeBera01, ho editato la mia risposta vedi lì

(03 Ott '14, 23:20) anonimo01 anonimo01's gravatar image

Ho risolto eliminando il lock ed installando i pacchetti da un file .deb

coll. permanente

ha risposto 04 Ott '14, 12:09

ValeBera01's gravatar image

ValeBera01
10222

Ok, se hai risolto in quel modo (ma secondo me non hai risolto niente, hai messo una toppa) accetta la tua risposta, comunque per come la penso io dovevi fare le cose che ti ho detto, comunque hai un repo di 12.10 e un repo esterno non raggiungibile. Quel pacchetto bastava installarlo dal sistema una volta messo tutto a posto, non serviva cercare il .deb e installarlo manualmente Se non hai fatto le cose che ti dicevo il sistema ha dei problemi negli aggiornamenti e infatti hai installato un .deb manualmente EDIT: magari spiega come hai rimosso il lock e la procedura del .deb

(04 Ott '14, 12:17) anonimo01 anonimo01's gravatar image

Mi potresti dire come potrei fare?

P.S. Secondo te quanti anni ho?

(04 Ott '14, 19:29) ValeBera01 ValeBera01's gravatar image

come potrei fare cosa? mettere il risolto? clicca sul segno di spunta, quello a forma di V che vedi sotto i pollici della tua risposta

(04 Ott '14, 21:52) anonimo01 anonimo01's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×78

domanda posta: 02 Ott '14, 18:17

domanda visualizzata: 2,181 volte

ultimo aggiornamento: 04 Ott '14, 21:52

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.