Ciao a tutti! Premetto che ho un notebook con Ubuntu 14.04 e Winows 8 in dualboot. Da un po' di giorni ho notato che quando accedo a Windows 8 e spengo il pc (ho già tolto l'opzione di avvio rapido), questo mi presenta il solito GRUB con tutte le voci corrette, ma quando seleziono "Ubuntu" l'avvio si blocca e il block-maiusc si accende e si spegne, costringendomi ad un riavvio forzato. Dopo questo strano comportamento il pc si riavvia, ma mi presenta una finestra blu con scritto "GNU GRUB versione 2.02^^beta2-9ubuntu1" e se seleziono Ubuntu il sistema operativo si avvia, ma mi scrive, tipo riga di comando, tutto quello che fa finchè non scrive che non è possibile montare la partizione e posso cegliere se aggiustarla (fix) o ignorare (ignore), selezionando fix mi si riavvia il pc e riparte il bootloader blu, questa volta il sistema parte e funziona perfettamente, eccetto per le scritte he mi mostrano cosa sta facendo. Riavviando il pc da Ubuntu si presenta sempre il bootloder blu, ma il sistema parte e funziona tranquillamente (scritte a parte ovviamente). Aggiungo inoltre che il "nuovo" GRUB è presente da quando ho dato il comando "dist-upgrade". Qualcuno sa aiutarmi?

chiesto 18 Ott '14, 12:31

Michi-Pine's gravatar image

Michi-Pine
244202632

modificato 18 Ott '14, 15:32

Su Windows hai disabilitato il Fast Boot?

Usi UEFI o il BIOS Legacy?

Quali ppa esterni hai attivato?

Quale partizione ti dice che non è possibile montare?

(18 Ott '14, 12:58) dadexix86 ♦♦ dadexix86's gravatar image

Il fast boot è disabilitato, uso UEFI e con i ppa ho qualche problema che nessuno è ancora riuscito a risolvere (vedi qui). Per quanto riguarda la partizione penso si riferisca a quella di Ubuntu, perchè non c'è nessun dettaglio.

(18 Ott '14, 15:36) Michi-Pine Michi-Pine's gravatar image

Per caso su Windows hai installato i driver per leggere le partizioni ext?

Sembra quasi che Windows "tocchi" la partizione di Ubuntu in qualche modo.

Quando avevi installato, lo spazio l'avevi ridotto da Windows o da Ubuntu direttamente?

Per i ppa, quali esterni hai aggiunto?

(18 Ott '14, 15:40) dadexix86 ♦♦ dadexix86's gravatar image

Sì su Windows ho installato un programma per leggere la partizione ext, non ci avevo pensato!
Io avevo il pc con Windows 8 ed ho ridotto la partizione di Windows per creare quella di Ubuntu, ma quando ancora era vuoto e sono andato oltre i file di metà memoria di Windows.
Eh di ppa ne ho aggiunte un bel po', il fatto è che non sono ancora riuscito a capire quali creino problemi, perchè anche provando a disattivarle una ad una non funziona comunque... Ti devo postare il file sources.list?

(18 Ott '14, 16:52) Michi-Pine Michi-Pine's gravatar image

No, no, per i ppa continua di là.

Qui direi che il problema è il driver per leggere ext da Windows.

Prova a disinstallarlo e controlla se hai ancora lo stesso problema (dovrai riavviare un tot di volte sia Ubuntu che Windows, probabilmente)

(18 Ott '14, 17:14) dadexix86 ♦♦ dadexix86's gravatar image

Ok, provo.
Per quanto riguarda il continuare nell'altra discussione è da un sacco che nessuno mi risponde più purtroppo...

(18 Ott '14, 17:52) Michi-Pine Michi-Pine's gravatar image

Disinstallando si è risolto il problema del "fix", ma non quello del bloc-maiusc. Quindi devo riavviare sempre dal GRUB "normale" e parte solo quando mi compare il GRUB blu.
PS: ho già riavviato più volte entrambi i sistemi operativi, la situazione dovrebbe essersi stabilizzata così...

(18 Ott '14, 18:08) Michi-Pine Michi-Pine's gravatar image

Beh, almeno ora sappiamo che i due problemi non sono collegati, è già un inizio.

Il problema del doppio GRUB ti succede solo quando accedi da Windows e poi riparti oppure se rebooti da Ubuntu e riaccedi a Ubuntu hai lo stesso probleam?

(18 Ott '14, 19:10) dadexix86 ♦♦ dadexix86's gravatar image

Riavviando da Ubuntu sempre ho il GRUB blu ogni volta, mentre quando riaccedo dopo aver riavviato da Windows mi dà il GRUB classico e, una volta selezionto Ubuntu, si blocca con il tasto bloc-maiusc lampeggiante e lo schermo viola; forzato lo spegnimento, tenendo premuto il pulsante, e riaccendendo il pc torna il GRUB blu e parte Ubuntu.

(18 Ott '14, 19:24) Michi-Pine Michi-Pine's gravatar image

Ok, quindi il problema ora sappiamo che è Windows a causarlo.

Probabilmente va a toccare qualche file nella partizione condivisa EFI.

Personalmente ho sempre evitato EFI come la peste, proprio per evitarmi anche questo tipo di problemi (Windows da una parte e Ubuntu da un'altra, senza Windows tocchi i miei files a mia insaputa).

La soluzione è controllare cosa fa Windows in quella partizione e impedirgli di farlo :)

Per supporto specifico ti conviene chiedere direttamente a persone specificatamente competenti in merito.

(18 Ott '14, 19:28) dadexix86 ♦♦ dadexix86's gravatar image

Quello che non capisco è perchè faccia così solo ora. Cioè come si è "installato" questo nuovo GRUB?

(18 Ott '14, 19:33) Michi-Pine Michi-Pine's gravatar image

Potresti aver fatto casino con uno qualsiasi di quella miriade di ppa esterni oppure potrebbe essere un aggiornamento o un programma che hai installato su Windows.

Io propendo per la seconda.

Di GRUB ne hai uno solo, i cui file vengono modificati a tua insaputa da questo programma/aggiornamento quando accedi a Windows.
Se fosse un problema interno ad Ubuntu ce l'avresti anche riavviando direttamente Ubuntu senza passare da Windows.

(18 Ott '14, 19:50) dadexix86 ♦♦ dadexix86's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,661
×263
×180
×136

domanda posta: 18 Ott '14, 12:31

domanda visualizzata: 1,333 volte

ultimo aggiornamento: 18 Ott '14, 19:50

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.