ho installato Ubuntu 14.04 da poco, aggiornando il sistema dalla versione precedente, sulla quale girava perfettamente VirtualBox 4.1.
Ora, provandolo ad avviare appare il seguente errore:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first.

This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Non so che fare, ho provato da terminale a fare tutto quello che ho trovato nei post con questo argomento ma non si avvia.

Allego il messaggio che VirtualBox presenta quando provo ad avviarlo

Altri messaggi che riporto sono:
report from command line sudo /etc/init.d/vboxdrv setup
report from command line sudo lsmod

Poi riporto il risultato di altri due comandi:

sudo service vboxdrv start
Starting VirtualBox kernel modules
modprobe vboxdrv failed. Please use 'dmesg' to find out why

sudo dkms status
nvidia-173, 173.14.39, 3.13.0-38-generic, i686: installed nvidia-173, 173.14.39, 3.2.0-70-generic-pae, i686: installed vboxhost, 4.1.8: added

chiesto 18 Ott '14, 19:50

luke23's gravatar image

luke23
40237

modificato 19 Ott '14, 11:45

dadexix86's gravatar image

dadexix86 ♦♦
16.9k716161

@uke23: alcune domande:

  1. usi la versione dei repo, o quella del sito Oracle?
  2. VBox è arrivato alla versione 4.3, perché non aggiorni?
  3. come mai hai il kernel 3.13.0-38, hai per caso attivato i repo proposed?
(18 Ott '14, 20:02) enzotib ♦♦ enzotib's gravatar image

sono molto poco preparato sulle tue domande..provo a rispondere a tutto:

  1. parli di virtualbox? mi sembra di averlo scaricato dal sito Oracle ma non ricordo bene

  2. ho provato a farlo, scaricando dal gestore applicazioni la versione 4.3 ma non si installa trovando dei conflitti nei pacchetti con la 4.1

  3. non so cosa siano i repo-proposed..se mi spieghi ti seguo, grazie

la cosa più importante è che ho una macchina virtuale con windows xp che non posso assolutamente perdere perchè ho dentro un programma importante: la domanda è? se disinstallo vbox 4.1 e installo vbox 4.3, quella rimane??

(18 Ott '14, 20:29) luke23 luke23's gravatar image

@luke23: la macchina virtuale non la perdi. Per i repo proposed, vediamo l'output del comando:

grep proposed /etc/apt/sources.list
(19 Ott '14, 00:11) enzotib ♦♦ enzotib's gravatar image

Output

luca@luca-HP-Pavilion-dv5-Notebook-PC:~$ grep proposed /etc/apt/sources.list
deb http://it.archive.ubuntu.com/ubuntu/ trusty-proposed restricted main multiverse universe
(20 Ott '14, 14:12) luke23 luke23's gravatar image

@luke23: lancia software-properties-gtk, disabilita i repo proposed, poi riavvia con un kernel precedente, poi rimuovi il kernel installato dai proposed con

sudo apt-get purge 3.13.0-38
(20 Ott '14, 16:58) enzotib ♦♦ enzotib's gravatar image

proverò seguendo le tue istruzioni anche se non so bene come si faccia a disabilitare .. riavviare con un kernel precedente ecc ecc, tra poco ti dico

(20 Ott '14, 17:33) luke23 luke23's gravatar image

@luke23: nell'interfaccia di software-properties-gtk trovi da qualche parte un segno di spunta che fa riferimento ai repo "proposed", devi togliere il segno di spunta.
Per riavviare con un kernel precedente devi sceglierlo al menu di grub, andando su Opzioni avanzate per Ubuntu e guardando la lista dei kernel disponibili.

(20 Ott '14, 17:56) enzotib ♦♦ enzotib's gravatar image

allora.. ho disabilitato i repo-proposed. Nelle opzioni di sistema a cui accedo dal menù in alto a destra seleziono impostazioni di sistema ma non vedo nulla che assomigli a una lista di kernel..

(20 Ott '14, 18:30) luke23 luke23's gravatar image

nel frattempo ho installato le ubuntu-tweak..possono servire??

(21 Ott '14, 10:22) luke23 luke23's gravatar image

@luke23: il menu di grub è quello che dovresti vedere subito dopo il BIOS, all'avvio del PC. Se non lo vedi allora avvia tenendo premuto il tasto Maiusc (mi pare sia così).
E' probabile che il kernel si può rimuovere anche senza avviarne prima un altro, ma non sono sicuro.

(21 Ott '14, 10:32) enzotib ♦♦ enzotib's gravatar image

Come avevi detto, ho trovato il menu' di grub. Ho fatto partire il sistema con un kernel precedente. Ho rimosso il kernel difettoso (3.13.0-38) da terminale. infatti attualmente vedo che sta funzionando il kernel 3.2.0-70.

VIRTUAL BOX continua a non funzionare..

A questo punto cosa devo fare? GRAZIE

(21 Ott '14, 14:33) luke23 luke23's gravatar image

@luke: 3.2.0-70? e da dove esce? Hai Ubuntu 14.04? Il kernel giusto dovrebbe essere il 3.13.0-37. Hai provato a rifare la procedura seguente?

sudo /etc/init.d/vboxdrv setup
(21 Ott '14, 15:16) enzotib ♦♦ enzotib's gravatar image

Ho installato ubuntu 14.04 come mi è stato proposto dal gestore aggiornamenti automatico..
Non so da dove esca la 3.2.0-70, non ne ho idea ma se mi dici i passaggi provo a impostare tutto correttamente. In rete ho letto che dovrebbe appartenere a ubuntu 12.04.

appena sono a casa, dopo le 17,45, provo a fare quello che mi consigli e ti scrivo il risultato.

(21 Ott '14, 15:26) luke23 luke23's gravatar image

ti incollo il risultato del comando: http://pastebin.com/bRpf0sDg

e anche questo: http://pastebin.ubuntu.com/8616618/

(21 Ott '14, 17:55) luke23 luke23's gravatar image

questo?

uname -r
(21 Ott '14, 17:58) anonimo01 anonimo01's gravatar image

@luke23: con il comando

dpkg --get-selections linux-*

puoi vedere l'elenco dei pacchetti installati il cui nome inizia per "linux-". Assicurati che insieme al pacchetto il cui nome inizia con linux-image- e con numero dato dal comando che ti ha suggerito @stani, ci sia anche il pacchetto con lo stesso numero il cui nome inizia con linux-headers-. Se non è installato, installalo e riprova il setup di vboxdrv.

(21 Ott '14, 18:05) enzotib ♦♦ enzotib's gravatar image

luca@luca-HP-Pavilion-dv5-Notebook-PC:~$ uname -r 3.2.0-70-generic-pae

(21 Ott '14, 18:06) luke23 luke23's gravatar image

prova

sudo apt-get install linux-headers-$(uname -r)

sudo apt-get install dkms

e riprova

sudo /etc/init.d/vboxdrv setup
(21 Ott '14, 18:11) anonimo01 anonimo01's gravatar image

report del comando dpkg --get-selections linux-*: http://pastebin.ubuntu.com/8616680/

non vedo alcun pacchetto che cominci con "linux-headers-.." ! mi devo preoccupare??

(21 Ott '14, 18:13) luke23 luke23's gravatar image

aspita, il kernel 2.6.38-8 è del giugno 2011, un pezzo d'antiquariato.

(21 Ott '14, 18:16) enzotib ♦♦ enzotib's gravatar image

comunque sei fermo al kernel 3.2.0-70 intanto vedi se con i comandi di prima, virtualbox si avvia

(21 Ott '14, 18:16) anonimo01 anonimo01's gravatar image

negli avanzamenti di versione è andato storto qualcosa, hai il kernel di 12.04 su 14.04, ma questo che dice?

cat -n /etc/apt/sources.list
(21 Ott '14, 18:22) anonimo01 anonimo01's gravatar image
(21 Ott '14, 18:22) luke23 luke23's gravatar image

lascia perdere quello che probabilmente ho detto un cavolata io, non avevo fatto caso subito al kernel, posta l'output del comando che ti dicevo prima

(21 Ott '14, 18:26) anonimo01 anonimo01's gravatar image

report del comando cat -n /etc/apt/sources.list: http://pastebin.ubuntu.com/8616815/

per stani: la versione del kernel 3.13.0-38, che avevo trovato come ultima installata, l'ho rimossa io

VIRTUALBOX NON SI AVVIA

(21 Ott '14, 18:27) luke23 luke23's gravatar image

dai

sudo apt-get update

e poi

sudo apt-get dist-upgrade

e postali che dovrebbe aggiornarti il kernel

(21 Ott '14, 18:32) anonimo01 anonimo01's gravatar image

http://pastebin.ubuntu.com/8616973/

poi ho rilanciato il comando uname -r:

uname -r 3.2.0-70-generic-pae

NON È CAMBIATO NIENTE! :( inoltre mi sembra che anche in generale il sistema sia rallentato, pesante, quando clicco su qualsiasi elemento ci mette alcuni secondi prima di rispondere..

(21 Ott '14, 18:43) luke23 luke23's gravatar image

sicuramente gli avanzamenti di versione, come hai fatto tu, possono portare problemi prova a cercare in gestore pacchetti il kernel 3.13.0-37 cercando linux-image e linux-headers installali e riavvia

(21 Ott '14, 19:46) anonimo01 anonimo01's gravatar image

grazie, proverò oggi in pausa pranzo poi riporto i risultati..

(22 Ott '14, 10:44) luke23 luke23's gravatar image

una volta riavviato, controlla con

uname -r

se il kernel in uso è il 3.13.0-37 se è quello, ridai

sudo apt-get install linux-headers-$(uname -r)

se gli headers li hai già te lo dice,e riprova a installare questo

sudo apt-get install dkms

anche in questo caso, se il pacchetto è già installato te lo dice

se tutte queste cose sono a posto, riprova

sudo /etc/init.d/vboxdrv setup
(22 Ott '14, 11:31) anonimo01 anonimo01's gravatar image

ho provato tutto, virtualbox non funziona. poi con questo kernel non mi va più il mouse senza fili ne' la connessione wireless..

Esiste un kernel più stabile e veloce degli altri per Ubuntu 14.04??

Inoltre ho notato che pur avendo un processore a 64bit sul mio portatile, Ubuntu ha un kernel a 32bit (i686).. è sbagliato?

(22 Ott '14, 14:54) luke23 luke23's gravatar image

non so più che dirti, ma secondo me i problemi sono dovuti agli avanzamenti di versione, io salverei i dati e la macchina virtuale (per questo non so dirti di preciso, ho usato virtual box anni fa e non ricordo più il nome del file, mi pare che era un .vdi ma non ne sono sicuro) e poi lo reimporti nella nuova virtualbox.

vediamo se @enzotib sa precisamente il file della macchina virtuale e dov'è

(22 Ott '14, 15:27) anonimo01 anonimo01's gravatar image

@stani e quale kernel mi consiglieresti? penso di disinstallare il 3.13.0-37 perchè va male..

(22 Ott '14, 15:40) luke23 luke23's gravatar image

quello è l'ultimo kernel stabile su 14.04 ce l'ho su 3 disribuzioni, Ubuntu, Kubuntu e Mint 17 e non mi da problemi

come dicevo prima, secondo me i problemi sono dovuti agli avanzamenti di versione

(22 Ott '14, 15:53) anonimo01 anonimo01's gravatar image

@stani quindi cosa mi consiglieresti?

(22 Ott '14, 15:59) luke23 luke23's gravatar image

quello che ti ho già consigliato in un commento precedente, salvati i dati e la macchina virtuale (per questo devi aspettare qualcuno che sa dové e come si chiama il file, io non mi ricordo) e poi re installa da zero ubuntu, in modo da avere un'installazione pulita

(22 Ott '14, 16:04) anonimo01 anonimo01's gravatar image

@stani, @luke23, per la virtual machine conviene salvare tutta la directory che la contiene, ma anche solo il virtual disk può essere sufficiente. Per esperienza personale, VirtualBox è non dà particolari problemi a ripristinare una VM, anche di una versione precedente di VBox, che funzionava. In ogni caso se ci sono problemi siamo qui ad aiutare.

(22 Ott '14, 17:28) enzotib ♦♦ enzotib's gravatar image

grazie mille siete veramente un sostegno! ;) stasera ho salvato tutta la cartella home su un disco esterno. Ho controllato la presenza delle directory di virtualbox, che ci sono. Ho preparato un dvd con dentro Ubuntu 14.04LTS scaricato oggi dal sito originale. Non mi resta che reinstallare tutto il sistema operativo da zero e installare l'ultima versione di virtualbox, poi provare a ripristinare la macchina virtuale salvata. Vi tengo aggiornati perchè non ho mai fatto nulla di simile con Ubuntu, penso che cercherò qualche dritta in rete per fare tutto nel modo giusto. Se riesco ci provo domani

(22 Ott '14, 23:30) luke23 luke23's gravatar image

buongiorno, oggi reinstallo Ubuntu 14.04(.01) LTS scaricato dal sito originale, con installazione da Dvd.

1) mi consigliate la versione della comunità italiana rispetto a quella standard?

2)prima di reinstallare il sistema è consigliabile formattare tutto o la sovrascrittura farà altrettanto?

(23 Ott '14, 10:08) luke23 luke23's gravatar image

credo che una vale l'altra, quando reinstalli scegli altro e reinstalla sulla partizione che avevi già per Ubuntu

(23 Ott '14, 10:17) anonimo01 anonimo01's gravatar image

ho avuto anch'io lo stesso problema ho cambiato la cpu e ora il problema non c'è più quindi presumo sia un problema di kernel

(23 Ott '14, 23:24) Mattia Franc... Mattia%20Francesco%20Babolin's gravatar image

Buongiorno, ho risolto il problema, ecco i passaggi:

  1. ho abilitato nel BIOS l'opzione della virtualizzazione (VT-x);
  2. ho reinstallato da zero Ubuntu 14.04 LTS;
  3. ho installato VirtualBox 4.3(.10) da Ubuntu Software Center (dove la versione disponibile non è l'ultima rilasciata sul sito originale, in cui c'è la versione 4.3.18);
  4. ho clonato da dentro VirtualBox la macchina virtuale precedentemente salvata e solo la macchina clonata funziona!

N.B. avevo copiato la macchina salvata e incollata sulla home, non funzionava perché VirtualBox leggeva uno stesso numero identificativo sull'hard disk virtuale della VM.
Solo la clonazione permette la creazione di un nuovo numero identificativo univoco.

@enzotib e @stani: un grazie particolare per l'aiuto.

coll. permanente

ha risposto 24 Ott '14, 10:49

luke23's gravatar image

luke23
40237

modificato 24 Ott '14, 11:16

enzotib's gravatar image

enzotib ♦♦
14.0k112186

@luke23: molto bene.

(24 Ott '14, 11:17) enzotib ♦♦ enzotib's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×434
×78

domanda posta: 18 Ott '14, 19:50

domanda visualizzata: 2,089 volte

ultimo aggiornamento: 24 Ott '14, 11:17

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.