Dopo aver effettuato l'aggiornamento alla versione 14.04 di Ubuntu ed avere eseguito il reboot del sistema, mi si è presentata la "famigerata" shell di GRUB 1.9.

A questo punto è scattato il panico, essendo neofita di amministrazione di distribuzioni Ubuntu!

Facendo ricerche per trovare se qualcuno si fosse imbattuto nel mio stesso problema, ho visto il post su un problema nell'installazione della versione 13 ed ho cercato di seguirne le indicazioni.

Sono riuscito ad eseguire il boot, ma dopo aver eseguito e superato numerosi controlli ottengo una finestra di dialogo che recita:

The system is running in low-graphics mode.

A questo punto, dopo aver confermato, ho alcune opzioni come

Run in low-graphics mode
Reconfigure graphics
Troubleshoot the error
Exit to console

Ho provato la seconda opzione e la terza senza successo, quindi ho provato la prima.
Nuova finestrella con messaggio

Stand by one minute while the display restarts.

Una volta confermato mi sono ritrovato nella console e ho eseguito il comando sudo update-grub

Ottengo:

Generating grub configuration file
Attenzione : Setting grub GRUB-TIMEOUT to a non zero value when GRUB-HIDDEN-TIMEOUT is set is no longer supported.

Trovata immagine [...] vmlinux 3.13
Trovata immagine [...]
[...]
Trovato Microsoft Windows XP su /dev/sda1
fatto

A questo punto faccio reboot e sono di nuovo al punto di partenza con la shell GRUB.

Ringrazio anticipatamente tutti coloro che vorranno aiutarmi.

PS: mi sembra che prima che compaia la shell di GRUB, appaiano due messaggi di file not found

chiesto 19 Ott '14, 10:56

PietroAlbe's gravatar image

PietroAlbe
30113

modificato 19 Ott '14, 11:43

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

@PietroAlbe: spieghi molto dettagliatamente cosa ti succede, ma di ciò che hai fatto prima, oltre al fatto che hai aggiornato il sistema non dici nulla, neppure da quale versione hai aggiornato.
Credo che a parte che con altri tentativi alla cieca, con un po di fortuna si possa risolvere, sarebbe più opportuno che tu riferissi maggiori dettagli, su ciò che avevi installato prima (compresi eventuali driver proprietari) e sul PC

(19 Ott '14, 11:12) enzoge enzoge's gravatar image

Ok, cerco di aggiungere ulteriori informazioni
Ho aggiornato la versione 12.04 utilizzando l'update manager di ubuntu.
Ho una scheda grafica ati radeon rv670//680 radeonhd 3690/3800

Il pc ha un dual boot su due dischi sda1 Windows, sdb1 Ubuntu.
non ho installato nessun driver particolare per la scheda video.

Dal bash di grub ho eseguito questa procedura

set prefix=(hd1,1)/boot/grub
set root=(hd1,1)
insmod (hd1,1)/boot/grub/linux.mod 
linux /vmlinuz root=/dev/sdb1 ro
initrd /initrd.img
boot

grazie

(19 Ott '14, 11:34) PietroAlbe PietroAlbe's gravatar image

Hai seguito le istruzioni ufficiali per l'avanzamento?

Vedo Windows XP, quindi non hai UEFI, prova a ripristinare GRUB come spiegato sulla guida ufficiale apposita.

(19 Ott '14, 11:39) dadexix86 ♦♦ dadexix86's gravatar image

Inoltre mi sembra strano quell'output di update-grub. Dovrebbe essere più complesso, e dare il percorso completo delle immagini, tipo

Trovata immagine linux: /boot/vmlinuz-3.13.0-38-generic
(19 Ott '14, 11:47) dadexix86 ♦♦ dadexix86's gravatar image

Durante la preparazione all'aggiornamento e' apparso un messaggio che avvisava che la mia scheda video avrebbe potuto non essere in grado di gestire la nuova versione. Ho ignorato il messaggio (mannaggia a me) e ho proseguito senza problemi di sorta.

L'output del comando update-grub e' come quello che indichi, ho solo aggiunto i puntini, mi premeva far notare la presenza dell'immagine di Windows

(19 Ott '14, 12:16) PietroAlbe PietroAlbe's gravatar image

@PietroAlbe: ecco che senza far scervellare nessuno, sai bene quale è l'origine del problema.
Se non le hai cerca di fare le copie poi, siccome credo che con la tua scheda video con la 14.04, salvo indicazioni di qualcuno più addentro al problema ci sia poco da fare, da parte mia, ammesso che la 12.04 non scherzi, ti suggerirei di tornare a quella e, a bocce ferme, cercare un rimedio.

(19 Ott '14, 12:43) enzoge enzoge's gravatar image

@PietroAlbe sei sicuro di non aver installato i driver proprietari?

Perché la tua scheda dovrebbe essere supportata da quelli liberi (secondo la ATI è obsoleta e quindi con i loro non la supportano più).

(19 Ott '14, 12:58) dadexix86 ♦♦ dadexix86's gravatar image

So benissimo @ilgallinetta che sia stata colpa mia, ma non pensavo di ritrovarmi in una situazione simile anche perche' come dice @dadexix86 e dalla documentazione letta prima di aggiornare la scheda video sembrava essere comunque supportata. Pensavo al massimo che avrei avuto dei rallentamenti, non che rendesse il pc inutilizzabile :-( Tornerei anche volentieri alla 12.04 o a qualsiasi versione, mi basta non perdere i dati, ma non sapendo bene come procedere senza fare ulteriori danni, ogni tipo di supporto e' gradito :-)

(19 Ott '14, 13:32) PietroAlbe PietroAlbe's gravatar image

@dadexix86 sinceramente non saprei se siano stati installati dei driver propietari, io mi sono limitato ad aggiornare Ubuntu senza modificare niente.

(19 Ott '14, 13:36) PietroAlbe PietroAlbe's gravatar image

Innanzitutto fatti un backup di tutti i dati che non vuoi perdere (bisognerebbe farlo indipendentemente da cosa si fa sul computer, un guasto fisico che ti brucia tutto può capitare in qualsiasi momento.)

Una volta fatto il backup, accedi da live e reinstalla la 12.04 da zero.

Dopo aver fatto il backup e prima di tornare alla 12.04, potresti provare a rimuovere i driver ATI

sudo apt-get --purge autoremove fglrx.

(nota il . alla fine del nome)

(19 Ott '14, 13:41) dadexix86 ♦♦ dadexix86's gravatar image

@PietroAlbe: infatti come ho scritto in precedenza, ora che si sa da dove arriva il problema, spero che qualcuno più addentro, ovvero che conosce meglio di me questa tematica, riesca ad aiutarti.

(19 Ott '14, 13:46) enzoge enzoge's gravatar image

scusami @dadexix86 ma come posso fare il backup avendo solo il terminale? Devo farlo tramite la versione live di Ubuntu?

Posso copiare il contenuto su un disco esterno o chiavetta USB?

Posso anche copiare il contenuto del disco (foto,musica,etc) di Windows /dev/sda1?

grazie

(19 Ott '14, 13:54) PietroAlbe PietroAlbe's gravatar image

@PietroAlbe: le copie potresti farle sia da terminale, usando l'istruzione cp (man cp), sia accedendo al sistema con la live in modalità prova. ;)

(19 Ott '14, 14:02) enzoge enzoge's gravatar image

Io accederei da live, ma si può anche fare con cp, gcp o rsync da terminale.

Perché io preferirei usare rsync o gcp a cp? Perché ti permettono di vedere il progresso e la velocità di trasferimento (anche se rsync necessita di comandi più complessi).
Fonte

(19 Ott '14, 14:19) dadexix86 ♦♦ dadexix86's gravatar image

ok, grazie per la pazienza @dadexix86, sto copiando i dati ci vorra' un'eternita :-(

(19 Ott '14, 16:25) PietroAlbe PietroAlbe's gravatar image

Prego, fammi sapere come va a finire :)

(19 Ott '14, 16:27) dadexix86 ♦♦ dadexix86's gravatar image

@dadexix86 Finalmente ho risolto :-) Dopo aver rimosso il driver fglrx ed installato il programma boot-repair, il pc e' nuovamente funzionante!!!

(23 Ott '14, 01:42) PietroAlbe PietroAlbe's gravatar image

Ottimo, allora scrivilo come riposta e accettala :)

(23 Ott '14, 05:56) dadexix86 ♦♦ dadexix86's gravatar image

Risolto rimuovendo il driver fglrx ed installato il programma boot-repair

coll. permanente

ha risposto 23 Ott '14, 17:53

PietroAlbe's gravatar image

PietroAlbe
30113

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,705
×439
×275
×209

domanda posta: 19 Ott '14, 10:56

domanda visualizzata: 1,442 volte

ultimo aggiornamento: 23 Ott '14, 17:53

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.