0
1

Ciao, sono un nuovo utente (inesperto).

Dopo avere eseguito istruzioni da terminale per loggarmi come root lUbuntu non è più partito. Ho seguito passo passo la seguente guida:

http://aranzulla.tecnologia.virgilio.it/come-loggarsi-come-root-ubuntu-30856.html

L'unica cosa che riesco a fare adesso è accedere alla schermata tty1 e loggarmi, come root o meno, ma quando lancio un qualsiasi programma ricevo la risposta "impossibile aprire il display".

Qualcuno riesce a darmi una mano?

Grazie.

chiesto 22 Ott '14, 12:30

Carmelo_19's gravatar image

Carmelo_19
1011

@Carmelo_19: perché seguire una guida per loggarsi per via grafica come root? Questa cosa è non solo inutile, ma anche pericolosa.
Probabilmente hai danneggiato il file seguente. Esegui il seguente comando:

cat /etc/lightdm/lightdm.conf

e copia il contenuto su http://pastebin.ubuntu.com/ e poi aggiungi un commento qui con l'indirizzo della pagina.

(22 Ott '14, 13:04) enzotib ♦♦ enzotib's gravatar image

Magari come passatempo puoi anche leggere questo :)

(22 Ott '14, 13:06) enzotib ♦♦ enzotib's gravatar image

Grazie!

uahah si, hai ragione, mi sento un imbecille :(

http://pastebin.ubuntu.com/8626997/

(22 Ott '14, 13:59) Carmelo_19 Carmelo_19's gravatar image

Per recuperare il sistema, rimuovi quel file, che non è necessario (di default non c'è):

sudo rm /etc/lightdm/lighdm.conf

Il consiglio del post non sembra del tutto sbagliato, ma ho provato anch'io, e almeno sulla versione attuale di Ubuntu, la 14.04 non funziona. Non so se magari funzionava su versioni precedenti e/o su altre versioni quali Xubuntu, Lubuntu, etc.

coll. permanente

ha risposto 22 Ott '14, 17:51

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Fatto, ho rimosso il file, ma niente, sono sempre bloccato su tty1.

In questo istante vedo: http://pastebin.ubuntu.com/8629488/

In particolare quando avvio compare per 1secondo la schermata di caricamento (LUbuntu con i pallini sotto) e subito passa a tty1. Se provo ad eseguire un qualsiasi programma mi torna: "Impossibile aprire il display"

(22 Ott '14, 18:29) Carmelo_19 Carmelo_19's gravatar image

PS: la gravante è che non posso nemmeno reinstallarlo perchè dopo aver sostituito il fastidioso Windows 8 con LUbuntu non riesco ad accedere più a Setup del BIOS (problema, questo, che devo risolvere con Lenovo), quindi non mi parte più nulla (USB/CD/DVD) tranne quanto descritto sopra.

(22 Ott '14, 18:30) Carmelo_19 Carmelo_19's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×30

domanda posta: 22 Ott '14, 12:30

domanda visualizzata: 743 volte

ultimo aggiornamento: 22 Ott '14, 18:30

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.