perchè nel installare programmi attraverso ubuntu software center non mi istalla il programma e mi mostra il messaggio d'errore come questo?

Le dipendenze dei pacchetti non possono essere risolte Questo problema potrebbe essere causato dalla mancanza o dalla possibilità di non installare pacchetti software aggiuntivi. Potrebbe inoltre esserci un conflitto tra pacchetti software che non possono essere installati nello stesso momento.

dettagli

I seguenti pacchetti presentano dipendenze non soddisfatte:

k3b: Depends: libc6 (>= 2.4) ma 2.15-0ubuntu20 sta per essere installato
     Depends: libgcc1 (>= 1:4.1.1) ma 1:4.7.2-2ubuntu1 sta per essere installato
     Depends: libk3b6 (= 2.0.2-5ubuntu1) ma 2.0.2-5ubuntu1 sta per essere installato
     Depends: libkcddb4 (>= 4:4.3.4) ma 4:4.9.2-0ubuntu1 sta per essere installato
     Depends: libkcmutils4 (>= 4:4.4.95) ma 4:4.9.5-0ubuntu0.1 sta per essere installato
     Depends: libkde3support4 (>= 4:4.4.4) ma 4:4.9.5-0ubuntu0.1 sta per essere installato
     Depends: libkdecore5 (>= 4:4.4.95) ma 4:4.9.5-0ubuntu0.1 sta per essere installato
     Depends: libkdeui5 (>= 4:4.5.85) ma 4:4.9.5-0ubuntu0.1 sta per essere installato
     Depends: libkfile4 (>= 4:4.7.0) ma 4:4.9.5-0ubuntu0.1 sta per essere installato
     Depends: libkio5 (>= 4:4.4.4) ma 4:4.9.5-0ubuntu0.1 sta per essere installato
     Depends: libknotifyconfig4 (>= 4:4.4.4) ma 4:4.9.5-0ubuntu0.1 sta per essere installato
     Depends: libqt4-dbus (>= 4:4.5.3) ma 4:4.8.3+dfsg-0ubuntu3.1 sta per essere installato
     Depends: libqt4-qt3support (>= 4:4.5.3) ma 4:4.8.3+dfsg-0ubuntu3.1 sta per essere installato
     Depends: libqt4-xml (>= 4:4.5.3) ma 4:4.8.3+dfsg-0ubuntu3.1 sta per essere installato
     Depends: libqtcore4 (>= 4:4.8.0) ma 4:4.8.3+dfsg-0ubuntu3.1 sta per essere installato
     Depends: libqtgui4 (>= 4:4.8.0) ma 4:4.8.3+dfsg-0ubuntu3.1 sta per essere installato
     Depends: libqtwebkit4 (>= 2.2~2011week36) ma 2.2.1-4ubuntu1 sta per essere installato
     Depends: libsolid4 (>= 4:4.4.4) ma 4:4.9.5-0ubuntu0.1 sta per essere installato
     Depends: libstdc++6 (>= 4.1.1) ma 4.7.2-2ubuntu1 sta per essere installato
     Depends: k3b-data (= 2.0.2-5ubuntu1) ma 2.0.2-5ubuntu1 sta per essere installato

spero di essere stato chiaro sulla domanda! attendo vostre risposte! grazie!

chiesto 19 Ago '13, 14:23

dyurone's gravatar image

dyurone
9111

modificato 19 Ago '13, 16:12

rpadovani's gravatar image

rpadovani ♦♦
3.1k51351

Ciao @dyurone,
hai per caso seguito guide esterne che ti dicevano di aggiungere dei PPA?

Ciao,
R.

(19 Ago '13, 16:13) rpadovani ♦♦ rpadovani's gravatar image

il problema è che non so cosa sia successo! ho lasciato giocare mio cugino di 11 anni e nel ritornare al miop lavoro mi sono accorto di questo problema! ma lui dice di non aver toccato nulla al di fuori del gioco!

(19 Ago '13, 23:53) dyurone dyurone's gravatar image

Fai una prova con:

sudo dpkg --force-all --configure -a
sudo apt-get -f install
sudo apt-get update
sudo apt-get -f dist-upgrade

Questi comandi li ho copiati da una pagina dove c'era il tuo stesso problema, vedi tu se usarli.ciao

coll. permanente

ha risposto 19 Ago '13, 14:38

agric's gravatar image

agric
1.5k111529

modificato 19 Ago '13, 16:13

rpadovani's gravatar image

rpadovani ♦♦
3.1k51351

ciao WebbyIT ♦♦

ho provato il tuo suggerimento ma non funziona! mi visuallizza lo stesso errore!

Le dipendenze dei pacchetti non possono essere risolte

Questo problema potrebbe essere causato dalla mancanza o dalla possibilità di non installare pacchetti software aggiuntivi. Potrebbe inoltre esserci un conflitto tra pacchetti software che non possono essere installati nello stesso momento.

(20 Ago '13, 00:00) dyurone dyurone's gravatar image

Prova così:

  • sudo apt-get autoremove --purge k3b
  • sudo apt-get update
  • sudo apt-get -f install
  • sudo apt-get dist-upgrade

Se non ti da più errore dai:

  • sudo apt-get install k3b

e vediamo che succede. Se quest'ultimo dovesse darti errore posta l'output di

  • ls /etc/apt/sources.list.d

Ah, per rispondere usa i commenti.

coll. permanente

ha risposto 20 Ago '13, 00:21

nico's gravatar image

nico
9833416

modificato 20 Ago '13, 00:22

ciao, controlla da sorgenti software se hai impostato da "server principale". ora dal terminale: sudo rm /var/lib/apt/lists/* -vf, puliamo eventuali in sospeso. adesso aggiorna il sistema con i tre comandi canonici: sudo apt-get update, sudo apt-get upgrade, sudo apt-get dist-upgrade. ho dato per scontato che tu abbia 12.04 o superiore.

coll. permanente

ha risposto 20 Ago '13, 00:24

dxgiusti's gravatar image

dxgiusti
1.3k211

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×114

domanda posta: 19 Ago '13, 14:23

domanda visualizzata: 2,427 volte

ultimo aggiornamento: 20 Ago '13, 10:23

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.