Buongiorno a tutti.
Ho un lettore barcode usb collegato in emulazione di tastiera su pc con SO Ubuntu14 che dovrebbe trasmettere il codice a barre letto in un'applicazione OpenOffice. Se apro la console e scannerizzo il risultato ottenuto e' quello scritto nel barcode. Se apro un terminale scrive solo la sequenza incomprensibile, oppure nell'applicazione in Oo Calc non scrive nulla. Sto migrando questa architettura da Windows7 con Oo in altri 4 pc con Ubuntu14 ed il problema lo riscontro su tutti. Tutti i font del barcode 3OF9 sono stati caricati correttamente durante l'installazione. Qualche idea?

chiesto 07 Gen '15, 10:54

Mau2608's gravatar image

Mau2608
29114

"Se apro la console" quale console?

Lo scanner barcode è compatibile con Linux? Necessita di driver proprietari? Marca/modello?

(07 Gen '15, 12:09) dadexix86 ♦♦ dadexix86's gravatar image

@Mau2608: non sarebbe male conoscere qualche dato sull'hardware, se il lettore è collegato in serie alla tastiera o in parallelo, se esiste qualche driver che hai installato e come funzione se lo usi con gedit anziché con Oo.

(07 Gen '15, 12:16) enzoge enzoge's gravatar image

Lo scanner e' Atlantis ScanBar LS1500 collegato in porta usb. Non ci sono driver proprietari ed ho provato anche con gedit ed il risultato e' il medesimo di calc di oo cioe' blank, con un salto del tabulatore dovuto alla configurazione che ho dato allo scan per saltare nella casella successiva alla fine della lettura del dato da barcode. Per "console" intendo l'apertura con CTRL+ALT+F1 e quando scannerizzo qui leggo esattamente il dato riportato nel barcode

(07 Gen '15, 18:04) Mau2608 Mau2608's gravatar image

Se al posto di gnome-terminal (il default di Ubuntu) usi xterm, continua a mostrarti roba sconclusionata?

(07 Gen '15, 18:19) dadexix86 ♦♦ dadexix86's gravatar image

si! e se faccio piu' di uno scan si blocca.

(07 Gen '15, 18:28) Mau2608 Mau2608's gravatar image

Che versione di Ubuntu 14 usi? Hai provato con la 12.04?
Da quanto dici sembra che a carattere funzioni bene, fa uguale anche con la finestra di terminale consigliata da @dadexix86?
Tempo fa a me era capitato che non leggeva il CR e dopo la lettura dovevo premere l'invio, guarda che per caso non sia così, magari togli il CR automatico leggi e premi l'invio. Altrimenti si direbbe che la grafica non lo riconosca o che ci sia qualcosa da cambiare nelle impostazioni.

(07 Gen '15, 18:32) enzoge enzoge's gravatar image

@Mau2608: prova a togliere la tabulazione di fine lettura e vedi se cambia!

(07 Gen '15, 18:45) enzoge enzoge's gravatar image

dalle svariate prove che ho fatto in questi ultimi giorni mi sembra che sia la grafica che non decodifica il barcode. Questo supportato dal fatto che senza grafica funziona. domani comunque provo a togliere il tab in automatico che ho memorizzato e provo. la versione è 14.04.1 LTS release 14.04. se non riesco provero' anche con la 12.04....

(07 Gen '15, 18:49) Mau2608 Mau2608's gravatar image

e se faccio piu' di uno scan si blocca

Di preciso cosa si blocca? Il terminale o lo scanner? Si blocca anche senza grafica?

(07 Gen '15, 20:42) dadexix86 ♦♦ dadexix86's gravatar image
-1

Oh, ottimo!

Allora per favore scrivi una risposta e accettala, così viene segnata come risolta la domanda :)

(08 Gen '15, 10:12) dadexix86 ♦♦ dadexix86's gravatar image

modificando il settaggio dello scanner ho risolto! ci sono due modi di input dati al pc 1. in emulazione di tastiera 2. solo tastiera. avevo memorizzato Emulazione di Tastiera invece serviva solo Tastiera.....!!! adesso funziona sia con il CR che con il Tab. Grazie della collaborazione

coll. permanente

ha risposto 08 Gen '15, 10:10

Mau2608's gravatar image

Mau2608
29114

@Mau2608: mi fa molto piacere che tu abbia risolto facendo quanto ti ho suggerito nel mio quintultimo commento:
"Tempo fa a me era capitato che non leggeva il CR e dopo la lettura dovevo premere l'invio, guarda che per caso non sia così, magari togli il CR automatico leggi e premi l'invio. Altrimenti si direbbe che la grafica non lo riconosca o che ci sia qualcosa da cambiare nelle impostazioni."

(08 Gen '15, 11:33) enzoge enzoge's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×86

domanda posta: 07 Gen '15, 10:54

domanda visualizzata: 2,637 volte

ultimo aggiornamento: 08 Gen '15, 12:31

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.