Ciao, ho un problema con transmission. Utilizzandolo con ubuntu 14, mi risulta molto lento (3 o 4 k/s!!). Nelle preferenze ho controllato e la porta in ascolto risulta chiusa. il forwarding UPnP del modem è abilitato ma pare non funzionare qualcosa. Il mio router è Wi-Fi Router X4 N300

Sapete come posso procedere?

chiesto 10 Gen '15, 20:00

teo's gravatar image

teo
23447

modificato 10 Gen '15, 20:34

Mi stavo chiedendo la stessa cosa. Mi trovo su un laptop in cui fino qualche giorno fa avevo windows 7 e tramite bittorrent scaricavo in maniera decente, mentre con Transmission e Ubuntu 14.04 è a dir poco imbarazzante.

(10 Gen '15, 21:54) Gamby Gamby's gravatar image

È strano che non funzioni.

L'UPNP su quale porta viene redirezionato dal router? Hai messo quella porta su transmission?

Non è che hai anche abilitato il firewall in Ubuntu?

E se apri la porta di transmission invece funziona?

(10 Gen '15, 22:00) dadexix86 ♦♦ dadexix86's gravatar image

Dalle impostazione del mio router posso solo abilitare UPNP ma no so dove verificare au quale porta sia redirezionato.

Per sapere se il firewall è attivo e nel caso per disattivarlo?

Provato ad aprire la porta di transmission ma non so bene come inserire i dati che mi chiede, io li ho configurati così ma non succede nulla...

  Enable Virtual Server
Local IP    Local Port  Type    Public Port     Comment

Current Virtual Server Table:
NO.     Local IP    Local Port  Type    Public Port     Comment     Select
1   192.168.0.100   51413   TCP 51413
(10 Gen '15, 22:30) teo teo's gravatar image

Di default il firewall su Linux è disattivo. Guarda ad esempio la guida ufficiale al firewall per più info.

Ma sul router hai aperto la 51413?

Ti consiglio di fare una lettura alla sezione specifica della guida di Transmission

(10 Gen '15, 22:35) dadexix86 ♦♦ dadexix86's gravatar image

Dunque credo che sia attivo il firewall e questa la situazione che mi compare http://paste.ubuntu.com/9707816/

Sul router ho provato ad aprire la porta ma non so se i dati inseriti sono corretti:

Enable Virtual Server
Local IP    Local Port  Type    Public Port     Comment

Current Virtual Server Table:
NO.     Local IP    Local Port  Type    Public Port     Comment     Select
1   192.168.0.100   51413   TCP 51413
(10 Gen '15, 22:45) teo teo's gravatar image

Non mi sembra che sia attivo :)

Dai un'occhiata a GUFW per un'interfaccia grafica alla gestione del firewall.

Se l'IP del tuo computer è 192.168.0.100 allora dovrebbe essere aperta sul router. Chiudi Transmission, riaprilo e riprova.

(10 Gen '15, 22:50) dadexix86 ♦♦ dadexix86's gravatar image

Grazie dadexix86, seguendo le tue indicazioni sono riuscito ad aprire la porta di transmission agendo nelle pagine di conf del router.

Non che la situazione sia molto migliore di prima ma giusto un pelino.

Chissà come mai con BitTorrent e Windows non ho mai dovuto agire sul router ed il download rate è sempre stato nettamente più alto di quello che sto riscontrando con Transmission + Ubuntu.

(10 Gen '15, 22:56) Gamby Gamby's gravatar image

@Gamby le prove le fai con lo stesso Torrent con tanti nodi (tipo le iso di Ubuntu)? Se sì, è possibile che il tuo provider blocchi o limiti il traffico p2p da Linux, prova a controllare con il tuo provider se ha queste limitazioni :)

(10 Gen '15, 23:14) dadexix86 ♦♦ dadexix86's gravatar image

Ancora niente. L'IP dovrebbe essere quello ma poi mi chiede di inserire local port (e io ho messo quella predefinita da transmission 51413) e Public port e li non so cosa inserire (rimettendo 51413 non funziona!)

(10 Gen '15, 23:18) teo teo's gravatar image

Come public port devi mettere una porta che il tuo provider ti apre verso l'esterno.

Prova a contattarli e chiedere quali porte puoi usare :)

(10 Gen '15, 23:28) dadexix86 ♦♦ dadexix86's gravatar image

come provider ho fastweb, può essere utile saperlo?

Con utorrent non avevo mai avuto tutte queste dificoltà...

(10 Gen '15, 23:38) teo teo's gravatar image

Se pensi di trovarti meglio, sembra che tu possa installare utorrent anche su Ubuntu (ma non l'ho mai fatto, dato che non ho mai avuto problemi con i client di default).

(10 Gen '15, 23:52) dadexix86 ♦♦ dadexix86's gravatar image

Modifica>Preferenze>Privacy. Abilita la blocklist inserendo: http://list.iblocklist.com/?list=bt_level1&fileformat=p2p&archiveformat=gz quindi clicca su "Aggiorna". Al termine chiudi e riapri transmission.

(11 Gen '15, 16:26) Beppe Beppe's gravatar image

Grazie Beppe, ho provato ma non è cambiato molto. Per ora ho risolto connettendo direttamente il pc al modem e bypassando il router che a questo punto uso solo per la vifi degli altri dispositivi. La velocità in questo modo è salita a livelli più normali, intorno ai 60kB/s

(11 Gen '15, 19:51) teo teo's gravatar image

@teo: l'output del mio sudo iptables -L è molto più breve e semplice.
Per cancellare tutte le (eventuali) regole del firewall puoi eseguire i comandi:

sudo iptables -F
sudo iptables -F -t filter
sudo iptables -F -t nat
sudo iptables -F -t mangle
sudo iptables -F -t raw
sudo iptables -F -t security

però se effettivamente sono impostate, allora c'è qualche comando o servizio che lo fa, e quindi al riavvio lo rifarà.

(11 Gen '15, 19:57) enzotib ♦♦ enzotib's gravatar image

ma potresti provare Qbittorrent

(11 Gen '15, 20:00) Alien_X Alien_X's gravatar image

La porta continua a restare chiusa...la velocità max è intorno ai 70-80 kB/s...prima di passare a qbittorrent volevo capire se posso fare altro perche transmission mi sembra ben fatto.

Il mio operatore è fastweb e so che forse non garantisce un IP pubblico...può voler dire qualcosa?

(12 Gen '15, 19:21) teo teo's gravatar image

Prima di fare ulteriori prove, scarica deluge e vedi se va più veloce. Ricordo che funzionava particolarmente bene sotto rete fastweb, non sarà leggero come transmission (python vs C) ma è molto valido.

(12 Gen '15, 19:38) dslul dslul's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×7

domanda posta: 10 Gen '15, 20:00

domanda visualizzata: 1,858 volte

ultimo aggiornamento: 12 Gen '15, 19:38

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.