Buongiorno ragazzi,

da qualche giorno non riesco più ad autenticare gli utenti che erano registrati nel mio ubuntu 14.04 LTS.

Considerate che le password non sono state affatto dimenticate/perse e che nella modalità di recovery da terminale si riesce a modificare queste loro password e a creare nuovi utenti.

Sicuramente mi chiederete che il problema allora non si pone, e invece esiste veramente in quanto l'utente con la password cambiata da terminale non combacia nemmeno con quella digitata nell'ambiente desktop. E' come se l'ambiente del terminale fosse diverso dall'ambiente desktop.

Voi sapreste dirmi che cosa è successo? Vi ringrazio enormemente da adesso. Ciao e grazie a tutti per le risposte.

chiesto 12 Gen '15, 11:40

plug's gravatar image

plug
763711

reverted 14 Gen '15, 19:20

enzotib's gravatar image

enzotib ♦♦
14.0k112186

@plug: giusto una domanda sciocca: hai una sola versione del sistema installato sul disco, o magari un boot multiplo con diversi OS?

(12 Gen '15, 11:43) enzotib ♦♦ enzotib's gravatar image

Si, ho diversi sistemi installati.

  • windows vista 32 bit
  • ubuntu 12.04 lts (da disinstallare)
  • altra installazione ubuntu 14.04 che devo togliere perche non la sto più usando
  • partizione ntfs che uso per archiviare dati
(12 Gen '15, 11:51) plug plug's gravatar image

La password che inserisci al login è diversa da quella da terminale (non recovery) o da quella che ti chiede graficamente?

(12 Gen '15, 11:53) dslul dslul's gravatar image

Allora: dal momento che non riesco a fare l'autenticazione da login grafico del desktop, questo non lo posso sapere perchè al terminale non posso più accedervi.

Le procedure di autenticazione che si hanno sono solamente queste, la classica autenticazione di login di ubuntu che non funziona più e quella del recovery.

Di altre non ne sono a conoscenza

(12 Gen '15, 12:11) plug plug's gravatar image

@plug: non usare le risposte, usa i commenti.

(12 Gen '15, 12:17) enzotib ♦♦ enzotib's gravatar image

@plug: in realtà quando avvii il sistema in modalità di recovery non dovrebbe servire alcuna password. Inoltre, dall'ambiente grafico, premendo Ctrl-Alt-F1 dovrebbe apparirti una schermata a caratteri dove puoi autenticarti, prova.
Infine ti chiedo, quando inserisci la password al login ti dice che è sbagliata, oppure ritorna subito alla schermata di login?

(12 Gen '15, 12:21) enzotib ♦♦ enzotib's gravatar image

@plug, e poi scusa, dichiari di dover disinstallare la 12.04, di dover togliere la 14.04, quindi alla fine a che ti serve rimettere a posto il sistema?

(12 Gen '15, 12:22) enzotib ♦♦ enzotib's gravatar image

Si questo terminale con ctrl+alt+f1 in effetti funziona anche con le password che non mi accettava prima per tutti gli utenti del sistema.

Quando inserisco 'la password al login', suppongo ti riferisci all'ambiente grafico del desktop,la devo reinserire perche compare il messaggio: avvio della sessione non riuscito.

Ma quello che più mi preme è questo: quello di potermi loggare nell'ambiente grafico

Le versioni della 12.04 e l'altra di 14.04 corrotta le dovrò levare appena possibile

(12 Gen '15, 12:38) plug plug's gravatar image

Come ha affermato enzotib, devi cancellare il sistema operativo in questione? Se si, allora ti conviene entrare da live per salvare i dati, in caso contrario, assicurati con group nomeutente di non appartenere al gruppo root

(12 Gen '15, 12:48) dslul dslul's gravatar image

@plug: se ti dice "avvio della sessione non riuscito" il problema non è la password, è altrove.

(12 Gen '15, 13:06) enzotib ♦♦ enzotib's gravatar image

Tenete conto che delle due versioni di 14.04, una la devo certamente eliminare, equesta, che adesso ha problemi di password e che forse risolverò con un aggiornamento dei pacchetti se ne riesco a recuperare la connessione internet dal terminale

(12 Gen '15, 13:06) plug plug's gravatar image

Potresti postare uno screen o una foto dell'errore che ti da quando cerchi di fare il login?

(12 Gen '15, 13:23) dslul dslul's gravatar image

In questo momento non ho possibilità di fare foto allo schermo: comunque ti voglio rappresentare graficamente il semplice messaggio che mi compare:

Utente
Avvio della sessione non riuscito

E in effetti è proprio come dice enzotib, non è un problema di password sbagliata, ma altra cosa... Perchè in effetti se fosse un problema di password inserita male sarebbe:

Utente
Password non valida, riprovare

ps: scusami di nuovo per l'assenza di foto ma spero che si capisca lo stesso

(12 Gen '15, 18:39) plug plug's gravatar image

Si si capisce lo stesso, a questo punto prova a dare da tty1 (ctrl alt f1 e logga con user e pass):

sudo cat /var/log/lightdm/lightdm.log

e posta qui il risultato

(12 Gen '15, 18:45) dslul dslul's gravatar image

dslul, non posso comunicare con quella macchina perche ora è isolata.

Mi potresti dire come salvare il messaggio in una usb? Così ti potrei mandare con altro pc il tutto.

(12 Gen '15, 19:03) plug plug's gravatar image

puoi redirigere l'output su file e poi trasferirlo su una usb

sudo cat /var/log/lightdm/lightdm.log > output.log

Prima prova questi comandi che ho trovato in rete relativi al tuo problema:

sudo apt-get install ubuntu-desktop
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install ubuntu-session
sudo apt-get install --reinstall ubuntu-session
sudo dpkg-reconfigure -a

Uno di questi potrebbe risolvere il tuo problema. I vari --reinstall sono solo in caso tu abbia già quel pacchetto, ma se hai dubbi puoi eseguirli tutti.

(12 Gen '15, 19:14) dslul dslul's gravatar image

E' un problema perchè non mi è possibile andare in rete. Prima usavo la macchina con il wifi e un modem-router wireless. Ho visto che la cheda wireless della macchina vede il modem-router ma ora non si connette

(12 Gen '15, 19:21) plug plug's gravatar image

Non puoi collegarlo col cavo? Casomai prova solo i comandi con il reinstall sperando che quei pacchetti siano nella cache di apt e dai il reconfigure (ultimo comando)

(12 Gen '15, 19:35) dslul dslul's gravatar image

dslul dovrei salvare ancora le ultimi file su pendrive e non vorrei che facendo questa operazione mi compromettesse la cosa.

Tu potresti darmi qyalche dritta nel come farmi riconoscere la mia pennina usb, poi potrò proseguire sulla riconfigurazione

(12 Gen '15, 20:41) plug plug's gravatar image

Sono sicuri quei comandi, comunque qui c'è la guida dalla wiki per montare la pendrive: http://wiki.ubuntu-it.org/Hardware/DispositiviPartizioni/MontarePartizioni/Fat

(12 Gen '15, 20:47) dslul dslul's gravatar image

-sudo dpkg-reconfigure -a

Ho seguito i passaggi indicati ma solo uno risulta funzonante, l'ultima riga che vedi, il sudo dpkg-reconfigure -a che ovviamente non avrebbe senso in quanto la rete non permette di scaricare.

Quello che si potrebbe fare è riabilitare l'adattatore wifi atheros ar242 è in grado di vedere col comando iwlist scan, il mio modem-router wifi, ma non riesco a connetterlo!

Secondo te è meglio continuare questa domanda per trovare la soluzione oppure quella di aprirne un altra?

(14 Gen '15, 10:56) plug plug's gravatar image

Scusa errore mio, l'opzione -a non esiste più. Prova questi:

sudo dpkg-reconfigure ubuntu-session
sudo dpkg-reconfigure ubuntu-desktop
sudo dpkg-reconfigure lightdm

Comunque se riesci guarda le ultime righe di sudo cat /var/log/lightdm/lightdm.log e vedi se vedi qualche errore e ricopialo qui.

(14 Gen '15, 11:16) dslul dslul's gravatar image

so che esiste un servizio del forum per copiare velocemente un file di testo lunghetto... sai dirmi qualcosa?

(14 Gen '15, 12:22) plug plug's gravatar image

http://paste.ubuntu.com/

Quei comandi qui sopra non hanno risolto? Comunque modifica il titolo dal momento che il problema non è più la password.

(14 Gen '15, 13:02) dslul dslul's gravatar image

Grazie delle info sul funzionamento del sito, le cercavo senza risposta..

(14 Gen '15, 17:31) plug plug's gravatar image

aspetta!

Ti voglio far vedere il file lightdm.log, vedi se riesci a vedere qualcosa..

(14 Gen '15, 17:48) plug plug's gravatar image

No, non ho risolto, cercherò ancorà... grazie nel frattempo. Un altra cosa dsful. Ti ringrazio per la disponibilità nell'indirizzarmi verso la soluzione.

(14 Gen '15, 18:07) plug plug's gravatar image

Se hai un cellulare android hai risolto il problema della connessione, ti basta condividere la connessione (anche wifi) via cavo usb e ubuntu te la riconosce come se fosse via ethernet, a quel punto provi quei comandi e speri

(14 Gen '15, 19:03) dslul dslul's gravatar image

@plug: ma che cavolo fai, prendi una domanda e la stravolgi completamente modificandola?
Se hai un'altra domanda scrivi un altro post.

(14 Gen '15, 19:21) enzotib ♦♦ enzotib's gravatar image

sono spiacente della cosa, proverò a togliere l'errore

(14 Gen '15, 19:26) plug plug's gravatar image

@plug: non c'è nessun errore da togliere, ho ripristinato io la domanda a com'era prima.
Cambiare completamente il testo di una domanda invalida i commenti e le risposte già scritte, quindi è una cosa che non si fa.

(14 Gen '15, 19:50) enzotib ♦♦ enzotib's gravatar image

Va bene, chiedo intanto scusa per l'uso improprio per il proseguo della domanda.

Provvederò a riformulare altra domanda per il proseguimento della questione.

(14 Gen '15, 20:09) plug plug's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×73
×47

domanda posta: 12 Gen '15, 11:40

domanda visualizzata: 1,459 volte

ultimo aggiornamento: 14 Gen '15, 20:09

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.