Salve,

da pochi giorni sulla versione 14 04 lts di LUBUNTU già installata in dual boot con windows XP, alla schermata iniziale mi compare questo messaggio: L'unità disco per /Windows non è ancora pronta o non è operante. Attendere oppure premere S per omettere il mount o M per il ripristino manuale. Io premo S e Lubuntu si avvia normalmente.

Ho provato a premere M ricevendo questo messaggio:

File  system check for mount failed.
a maintenance shell will now be started.
control-d will terminate this shell and continue booting after re-trying file system.
Any further errors will be ignored
root@pino-kt600-8237: #

a questo non capisco se bisogna dare un comando e quale.

chiesto 15 Gen '15, 23:16

oneppe's gravatar image

oneppe
305911

modificato 19 Gen '15, 11:00

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161


Durante l'installazione hai montato il disco di Windows, e questo ha impostato il mount automatico al'avvio, come segnalato nel file /etc/fstab.

# /windows was on /dev/sda2 during installation UUID=CC66-631A /windows vfat utf8,umask=007,gid=46 0 1

Per rimuovere il problema ti basta quindi aprire il file in questione con i privilegi di super utente e commentare la riga incriminata.

  1. Innanzitutto fai un backup del file

    sudo cp /etc/fstab /etc/fstab.bak
    
  2. Aprilo con un editor di testo (se usi Ubuntu avrai probabilmente Gedit installato, altrimenti adatta il seguente comando alle tue esigenze)

    gksudo gedit /etc/fstab
    
  3. Aggiungi un # davanti alla riga in cui viene montata la partizione, facendola diventare

    # UUID=CC66-631A  /windows        vfat    utf8,umask=007,gid=46 0       1`
    
  4. Salva il file e chiudi il programma

  5. Riavvia e controlla che si sia risolto il problema.

coll. permanente

ha risposto 17 Gen '15, 21:29

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

modificato 17 Gen '15, 21:29

Il comando: sudo cp /etc/fstab /etc/fstab.bak è al sistema operativo? Nel senso che non deve restituire alcun messaggio, dopo la richiesta di inserimento pw? Comunque, continuando, avendo lubuntu ho digitato: gksudo leafpad /etc/fstab e nel file apertosì ho inserito la # come suggerito, salvato, chiuso programma, riavviato e il problema si è risolto. GRAZIE. Adesso dovrei mettere risolto, ma ancora devo capire come fare.

(17 Gen '15, 23:55) oneppe oneppe's gravatar image

Se non dà output il comando cp (che sta per copia) è andato a buon fine :)

Per accettare la risposta devi cliccare sul simbolo "v" a sinistra di essa, sotto le manine. Questa segna la domanda come risolta.

Alla prossima! :)

(18 Gen '15, 00:00) dadexix86 ♦♦ dadexix86's gravatar image

Evidentemente hai impostato il mount automatico della partizione di Windows in Lubuntu.

Prova ad avviare Windows, fare un check della sua partizione da lì, poi riavviare in Windows, e poi riavviare in Lubuntu. Probabilmente per qualche motivo hai chiuso Windows in modo non corretto e la partizione è rimasta in uno stato tale che Lubuntu non può montarla.

coll. permanente

ha risposto 16 Gen '15, 07:21

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Sia su windows xp sia su lubuntu, per quello che capisco, non individuo niente di anomalo. Windows vede tutte le partizioni con le caratteristiche che ho assegnato. Chiaramente non riconosce il file system per la partizione su cui è installato lubuntu e l'area di swap. In lubuntu aprendo ilgestore file PCMManFM tutte le partizioni sono montate tan'è che con il click destro possono essere solo smontate. Per essere più esatti è il floppy disk che potrebbe essere montato ma non riesco a farlo perchè il comando riceve un messaggio di errore. Dopo l'avvio di windows ho dato il comando di pulizia disco e di controllo e correzione del file system, ma al riavvio di lubuntu non è scomparso il messaggio per cui chiedo aiuto. Aprendo gparted la partizione su cui è installato windows non ha punto di mount /windows e il suo flag è in boot. Forse potrei con gparted eliminare la partizione linux swap per creare spazio per una partizione primaria (la quarta) riducendo, senza formattare, la partizione di windows e assegnargli il punto di mount /windows?

(16 Gen '15, 16:01) oneppe oneppe's gravatar image

A meno di ripondere alla tua domanda, usa i commenti, grazie.

(16 Gen '15, 16:39) dadexix86 ♦♦ dadexix86's gravatar image

E posta anche per favore su pastebin il contenuto del file /etc/fstab.

(16 Gen '15, 16:39) dadexix86 ♦♦ dadexix86's gravatar image

Chiedo scusa per l'errore. Finora ho installato pastebinit con il gestore di pacchetti. Il comando /etc/fstab è not found. Cosa sbaglio?

(16 Gen '15, 17:06) oneppe oneppe's gravatar image

@onepeppe: però non capisco, se all'avvio non ti dà più l'errore (hai scritto "ma al riavvio di lubuntu non è scomparso il messaggio per cui chiedo aiuto."), allora il problema è risolto (sarebbe anche bene, in tal caso, accettare la risposta). Per problemi diversi da quello della domanda, per cortesia apri un'altra domanda.
Se invece il problema non è risolto, per cortesia spiega meglio cos'è ancora che non va.

(16 Gen '15, 17:51) enzotib ♦♦ enzotib's gravatar image

No, il problema non è risolto. Infatti ho scritto che il messaggio, per cui chiedo aiuto, non è SCOMPARSO. Al riavvio di lubuntu compare sempre : L'unità disco per /Windows non è ancora pronta o non è operante. Attendere oppure premere S per omettere il mount o M per il ripristino manuale. Ritornando al comando not found se digito cat /etc/fstab ricevo un risultato a terminale. E' quello che dadexix86 mi chiede?

(16 Gen '15, 18:44) oneppe oneppe's gravatar image

@oneppe: scusa, avevo letto male. Il comando che diceva @dadexix86 è

pastebinit /etc/fstab

ti esci come risposta un indirizzo che posto qui in un commento.

(16 Gen '15, 19:24) enzotib ♦♦ enzotib's gravatar image

Come ti ho detto, quello è un file. Al posto del comando datoti da @enzotib lo puoi semplicemente aprire e copiarne il contenuto nel sito di pastebin che scegli (ad esempio paste.ubuntu.com)

(16 Gen '15, 22:23) dadexix86 ♦♦ dadexix86's gravatar image

Devo copiare in firefox questo indirizzo? Ho già provato(su altro computer) a farlo e si apre un paste from coneppe (sempre io) con un elenco di 12 righe. E' questo il file che vuole vedere dadexix86?

(17 Gen '15, 14:03) oneppe oneppe's gravatar image

Sì, esattamente :) Il link devi metterlo qui in un commento, così che possiamo vedere anche noi il contenuto di quel file.

(17 Gen '15, 14:10) dadexix86 ♦♦ dadexix86's gravatar image

Ok. Sul computer in questione sto facendo cambiare la cpu.Forse piu' tardi sono in grado di metterlo in ulteriore commento. Grazie.

(17 Gen '15, 14:16) oneppe oneppe's gravatar image
(17 Gen '15, 16:37) oneppe oneppe's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×292

domanda posta: 15 Gen '15, 23:16

domanda visualizzata: 1,209 volte

ultimo aggiornamento: 19 Gen '15, 11:00

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.