Sono nuovo di Lubuntu, che ho installato con soddisfazione su un vecchio portatile, ma ho un problema che, se non riesco a risolvere, mi costringerà ad abbandonalo.

Si tratta di questo: dopo un periodo imprecisato di tempo di inattività, lo schermo si fa buio e non riesco più a farlo riaccendere. Il sistema resta attivo, ma lo schermo no. Per sbloccare la situazione occorre premere brevemente il tasto di spengimento. A quel punto la macchina avvia la procedura di chiusura di LUBUNTU. Appare lo splash screen di chiusura ed il pc si spenge.

Naturalmente il lavoro non salvato va perduto. Capite la seccatura.

Ho provato varie strade, ma non sapendo di preciso quale sia il programma responsabile, non riesco ad inibirlo.

Ho provato ad installare anche caffeine e caffeine-plus, ma non sembrano funzionare correttamente.

Ho controllato e non è settato nessun parametro di risparmio energetico a livello di BIOS.

Essendo nuovo di Lubuntu mi sono mosso un po' in ordine sparso, per cui può darsi che abbia arruffato il sistema, ma forse qualcuno può aiutarmi a risolvere questo problema!

chiesto 22 Gen '15, 14:36

FH70's gravatar image

FH70
20113

Qual è l'harwdare del computer?

(22 Gen '15, 15:14) dadexix86 ♦♦ dadexix86's gravatar image

Si tratta di un portatile (Marca Fujitsu Siemens) con Intel Celeron M 1,7Ghz e 1GB ram

(22 Gen '15, 15:28) FH70 FH70's gravatar image

Ok, riproviamoci :)

Quale scheda video hai?
Quale scheda di rete?
Quale scheda audio?
Quale scheda madre?

(22 Gen '15, 15:30) dadexix86 ♦♦ dadexix86's gravatar image

E' un portatile vecchiotto, nato con XP. La scheda video è una VIA S3 Unicrome PRO che usa 64mb in condivisione (riducibili via bios a 32 o 16) Come rete uso solo il wifi, per cui la scheda è una Atheros 5005g. La scheda audio è una VIA 8237 con processore REALTEK ALC655 (rev.0) La scheda madre credo sia proprietaria Fujitsu Siemens ed è dotata di Intel Celeron M 390 core dothan da 1.7GHz con 1MB di cache di secondo livello, 400MHz di Front Side Bus, 1Gb di memoria Ram, HD 40Gb.

(22 Gen '15, 16:34) FH70 FH70's gravatar image

Direi che abbiamo trovato il problema, la VIA S3 Unichrome ;)

E direi che non ho la più pallida di se e come possa essere ancora supportata, dato che l'azienda produttrice si è sempre rifiutata di supportare Linux :)

(22 Gen '15, 19:19) dadexix86 ♦♦ dadexix86's gravatar image

Può darsi che sia come tu dici, tuttavia non sono convinto. Infatti il pc non solo funziona sotto lubuntu da 3 mesi (anche l'installazione è andata liscia), ma anche le varie live che ho provato non hanno dato particolari problemi (per esempio GParted o REDO backup che ho utilizzato per diverse volte quando il pc lavorava sotto xp). Anche adesso sto lavorando con questo pc sotto lubunto, e non ho problemi. Ma se rispondo al telefono o mi assento per 20 minuti, può darsi (non sempre!) che quando torno trovi lo schermo spento. E talvolta, anche se è spento, magari si riaccende muovendo il mouse.

(22 Gen '15, 21:04) FH70 FH70's gravatar image

Il punto è che ci deve essere in Lubuntu da qualche parte la possibilità di inibire lo spengimento dello schermo per inattività, così come c'è sotto windows fin dalle versioni 3.0

Anche se l'HW è quello che è, per me il problema è fondamentalmente di tipo SW. Per esempio se è XFCE il responsabile dello spengimento ci dovrebbe essere il modo di inibirlo o, al limite, di disinstallarlo.

Non credi?

(22 Gen '15, 21:04) FH70 FH70's gravatar image

Sì, sì, certo :)

Se il tuo scopo è disabilitare lo spegnimento (cosa che non era chiara fino ad ora!) puoi provare a seguire questa guida, se non funziona quest'altra e farmi sapere come va :)

(22 Gen '15, 21:09) dadexix86 ♦♦ dadexix86's gravatar image

Ho guardato le guide suggerite ed ho fatto un po' di prove, ma non ho trovato soluzioni risolutive al mio problema. Dopo 10' il video si spengeva e dopo altri 10' si bloccava. Tuttavia mi hanno messo -credo- sulla strada giusta.

(24 Gen '15, 18:10) FH70 FH70's gravatar image

Se da terminale do il comando:

xset s off

il timeout dello screensaver è valorizzato a 0, ed il problema (aspettando un bel po') sembra risolto.

Purtroppo io sono inesperto di Linux e non so come fare in modo che quando la macchina si avvia esegua in automatico questa istruzione. In DOS l'avrei messa nel CONFIG.SYS o nell'AUTOEXEC.BAT, a seconda dei casi, ma qui non so che file editare. Suggerimenti?

(24 Gen '15, 18:11) FH70 FH70's gravatar image

Scusami se non ho risposto prima :)

Quel comando lo dai così oppure con sudo davanti?

Comunque dai un'occhiata alla stessa domanda su Ask :)

(25 Gen '15, 16:10) dadexix86 ♦♦ dadexix86's gravatar image

a me funziona anche senza sudo. Ho visto la risposta su ask, ma sono così ignorante di linux che i file .xsessionrc e .xinitrc non so dove trovarli e neppure come cercarli, dato che con mc non mi saltano fuori (di sicuro sbaglio io!)

(25 Gen '15, 18:06) FH70 FH70's gravatar image

Eureka! Ho postato:

sudo gedit ~/.xsessionrc

il file non esisteva, quindi l'ho creato e vi ho scritto:

#!/bin/bash
xset dpms 0 0 0
xset dpms off
xset s off

l'ho salvato ed ho resettato il pc.
Al riavvio ho dato:

xset q | grep -A 2 "Screen Saver"

ed il risultato è stato:

Screen Saver: prefer blanking: yes allow exposures: yes timeout: 0 cycle: 600

Con timeout=0, e non 600, come di default. Idem dicasi con

xset q | grep -A 2 "DPMS"

quindi funziona!

Grazie! Se scrivi la risposta te la convalido (si fa così, vero?) Ciao

(25 Gen '15, 20:20) FH70 FH70's gravatar image

Davanti !/bin/bash c'è il cancelletto, ma non mi riesce a farlo apparire

(25 Gen '15, 20:21) FH70 FH70's gravatar image

Accidenti. Non capisco. Non funziona. Se setto le variabili da terminale, funziona. Se le setto con lo script non funziona. O meglio, funziona ma non come mi aspettavo. Adesso lo screen saver non interviene ma il sistema va direttamente in modalità sospesa, e quando riparte il video è out (probabilmente per l'incompatibilità della sk video che dicevi). Per oggi può bastare. Farò altre prove domani. Sono comunque fiducioso. :-))

(25 Gen '15, 20:29) FH70 FH70's gravatar image

Per favore quando scrivi codice usa la sintassi corretta, che altrimenti è illeggibile :)

Potresti provare a creare uno script simile a quello che hai creato e metterlo nelle applicazioni di avvio.

(26 Gen '15, 19:25) dadexix86 ♦♦ dadexix86's gravatar image

Una volta inibito lo screensaver con lo script di cui sopra accodato a .xsessionrc, il pc dopo 10 minuti di inattività andava in stand-by, e non ne usciva più probabilmente per l'incompatibilità con linux da te evidenziata della scheda video.

Questo problema è da imputarsi a xfce4-power-manager che è nella dotazione standard di Lubuntu e che presenta un noto bug.

Per superare il problema ho sostituito la versione 1.2 con la successiva 1.4.01 che ha risolto il bug.

Per fare questo ho seguito questa guida:

http://forum.xfce.org/viewtopic.php?id=9149

Come faccio a segnare RISOLTO?

(29 Gen '15, 19:39) FH70 FH70's gravatar image

Ah, ottimo! :D Scrivi una risposta e la accetti :)

(29 Gen '15, 19:58) dadexix86 ♦♦ dadexix86's gravatar image

Se il pc va in stand-by a prescindere dalle impostazioni di xfce4-power-manager questo va imputato ad un noto bug della versione 1.2 di questo programma. Per risolvere il problema in Lubuntu 14.04 occorre aggiornare xfce4-power-manager alla versione 1.4.1.

Purtoppo l'operazione non è poi così immediata. Io per effettuarla consiglio di seguire questa guida che mi ha risolto il problema.

http://forum.xfce.org/viewtopic.php?id=9149

coll. permanente

ha risposto 30 Gen '15, 10:07

FH70's gravatar image

FH70
20113

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×73
×2

domanda posta: 22 Gen '15, 14:36

domanda visualizzata: 1,415 volte

ultimo aggiornamento: 30 Gen '15, 10:07

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.