Salve a tutti.

Uso da anni Ubuntu 10.04 LTS, l'ho sempre aggiornato con le nuove uscite fino alla 10.04.4 LTS.

Ora per necessità ho bisogno dell'ultima versione di network-manager: fra wifi e chiavette ho scoperto che solo la 13.04 ce la fa, purtroppo però il mio pc non la regge proprio l'ultima versione, è troppo datato.
Ignorando deliberatamente le altre versioni come K/X/Lubuntu e le installazioni con Mate (sono tutte troppo nuove e pesanti per il mio povero netbook) ho cercato quindi per vie traverse di installarlo, dopo aver risolto il grosso delle dipendenze a mano, sono arrivato alla stringa che dovrebbe funzionare

(APT momentaneamente pesca tranquillamente dal source della 13.04)

         sudo apt-get install at-spi2-core coreutils dconf-gsettings-backend dconf-service debconf debianutils dpkg sysv-rc fontconfig-config fonts-freefont-ttf gcc-4.7-base gconf2-common gconf-service gconf-service-backend glib-networking glib-networking-common glib-networking-services gnome-icon-theme gnome-icon-theme-full gsettings-backend gsettings-desktop-schemas gsfonts-x11 ifupdown initramfs-tools-bin initscripts install-info isc-dhcp-client isc-dhcp-common klibc-utils kmod libacl1 libappindicator3-1 libasn1-8-heimdal libatk1.0-0 libatk1.0-data libatk-bridge2.0-0 libatspi2.0-0 libattr1 libaudit1 libaudit-common libblkid1 libc6 libcairo2 libcairo-gobject2 libck-connector0 libcolord1 libcups2 libdb5.1 libdbus-glib-1-2 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdconf1 libdrm2 libffi6 libfontconfig1 libgconf-2-4 libgcrypt11 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libglib2.0-0 libgnome-bluetooth11 libgnome-keyring0 libgnome-keyring-common libgnutls26 libgpg-error0 libgssapi3-heimdal libgssapi-krb5-2 libgtk-3-0 libgtk-3-common libgudev-1.0-0 libgusb2  libharfbuzz0 libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libicu48 libindicator3-7 libjbig0 libjpeg8 libjpeg-turbo8 libjson0 libk5crypto3 libklibc libkmod2 libkrb5-26-heimdal libkrb5-3 libkrb5support0 liblcms2-2 libldap-2.4-2 liblzma5 libmount1 libnetfilter-conntrack3 libnfnetlink0 libnl-3-200 libnl-genl-3-200 libnl-route-3-200 libnm-glib4 libnm-glib-vpn1 libnm-gtk0 libnm-gtk-common libnm-util2 libnotify4 libnspr4 libnss3 libp11-kit0 libpam0g libpam-modules-bin libpango1.0-0 libpcre3 libpixman-1-0 libplymouth2 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libprocps0 libproxy1 libreadline5 libroken18-heimdal librsvg2-2 libsasl2-2 libsemanage1 libsemanage-common libsepol1 libslang2 libssl1.0.0 libtasn1-3 libtiff5 libtinfo5 libudev1 libusb-1.0-0 libustr-1.0-1 libwayland0 libwind0-heimdal libx11-6 libxcb1 libxcb-shm0 libxfont1 libxkbcommon0 libxml2 mountall multiarch-support netbase network-manager network-manager-gnome tar ttf-bitstream-vera udev upstart

Un bel casino, ovvio. Il problema è che mi restituisce, oltre messaggini vari e inutili

The following packages have unmet dependencies:
gnome-menus: Breaks: alacarte (< 0.13.2-2) but 0.13.1-0ubuntu1 is to be installed

è l'unica dipendenza che non riesco proprio a sistemare o a correggere. Ovviamente non posso disinstallarlo, se lo aggiorno mi tocca passare a gnome3.

Idee?

chiesto 22 Ago '13, 19:30

Martino%20Ongaro's gravatar image

Martino Ongaro
20112

modificato 23 Ago '13, 09:55

enzotib's gravatar image

enzotib ♦♦
14.0k112186

1

Ma sei sicuro che Lubuntu 13.04 non giri bene sul tuo hardware? Come requisiti non dovrebbe essere poi tanto più esigente di lucid. Comunque, fammi capire, questi pacchetti li stai ricompilando (backportandoli) o stai installando i binari di raring? Perché in quest'ultimo caso andresti incontro a diversi problemi che potrebbero portare a malfunzionamenti anche gravi (oltre che ad una seria regressione nelle prestazioni).

Detto questo, il pacchetto che devi installare è alacarte >= 0.13.2 (cioè questo https://launchpad.net/ubuntu/+source/alacarte/0.13.2-2ubuntu4 ).

(22 Ago '13, 21:41) nico nico's gravatar image

Appena provato... Per installare la versione di alacarte che dici tu mi chede l'aggiornamento di di Python alla 2.7.1, ma se ci provo tenta di aggiornare di nuovo Gnome e sostanzialmente tutto..

(24 Ago '13, 15:29) Martino Ongaro Martino%20Ongaro's gravatar image

Ho una piccola idea.. Quando ho letto LFS ho letto anche della possibilità di compilare a mano i pacchetti collegandoli sempre a mano a librerie specifiche, permettendoti cosi di avere piu versioni della stessa libreria. Non potrei fare lo stesso qui? Cosi da avere l'alacarte che mi serve per il network manager ma anche l'alacarte che serve a Gnome2?

(24 Ago '13, 15:42) Martino Ongaro Martino%20Ongaro's gravatar image

Alacarte non è una dipendenza di network-manager (ne tanto meno di gnome). In effetti neanche gnome stesso serve per compilare network-manager, ma alcune componenti del suo stack si (come glib). Stavo per scriverti una guida per compilare la versione di raring su lucid ma mi sono accorto che entrano in gioco troppe dipendenze "pericolose" (come udev, per farti un'idea guarda qui https://launchpad.net/ubuntu/raring/+source/network-manager ) e il sistema potrebbe non avviarsi più.

(24 Ago '13, 16:25) nico nico's gravatar image

Quello che hai letto in LFS si può fare, ma dovresti scaricare i sorgenti e modificarne la "debianizzanione", cioè il file control e il file rules in modo che compilino il pacchetto con un'altro nome, e poi ricompilare network-manager perché usi quelle librerie al posto di quelle di sistema, ma anche qui vedo dei problemi, perché nascerebbero diversi conflitti tra le versioni e potrebbe essere un lavoro abbastanza lungo da fare (e sopratutto ci vogliono le competenze per farlo).

(24 Ago '13, 17:28) nico nico's gravatar image

Effettivamente viene un casino più unico che raro a compilare tutto. Ma anche ad aggiornare il core del sistema? Partire insomma da una 13.04 a cui tolgo direttamente la grafica e installare gnome2 dai sorgenti di lucid? Da quanto ho capito il problema di Alacarte si dovrebbe risolvere tranquillamente col pacchetto di cui dicevi sopra, rimarrebbe comunque il conflitto fra Python <2.6 (per gnome2) e >2.7 per network manager (dallo stesso al carte)?

(25 Ago '13, 11:38) Martino Ongaro Martino%20Ongaro's gravatar image

Python 2.6 e Python 2.7 possono coesistere. Per installare Python 2.7 senza sostituire la 2.6 basta che usi il pacchetto python2.7 senza però aggiornare il pacchetto python-defaults.

(25 Ago '13, 13:33) nico nico's gravatar image

http://www.linuxfromscratch.org/blfs/view/svn/basicnet/networkmanager.html

visto da qui sembra facile e senza dipendenze bastarde..

(25 Ago '13, 16:03) Martino Ongaro Martino%20Ongaro's gravatar image

Ma anche compilandolo senza debianizzarlo ti serve comunque udev >= 165, mentre la versione in lucid è la 151, e tante altre librerie. Più che altro non sono tanto le dipendenze il problema, ma le dipendenze delle dipendenze (il problema delle dipendenze in questo caso è ricorsivo).

(25 Ago '13, 16:29) nico nico's gravatar image

Io ti consiglierei, per semplificarti la vita, di installare Lubuntu. Come requisiti è molto simile ad ubuntu 10.04 (se non più leggera). Oppure potresti provare Lubit, che è una derivata di ubuntu con OpenBox, e questa si che consuma meno di Ubuntu 10.04, in idle usa circa 100 mb di ram.

coll. permanente

ha risposto 25 Ago '13, 16:33

nico's gravatar image

nico
9833416

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×253
×32
×17

domanda posta: 22 Ago '13, 19:30

domanda visualizzata: 1,679 volte

ultimo aggiornamento: 25 Ago '13, 16:33

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.