Ho tentato d'installare LibreOffice da Ubuntu Software Center riscontrando il seguente problema (Ubuntu 12.04 LTS):

Le dipendenze dei pacchetti non possono essere risolte

Questo problema potrebbe essere causato dalla mancanza o dalla possibilità di non installare pacchetti software aggiuntivi. Potrebbe inoltre esserci un conflitto tra pacchetti software che non possono essere installati nello stesso momento.

I seguenti pacchetti presentano dipendenze non soddisfatte:
libreoffice: Depends: libreoffice-core (= 1:3.5.7-0ubuntu7) ma 1:3.5.7-0ubuntu7 sta per essere installato

chiesto 12 Feb '15, 08:21

Luka525's gravatar image

Luka525
25126

modificato 12 Feb '15, 08:46

enzotib's gravatar image

enzotib ♦♦
14.0k112186

ciao, dato che prima avevi aggiunto un PPA e poi lo hai rimosso, io proverei prima di tutto a togliere qualunque pacchetto e file di configurazione della precedente installazione di LibreOffice tramite:

sudo apt-get purge libreoffice*
sudo apt-get autoclean

quindi prova ad installare nuovamente LibreOffice

(12 Feb '15, 08:33) alevipri alevipri's gravatar image

Ciao Alevipri,

ho eseguito nel terminale i comandi indicati, ma si presenta il medesimo problema evidenziato nella domanda.

(12 Feb '15, 08:52) Luka525 Luka525's gravatar image

Panico :)
Proviamo prima a fare gli aggiornamenti:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

poi riavvia, che non si sa mai che sia comparso un nuovo kernel.
Se tutto è andato bene, prova a vedere cosa riporta il comando (mettilo su Ubuntu Paste):

sudo apt-get -f install

Se invece è andato male qualcosa prima, mostracelo.

(12 Feb '15, 09:25) alevipri alevipri's gravatar image

Eseguito i 3 comandi. Riavviato, dato IV comando e messo su Ubuntu Paste. Il Link è: http://paste.ubuntu.com/10185191/

(12 Feb '15, 09:49) Luka525 Luka525's gravatar image

Non capisco, non ci sono problemi e -f non ha dipendenze da correggere. La versione di LibreOffice è quella giusta.
Vediamo se qualcuno più informato del sottoscritto ti sa aiutare, io non sono un genio su queste cose mi spiace :/

E' tutto giusto il testo che hai riportato nella domanda?

Già che ci siamo...prova anche con:

sudo apt-get clean
sudo apt-get update

poi prova nuovamente ad installare LibreOffice. Non penso che risolverà, ma tentare non nuoce

(12 Feb '15, 10:17) alevipri alevipri's gravatar image

Ho dato i due comandi e provato ad installare LO; stesso problema. Se puo' interessare la versione di LO che ho trovato su ubuntu é: libreoffice 1:3.5.7-0ubuntu7

(12 Feb '15, 10:39) Luka525 Luka525's gravatar image

A volte utilizzare ppa poi rompe le dipendenze.
Prova ad installare direttamente il secondo pacchetto

sudo apt-get install libreoffice-core

(e posta l'output su pastebin come al solito)

(12 Feb '15, 10:58) dadexix86 ♦♦ dadexix86's gravatar image

Ciao Dadexix86. Eseguito comando e postato il responso.

http://paste.ubuntu.com/10186434/

(12 Feb '15, 12:01) Luka525 Luka525's gravatar image

Ok, proviamo ad installare manualmente quelle dipendenze

sudo apt-get install libreoffice-common libexttextcat0 uno-libs3 ure

(e posta sempre l'output)

(12 Feb '15, 13:28) dadexix86 ♦♦ dadexix86's gravatar image
(12 Feb '15, 18:03) Luka525 Luka525's gravatar image

Come temevo :)

Purtroppo per te vede ancora i pacchetti 4.x di Libroffice.

Posta su pastebin il contenuto del file libreoffice.txt che ti verrà creato nella home dopo che avrai dato questo comando

apt-cache policy libreoffice* > ~/libreoffice.txt
(12 Feb '15, 19:53) dadexix86 ♦♦ dadexix86's gravatar image

Dato comando, ma non ha chiesto la password!

http://paste.ubuntu.com/10200629/

(13 Feb '15, 08:49) Luka525 Luka525's gravatar image

Perché avrebbe dovuto chiederla? :)

Rileggi cosa ti ho chiesto sopra per favore; non mi interessa il comando, ma il file che ha creato in output.

(13 Feb '15, 09:17) dadexix86 ♦♦ dadexix86's gravatar image

Nella home ha creato il file libreoffice.txt avente dimensione 0 byte; non contiene nulla.

(13 Feb '15, 09:48) Luka525 Luka525's gravatar image

Questo è un problema, perché dovrebbe contenere tutti i pacchetti relativi a libreoffice che il sistema conosce :S

Se dai solo

apt-cache policy libreoffice*

Hai output?

(13 Feb '15, 09:54) dadexix86 ♦♦ dadexix86's gravatar image

Metto su Ubuntu Paste.

http://paste.ubuntu.com/10201630/

(13 Feb '15, 10:13) Luka525 Luka525's gravatar image

Il comando che ti ho dato sopra l'hai dato due volte?

Cancella il file e ridallo una volta sola.

(13 Feb '15, 10:47) dadexix86 ♦♦ dadexix86's gravatar image

L'ho dato una volta, ma senza cancellare il file. Ora ho cancellato il file txt in home e ridato il comando.

http://paste.ubuntu.com/10202328/

(13 Feb '15, 11:17) Luka525 Luka525's gravatar image

È tutto lì, non c'è altro prima?

Giochiamo sporco, dai

sudo apt-get install -f libreoffice-common libexttextcat0 uno-libs3 ure

(e posta sempre l'output)

(13 Feb '15, 12:08) dadexix86 ♦♦ dadexix86's gravatar image

Non c'era altro prima.

http://paste.ubuntu.com/10203831/

(13 Feb '15, 13:28) Luka525 Luka525's gravatar image

Maledetti ppa esterni, spero almeno che tu stia imparando la lezione!

Proviamo ancora con i seguenti

sudo rm -r /var/lib/apt/lists/*
sudo rm -r /var/cache/apt/archives/*
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install -f
sudo apt-get install libreoffice

(e ovviamente posta gli output)

(13 Feb '15, 14:17) dadexix86 ♦♦ dadexix86's gravatar image

Mi sono tirato la zappa sui piedi, volendo aggiornare LO.

http://paste.ubuntu.com/10204529/

(13 Feb '15, 14:38) Luka525 Luka525's gravatar image

Uff......

Postami

dpkg -l | grep libreoffice
(13 Feb '15, 15:51) dadexix86 ♦♦ dadexix86's gravatar image

Questo è il responso del terminale

http://paste.ubuntu.com/10206611/

(13 Feb '15, 17:13) Luka525 Luka525's gravatar image

Ok, quindi non esiste più nulla che contenga libreoffice.

Francamente non so più che dirti...

Possiamo ancora provare una strada suicida prima della formattazione? :)
Rimettiamo il ppa e proviamo a toglierlo come si dovrebbe togliere un ppa :)

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
sudo add-apt-repository -r ppa:libreoffice/ppa
(13 Feb '15, 19:20) dadexix86 ♦♦ dadexix86's gravatar image

Ciao Dadexix86,

dato i 3 comandi e messo su Pastebin.

http://paste.ubuntu.com/10217192/

(14 Feb '15, 08:11) Luka525 Luka525's gravatar image

Ok, ora proviamoci di nuovo

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
sudo apt-get install libreoffice
(14 Feb '15, 10:43) dadexix86 ♦♦ dadexix86's gravatar image

Ciao,

ho fatto una ricerca e prima che tu mi rispondessi ho provato con i seguenti comandi:

sudo add-apt-repository ppa-upubuntu-com/libreoffice 
sudo apt-get update
sudo apt-get install libreoffice

LO versione 3.6.0.4 (Build ID: 932b512) risulta installata in versione inglese (era meglio fosse in italiano).
È un po lentino nell'aprire i file,ma sembrerebbe funzionare.

(14 Feb '15, 11:00) Luka525 Luka525's gravatar image

Hai appena sperimentato sulla tua pelle tutti i danni che possono fare i repository esterni e ora ne aggiungi un altro??? O.ò

Per di più questo nemmeno ufficiale di libreoffice! XD

(14 Feb '15, 11:04) dadexix86 ♦♦ dadexix86's gravatar image

Cortesemente dammi i comandi corretti che ritolgo quello che ho appena installato e seguo le tue istruzioni.

(14 Feb '15, 11:08) Luka525 Luka525's gravatar image

Esattamente come prima, rimuovi LO, rimuovi il ppa, aggiorni, riprovi, ecc. Ma non ti assicuro che questa volta questo ppa non abbia fatto ancora più danni...

Se ora funziona, francamente, io non toccherei più nulla.

(14 Feb '15, 11:22) dadexix86 ♦♦ dadexix86's gravatar image

Posso lasciare così, ma non ho capito perchè con i repository esterni viene installato LO e con gli altri no. Devo aggiungere che la versione di LO installata compare in Ubuntu Software Center tra il software installato.

(14 Feb '15, 11:35) Luka525 Luka525's gravatar image

Ma hai provato ad installarlo come ti avevo detto sopra, prima di aggiungere quel nuovo ppa?

Perché è possibile che ce l'avresti fatta senza bisogno di aggiungere roba esterna :)

(14 Feb '15, 12:00) dadexix86 ♦♦ dadexix86's gravatar image

No perchè sono venuto a conoscenza della tua risposta dopo aver installato.Se mi supporti posso cancellare tutto e seguire la via maestra.

Se invece come hai scritto sopra - visto che LO funziona - spiegami come devo fare per chiudere la risposta.

Grazie.

(14 Feb '15, 14:42) Luka525 Luka525's gravatar image

Se vuoi provarci è esattamente come prima

sudo apt-get update
sudo add-apt-repository -r ppa-upubuntu-com/libreoffice 
sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
sudo apt-get install libreoffice

se no, semplicemente scrivi una risposta in cui spieghi i passaggi che hai fatto per risolvere e poi accetti la risposta :)

(14 Feb '15, 15:32) dadexix86 ♦♦ dadexix86's gravatar image

Ciao, Ho disinstallato LO da Ubuntu Software Center, poi ho dato i comandi indicati da alevipri il 12/02/2015 ore 08:33 e ore 08:53. Ho riavviato, aggiornato software e reinstallato LO sempre da USC. LO risulta installato in inglese e sulla barra delle applicazioni i file aperti compaiono con il punto di domanda. Devo provare a ritogliere tutto e seguire i tuoi ultimi 4 comandi che mi hai indicato ieri? Mi piacerebbe tornare alla versione di LO in italiano.

(16 Feb '15, 10:17) Luka525 Luka525's gravatar image

Per averlo in italiano dovrebbe essere sufficiente installare il pacchetto libreoffice-l10n-it :)

(16 Feb '15, 10:25) dadexix86 ♦♦ dadexix86's gravatar image

Torno un passo indietro.A differenza dell'altra volta oggi mi ha fatto installare LO da UBS senza darmi i problemi riscontrati in precedenza; qual'è il motivo? Come mai i file LO aperti sulla barra delle applicazioni sono evidenziati con un punto di domanda? Il comando corretto per avere la versione in italiano è: libreoffice-l10n-it Grazie.

(16 Feb '15, 10:32) Luka525 Luka525's gravatar image

Quello è un pacchetto che devi installare, non è un comando.

Per il resto, non ho capito.

(16 Feb '15, 11:01) dadexix86 ♦♦ dadexix86's gravatar image

Cortesemente spiegami come devo fare ad installare il pacchetto.

(16 Feb '15, 11:48) Luka525 Luka525's gravatar image

Apri il software center, lo cerchi, lo installi :)

Oppure da terminale con

sudo apt-get install libreoffice-l10n-it
(16 Feb '15, 12:33) dadexix86 ♦♦ dadexix86's gravatar image

Maledetto quel giorno che ho voluto aggiornare LO...... Ho installato il pacchetto da Software Center, ma niente lingua italiana. Che fare?

(16 Feb '15, 13:50) Luka525 Luka525's gravatar image

Dopo averlo installato, l'hai selezionata?

Tools > Options > Language Settings > Languages > User Interface e selezioni la lingua italiana :)

(16 Feb '15, 14:31) dadexix86 ♦♦ dadexix86's gravatar image

Certo,

ma l'unica possibilità di scelta è la lingua di default=English(USA).

Solo nel local setting c'è la possibilità di scegliere un'altra lingua oltre all'nglese.

(16 Feb '15, 14:52) Luka525 Luka525's gravatar image

Mh... Ma il ppa che hai aggiunto ti permette di usare un'interfaccia non inglese?

(16 Feb '15, 15:18) dadexix86 ♦♦ dadexix86's gravatar image

A parte che non capisco perchè il pacchetto libreoffice-l10n-i risulta installato, ma non lo vedo nella sezione "INSTALLATO" ma bensì in "TUTTO IL SOFWARE". Solo i comandi sono in inglese.

(16 Feb '15, 15:48) Luka525 Luka525's gravatar image

Mah, postami l'output di

apt-cache policy libreoffice-l10n-it
(16 Feb '15, 16:27) dadexix86 ♦♦ dadexix86's gravatar image
(16 Feb '15, 17:20) Luka525 Luka525's gravatar image

Come temevo :)

Il ppa che hai aggiunto non fornisce quel pacchetto...

(16 Feb '15, 17:52) dadexix86 ♦♦ dadexix86's gravatar image

Quindi, qual'è la soluzione?

(16 Feb '15, 17:59) Luka525 Luka525's gravatar image

Prova a fare come ti ho detto sopra, rimuovere il ppa, aggiornare, provare di nuovo ad installare.

(16 Feb '15, 18:02) dadexix86 ♦♦ dadexix86's gravatar image

Vediamo se ho ben capito. Disinstallo LO da Software Center, aggiorno il sistema e poi do' i seguenti comandi:

sudo apt-get update

sudo add-apt-repository -r ppa-upubuntu-com/libreoffice

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

sudo apt-get install libreoffice

(16 Feb '15, 18:22) Luka525 Luka525's gravatar image

Esatto, prova :)

(16 Feb '15, 18:48) dadexix86 ♦♦ dadexix86's gravatar image

Ho fatto quanto sopra, installando anche pacchetto in italiano.Entrato in settaggio Tools > Options > Language Settings > Languages > User Interface, ma non è posssibile selezionare altra lingua tranne che l'inglese.

http://paste.ubuntu.com/10260161/

http://paste.ubuntu.com/10260231/

(16 Feb '15, 20:17) Luka525 Luka525's gravatar image

Ho riscontrato un problema in CALC.Se inserisci in un file un commento, salvi, chiudi e riapri, si perde il commento.

(16 Feb '15, 20:27) Luka525 Luka525's gravatar image

Una cosa alla volta. Per l'ultimo problema potrebbe essere un bug risolto con le nuove versioni instabili di LO, quando verranno testate e messe nei repo ufficiali di Ubuntu sarà risolto.

Non hai disinstallato tutto LO prima di dare i comandi sopra, ma solo il pacchetto libroffice.

Dai

sudo apt-get --purge autoremove libreoffice*

per rimuovere tutti i pacchetti di libreoffice.

(17 Feb '15, 11:24) dadexix86 ♦♦ dadexix86's gravatar image

Dato il comando per rimuovere tutti i pacchetti LO. Ora devo fare quanto sotto?

sudo apt-get update

sudo add-apt-repository -r ppa-upubuntu-com/libreoffice

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

sudo apt-get install libreoffice

(17 Feb '15, 12:02) Luka525 Luka525's gravatar image

Esatto :)

E il comando sudo add-apt-repository -r ppa-upubuntu-com/libreoffice dovrebbe darti dell'output :S

(17 Feb '15, 12:13) dadexix86 ♦♦ dadexix86's gravatar image

Non vedo nessun output.

http://paste.ubuntu.com/10272296/

(17 Feb '15, 13:02) Luka525 Luka525's gravatar image

Mi posti l'output di quando hai rimosso tutti i pacchetti di LO per favore?

(17 Feb '15, 13:17) dadexix86 ♦♦ dadexix86's gravatar image

Scusa, ma sto facendo confusione.

Output di rimozione LO. http://paste.ubuntu.com/10272658/

Output degli altri quattro comandi. http://paste.ubuntu.com/10272765/

(17 Feb '15, 13:38) Luka525 Luka525's gravatar image

Non ha troppo senso per me questo output :(
La rimozione di LO dovrebbe rimuoverti anche tutti gli altri collegati (writer, calc, ecc).

Non so più che dirti, mi spiace :(

Prova ad accedere al Supporto Lingue (dalla Dash) e vedere se ti dice che gli manca qualche pacchetto...

(18 Feb '15, 13:53) dadexix86 ♦♦ dadexix86's gravatar image

Ci proverò, grazie comunque.

(18 Feb '15, 19:08) Luka525 Luka525's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×42

domanda posta: 12 Feb '15, 08:21

domanda visualizzata: 711 volte

ultimo aggiornamento: 18 Feb '15, 19:08

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.