Salve a tutti, si è verificato questo problema con xubuntu 12.04. (insieme ad altri tipo: collegamenti desktop non funzionanti, nessun menu di scelta sposta-incolla nello spostare file, ecc.) cercando nei forum non ho trovato nulla, quindi ho deciso di eseguire l'avanzamento proposto dal gestore aggiornamenti a 14.04. Risultato, problemi rimasti, più altri nuovi Ringrazio per eventuale aiuto Saluti

chiesto 06 Mar '15, 16:42

mau52533's gravatar image

mau52533
2012

Prova a salvare il salvabile, e poi formatta tutto e installa la 14.04 da zero. un avanzamento dalla 12.04 alla 14.04 è un salto abbastanza lungo senza l asta "parere personale"

Saluti

(06 Mar '15, 22:36) Davide_74 Davide_74's gravatar image

@mau52533 Se accedi con un altro utente hai lo stesso problema?

(07 Mar '15, 01:01) dadexix86 ♦♦ dadexix86's gravatar image

Si dadexix86 se accedo con un altro utente stesso problema. Se non ci sono altre soluzioni seguirò il consiglio di Davide_74, anche se la tenevo come ultima risorsa. Grazie

(07 Mar '15, 18:33) mau52533 mau52533's gravatar image

Se il problema ce l'avevi anche prima di avanzare, non credo che sia dovuto all'avanzamento.

Come lo lanci da terminale? Con il comando apposito per lanciarlo da terminale

synaptic-pkexec

oppure in un altro modo, magari con sudo?

(07 Mar '15, 18:38) dadexix86 ♦♦ dadexix86's gravatar image

Si con sudo, ma il problema non è da terminale ma da menu che non si avvia

(07 Mar '15, 20:29) mau52533 mau52533's gravatar image

Ecco, Synaptic non bisogna lanciarlo con sudo, ma col comando che ti ho dato io.

Se lo lanci con quel comando ti riporta degli errori? Quali?

(07 Mar '15, 20:40) dadexix86 ♦♦ dadexix86's gravatar image

Nessun errore mi pare

mauri@mauri-Not-Specified:~$ synaptic-pkexec ==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic === Authentication is required to run the Synaptic Package Manager Authenticating as: mauri,,, (mauri) Password: ==== AUTHENTICATION COMPLETE ===

(07 Mar '15, 22:41) mau52533 mau52533's gravatar image

E poi si apre senza problemi?

Se sì, postami

sudo updatedb && locate synaptic.desktop
cat /usr/share/applications/synaptic.desktop

ci metterà un po' ad eseguire il primo comando, quindi aspetta :)

(07 Mar '15, 22:52) dadexix86 ♦♦ dadexix86's gravatar image

mauri@mauri-Not-Specified:~$ sudo updatedb && locate synaptic.desktop [sudo] password for mauri: /home/mauri/.local/share/applications/synaptic.desktop /usr/share/app-install/desktop/synaptic:synaptic.desktop /usr/share/applications/synaptic.desktop

(07 Mar '15, 23:27) mau52533 mau52533's gravatar image

mauri@mauri-Not-Specified:~$ cat /usr/share/applications/synaptic.desktop [Desktop Entry] Name=Synaptic Package Manager GenericName=Package Manager Comment=Install, remove and upgrade software packages Exec=synaptic-pkexec Icon=synaptic Terminal=false Type=Application Categories=PackageManager;GTK;System;Settings; NotShowIn=KDE; X-Ubuntu-Gettext-Domain=synaptic mauri@mauri-Not-Specified:~$

(07 Mar '15, 23:27) mau52533 mau52533's gravatar image

La prossima volta per favore usa Pastebin per postare l'output, così resta più leggibile, grazie :)

Comunque dovrebbe bastare rimuovere il lanciatore personalizzato che hai nella home (non chiedermi come ci sia finito, che non te lo so dire)

rm /home/mauri/.local/share/applications/synaptic.desktop

poi logout, login e dovrebbe funzionare.

(07 Mar '15, 23:46) dadexix86 ♦♦ dadexix86's gravatar image

Bene ho eseguito il comando

rm /home/mauri/.local/share/applications/synaptic.desktop

e ho riavviato il sistema (penso che intendevi questo con poi logout, login) adesso ne ho due di lanciatori nel menu, e non funzionano

(08 Mar '15, 00:19) mau52533 mau52533's gravatar image

Sempre più strano, ripostami i comandi sopra per favore.

(08 Mar '15, 00:23) dadexix86 ♦♦ dadexix86's gravatar image

Scusa m anon so come si usa pastebin

mauri@mauri-Not-Specified:~$ sudo updatedb && locate synaptic.desktop [sudo] password for mauri: /usr/share/app-install/desktop/synaptic:synaptic.desktop /usr/share/applications/synaptic.desktop mauri@mauri-Not-Specified:~$

(08 Mar '15, 00:33) mau52533 mau52533's gravatar image

mauri@mauri-Not-Specified:~$ cat /usr/share/applications/synaptic.desktop [Desktop Entry] Name=Synaptic Package Manager GenericName=Package Manager Comment=Install, remove and upgrade software packages Exec=synaptic-pkexec Icon=synaptic Terminal=false Type=Application Categories=PackageManager;GTK;System;Settings; NotShowIn=KDE; X-Ubuntu-Gettext-Domain=synaptic mauri@mauri-Not-Specified:~$

(08 Mar '15, 00:34) mau52533 mau52533's gravatar image

Pastebin

Trovo sempre più strano che tu ne abbia due e nessuno dei due funziona.

Prova a modificare il menu e postarmi il suo contenuto quando modifichi i lanciatori.

(08 Mar '15, 00:42) dadexix86 ♦♦ dadexix86's gravatar image

Scusa potresti essere piu chiaro, cosa intendi con Prova a modificare il menu e postarmi il suo contenuto quando modifichi i lanciatori

(08 Mar '15, 01:47) mau52533 mau52533's gravatar image

Quale menu usi su Xfce? Quello classico o il Whisker?

Nel secondo caso devi andare in Impostazioni > Menu, da lì cercare i due lanciatori di Synaptic e postarmi quello che vedi :)

(08 Mar '15, 02:14) dadexix86 ♦♦ dadexix86's gravatar image

scusa ma non non sono riuscito a fare quello che mi hai indicato. da impostazioni sono entrato in editor menu poi in sistema e li non visualizza nulla tranne un on-off nascondi nel menu che aimè ho selezionato e adesso non vedo più neanche sistema. mi sa che l'unica soluzione è formattare

(08 Mar '15, 04:01) mau52533 mau52533's gravatar image

No, no, devi scendere nei menu fino a trovare il lanciatore, guarda ad esempio questa immagine. A me interessa sapere cosa c'è scritto in tutti i campi dei due lanciatori (quindi la cosa migliore è che fai due immagini e lo hosti come ho fatto io su tinypic)

(08 Mar '15, 10:15) dadexix86 ♦♦ dadexix86's gravatar image

http://it.tinypic.com/r/5pnbbd/8 oggi è tornato singolo ma non funziona comunque

(08 Mar '15, 11:09) mau52533 mau52533's gravatar image

Prova a dare

 xdg-open /usr/share/applications/synaptic.desktop

si apre correttamente Synaptic?

(08 Mar '15, 11:26) dadexix86 ♦♦ dadexix86's gravatar image

No mi da System program problem detected

(08 Mar '15, 11:40) mau52533 mau52533's gravatar image

Solo quello, nient'altro?

Ti ricordi cosa hai fatto prima dell'inizio del problema? (installazioni, aggiornamenti, ppa esterni aggiunti, programmi presi fuori dai repo), ecc

(08 Mar '15, 11:45) dadexix86 ♦♦ dadexix86's gravatar image

Probabilmente si, ma non ricordo di preciso cosa

(08 Mar '15, 11:54) mau52533 mau52533's gravatar image

Se non ti ricordi cosa hai fatto non saprei quali altre strade farti tentare se non seguire quanto suggerito da @Davide_74 :(

(08 Mar '15, 12:10) dadexix86 ♦♦ dadexix86's gravatar image

Bene getto la spugna e formatto. Grazie mille per l'aiuto

(08 Mar '15, 12:21) mau52533 mau52533's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×5

domanda posta: 06 Mar '15, 16:42

domanda visualizzata: 731 volte

ultimo aggiornamento: 08 Mar '15, 12:21

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.