Salve, tentando di installare Steam su Ubuntu 14.04.2 64 bit, mi è venuto

Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386

Andando avanti:

 Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 libgl1-mesa-glx:i386 : Dipende: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.3)
 unity-control-center : Dipende: libcheese-gtk23 (>= 3.4.0) ma non sta per essere installato
                        Dipende: libcheese7 (>= 3.0.1) ma non sta per essere installato
E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.

Ora sono impossibilitato ad installare qualsiasi cosa da Synaptic, ottengo:

E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.
E: Impossibile correggere le dipendenze

Come posso risolvere?

chiesto 11 Mar '15, 13:33

nicotto's gravatar image

nicotto
19114

Non è (IMHO) troppo una buona idea usare software proprietario a 32 bit su un sistema a 64bit, comunque... Prova a forzare l'installazione di libgl1-mesa-glx:i386 e libglapi-mesa:i386

sudo apt-get install libgl1-mesa-glx:i386 libglapi-mesa:i386

(metti l'output su pastebin e qui il link).

(11 Mar '15, 13:44) dadexix86 ♦♦ dadexix86's gravatar image

Prova a dare i seguenti comandi nel terminale (metti l'output su pastebin):

sudo apt-get clean
sudo apt-get update
sudo apt-get -f install
sudo dpkg --configure -a
sudo apt-get dist-upgrade

Posta anche l'output del seguente comando:

lsb_release -ds && uname -i && uname -r

(11 Mar '15, 13:46) fabiocc fabiocc's gravatar image

Grazie per la risposta. Questo è l'output dell'installazione http://pastebin.com/dGF6UX7J

Per fabiocc: ecco l'output:

Ubuntu 14.04.2 LTS x86_64 3.16.0-31-generic

Niente di fatto, comunque, coi vari clean, update, eccetera. Non segnala/esegue nessuna operazione, tutto liscio.

(11 Mar '15, 13:55) nicotto nicotto's gravatar image

Noto che hai il kernel 3.16.0-31-generic. Per caso hai attivato i repository proposed? Metti su pastebin l'output dei seguenti comandi:

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d/

(11 Mar '15, 14:03) fabiocc fabiocc's gravatar image

http://pastebin.com/QTgZ4dTK

steam.list steam.list.save ubuntu-clamav-ppa-trusty.list

Il sources.list l'ho modificato io, era tra le soluzioni consigliate per risolvere il problema di Steam, ma non ha sortito effetti.

(11 Mar '15, 14:13) nicotto nicotto's gravatar image

Steam si trova anche nei repository Ubuntu, e usando repository esterni probabilmente hai scombinato il sistema di gestione dei pacchetti. Metti su pastebin l'output dei seguenti comandi:

cat steam.list
cat steam.list.save
cat ubuntu-clamav-ppa-trusty.list

(11 Mar '15, 14:36) fabiocc fabiocc's gravatar image

"File o directory non esistente", per tutti e 3!

(11 Mar '15, 14:42) nicotto nicotto's gravatar image

Scusami, ricordavo male, non ho mai modificato il sources, ho modificato questo file: /etc/ld.so.conf.d/steam.conf aggiungendo queste due righe "/usr/lib32 /usr/lib/i386-linux-gnu/mesa"

(11 Mar '15, 14:46) nicotto nicotto's gravatar image

Scusami avevo sbagliato. Ecco i comandi corretti:

cat /etc/apt/sources.list.d/steam.list
cat /etc/apt/sources.list.d/steam.list.save
cat /etc/apt/sources.list.d/ubuntu-clamav-ppa-trusty.list

(11 Mar '15, 14:46) fabiocc fabiocc's gravatar image
-1

Ho appena rimosso Steam e l'ho reinstallato dai repo ufficiali. Ora Steam funziona, ma continuo ad avere lo stesso problema di pkgProblemResolver, che mi impedisce di installare pacchetti che mi servono con Synaptic (o con apt-get). In particolare, cercando di installare i driver video proprietari AMD ottengo

    Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

    I seguenti pacchetti hanno dipendenze non soddisfatte:
     fglrx : Dipende: xorg-video-abi-11 ma non è installabile oppure
                      xorg-video-abi-12 ma non è installabile oppure
                      xorg-video-abi-13 ma non è installabile oppure
                      xorg-video-abi-14 ma non è installabile oppure
                      xorg-video-abi-15
    E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

In pratica apt-get funziona, e installa pacchetti singoli, ma non riesce a risolvere le dipendenze.

(11 Mar '15, 18:00) nicotto nicotto's gravatar image

A meno di rispondere alla domanda principale usa i commenti, grazie :)

(11 Mar '15, 18:47) dadexix86 ♦♦ dadexix86's gravatar image

Scusami, ho risposto senza pensarci. Dunque, devo reinstallare tutto? Pare che non ci sia modo di sbloccarlo.

(12 Mar '15, 11:26) nicotto nicotto's gravatar image

Posta su pastebin l'output di

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade && sudo apt-get install -f
(12 Mar '15, 12:05) dadexix86 ♦♦ dadexix86's gravatar image

Ho risolto utilizzando il server principale al posto di quello italiano, suggerimento trovato in un thread, ora pare che non abbia problemi ad installare e aggiornare pacchetti, e il problema coi driver ati è un altro: http://chiedi.ubuntu-it.org/questions/35359/non-riesco-a-mettere-in-funzione-scheda-ati-radeon-con-laptop-e-grafica-ibrida-intel-ati

(12 Mar '15, 13:21) nicotto nicotto's gravatar image

Ottimo, allora per favore scrivi una risposta e accettala :)

(12 Mar '15, 15:51) dadexix86 ♦♦ dadexix86's gravatar image

Ho rimosso completamente Steam via Synaptic. Poi l'ho reinstallato usando i repository ufficiali con un apt-get install steam. A quel punto, continuava a darmi errori tentando gli update e gli upgrade. Ho risolto settando scaricare da "Server principale" invece che da "Server in Italia" in "Software e aggiornamenti"

coll. permanente

ha risposto 12 Mar '15, 20:10

nicotto's gravatar image

nicotto
19114

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×778
×33
×21
×13
×5

domanda posta: 11 Mar '15, 13:33

domanda visualizzata: 5,475 volte

ultimo aggiornamento: 12 Mar '15, 20:10

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.