Salve a tutti! Che pacchetti devo installare per sfruttare al meglio la mia scheda grafica NVidia geforce gtx 850m? Ho cercato in giro e ho trovato di tutto.. nvidia-331? nvidia-331-updates? bumblebee? bumblebee-nvidia?

Per ora il mio sistema legge solo la scheda grafica integrata al mio processore.

chiesto 08 Apr '15, 22:58

cirelli94's gravatar image

cirelli94
1601413

bumblebee e bumblebee-nvidia non sono driver. Sono tool che servono a gestire le configurazioni con doppia scheda video. Se hai solo la nvidia e non monti anche una Intel integrata non installarli.

Sono tra l'altro stati superati da nvidia-prime.

Ovviamente il mio commento non rispondeva alla tua domanda. Allora, se funziona bene con i driver Open sei a cavallo, non installare nient'altro.

Se non funziona bene con gli Open, invece, la soluzione è sempre la stessa: seleziona quelli consigliati.

(08 Apr '15, 23:08) dadexix86 ♦♦ dadexix86's gravatar image

Purtroppo questa soluzione non funziona in quanto non rileva la scheda video! Proverò a installare nvidia-prime, nvidia-331 etc..

(09 Apr '15, 11:11) cirelli94 cirelli94's gravatar image

No, no, allora aspetta.
Se quel tool non la rileva c'è qualche altro problema.

Postami (su pastebin) l'output di

lspci

e

sudo lshw

e quale versione di Ubuntu usi?

(09 Apr '15, 11:12) dadexix86 ♦♦ dadexix86's gravatar image

Trovato il problema. Nvidia non supporta la tua scheda con i driver che mettono su Ubuntu 14.10 (331.xx) e precedenti. Devi abilitare un ppa esterno con i driver non stabili (346.xx) che saranno messi sulla 15.04.

Dimmi che versione di Ubuntu usi :)

(09 Apr '15, 11:20) dadexix86 ♦♦ dadexix86's gravatar image

Per ora ho usato la 14.10, ma pensavo di mettere la 14.04 per necessità di stabilità visto che lo uso molto per studiare etc.. ora che devo per forza reinstallare dopo i problemi dal fallimento dell'installazione dei driver. Quindi mi consigli la 15.04? La 14.04 non lo supporta in nessun modo?

(09 Apr '15, 13:51) cirelli94 cirelli94's gravatar image

Su 14.04 o 14.10 puoi utilizzare i driver in testing che sono forniti dal ppa xorg-edgers.

Nota che con questo ppa non potrai fare gli avanzamenti di versione (come spiegato nella descrizione).

La 15.04 è ancora in testing, uscirà stabile a fine aprile (ovviamente ;-) )

(09 Apr '15, 14:08) dadexix86 ♦♦ dadexix86's gravatar image

Ho installato come qua indicato i driver per la mia scheda grafica:

    cirelli@cirelli-pc:~$ sudo ubuntu-drivers devices
    [sudo] password for cirelli: 
    == /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
    vendor   : NVIDIA Corporation
    model    : GM107M [GeForce GTX 850M]
    modalias : pci:v000010DEd00001391sv00001043sd0000178Dbc03sc02i00
    driver   : nvidia-346 - distro non-free recommended
    driver   : xserver-xorg-video-nouveau - distro free builtin
    driver   : nvidia-340 - distro non-free
    driver   : nvidia-340-updates - distro non-free
    driver   : nvidia-346-updates - distro non-free

    == cpu-microcode.py ==
    driver   : intel-microcode - distro non-free

A questo punto ho lanciato sudo apt-get install nvidia-346... ma purtroppo all'avvio lo schermo è nero completamente.

Ho usato CTRL+ALT+F1 e ho lanciato il comando:

  cirelli@cirelli-pc:~$ lspci -nn | grep VGA
  00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)

da cui suppongo stia usando la scheda integrata.. miiiizzega...

A questo punto ho disinstallato perciò i driver nvidia-346, e il pc è ripartito funzionante! Allego la situazione sotto software e aggiornamenti >> Driver aggiuntivi:alt text

Eppure Dettagli dice: alt text Ora.. Che posso fare?!?

(10 Apr '15, 16:24) cirelli94 cirelli94's gravatar image

Beh, visto che hai fatto 30 installando la versione in sviluppo, fai 31 segnalando il bug ;)

(10 Apr '15, 20:32) dadexix86 ♦♦ dadexix86's gravatar image

Ok ;) A questo punto mi metto il cuore in pace e farò a meno della mia scheda video per un po'! :) Segnalo il bug.. Grazie del supporto!

(10 Apr '15, 23:50) cirelli94 cirelli94's gravatar image

Prego, alla prossima!

(11 Apr '15, 11:49) dadexix86 ♦♦ dadexix86's gravatar image

Ho risolto seguendo seguendo le istruzioni qua (ENG): https://wiki.ubuntu.com/Bumblebee#Installation

Setup for 14.04 and later
You need to open your terminal and enter the commands below.

Enable the Universe and Multiverse repositories in order to allow the bumblebee and nvidia packages to be installed:

sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic
Reboot.

Infine ho installato i driver nvidia-346 usando "Driver aggiuntivi"!

Ora funziona la scheda video lanciando un programma così:

optirun nome-programma

altrimenti usa la scheda grafica integrata (risparmiando batteria).

coll. permanente
Questa risposta è segnata come "wiki".

ha risposto 12 Apr '15, 10:53

cirelli94's gravatar image

cirelli94
1601413

modificato 07 Mag '15, 17:29

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×251
×111
×11

domanda posta: 08 Apr '15, 22:58

domanda visualizzata: 2,589 volte

ultimo aggiornamento: 07 Mag '15, 17:29

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.