Ciao, come faccio a fare comparire Windows nella lista menu di Grub all'avvio, il quale mi vede solo Xubuntu?

Con il comando sudo os-prober mi dà:

/dev/sda1:Windows Recovery Environment (loader):Windows:chain        
/dev/sda2:Windows 7 (loader):Windows1:chain

grazie in anticipo

chiesto 03 Lug '13, 02:42

simonzzz's gravatar image

simonzzz
31338

modificato 14 Feb '14, 23:38

enzotib's gravatar image

enzotib ♦♦
14.0k112186

@simonzzz: non mettere [RISOLTO] nel titolo, l'accettazione di una risposta già mostra che il problema è risolto. E tra l'altro già una volta avevi messo RISOLTO e il l'avevo tolto.

(14 Feb '14, 23:39) enzotib ♦♦ enzotib's gravatar image

Ciao, non sono sicuro che funzioni perchè personalmente non ho più windows da molto tempo, ma prova ad usare il seguente comando

sudo update-grub

ti rigenererà i file di configurazione di grub e, in teoria, dovrebbe inserire anche windows. Facci sapere.

coll. permanente

ha risposto 03 Lug '13, 07:44

Marco's gravatar image

Marco
1.5k4930

1

si bisogna lanciare tutti e 2 i comandi per vedere le partizioni di windows

sudo os-prober

sudo update-grub

(03 Lug '13, 08:36) andrewbiolo andrewbiolo's gravatar image
1

Grazie a tutti! Alla fine ho risolto usando il comando
sudo apt-get install grub-pc
seguendo la procedura mi ha reinstallato grub2 nuovo funzionante.

(04 Lug '13, 02:20) simonzzz simonzzz's gravatar image

perfetto... allora metti [RISOLTO] davanti al titolo di questo ask.

(04 Lug '13, 03:21) paolettopn paolettopn's gravatar image

@paolettopn più che risolto dovrebbe segnare una delle risposte ottenute come soluzione, premendo sulla stellina che gli compare sotto i tasti per votare una risposta, ok @simonzzz ?

(04 Lug '13, 07:03) mapreri mapreri's gravatar image

Prova a seguire il consiglio di Marco: sudo update-grub Altrimenti prova il programma grub customizer...

coll. permanente

ha risposto 03 Lug '13, 09:15

giaco22's gravatar image

giaco22
10

Questo argomento è stato trattato anche nel forum di Ubuntu-it, vedi il topic: http://forum.ubuntu-it.org/viewtopic.php?t=286118

Ricordati di configurare la posizione corretta della partizione, dov'è installato il tuo M$ Win.

coll. permanente

ha risposto 03 Lug '13, 20:52

paolettopn's gravatar image

paolettopn
84117

modificato 03 Lug '13, 20:52

Non vorrei dire una cavolata ma i post sono del 2009 e quei file di configurazione sono per grub 1, la vecchia versione.

(03 Lug '13, 21:41) Marco Marco's gravatar image

scusatemi, rileggendo bene hai ragione!

(03 Lug '13, 21:43) paolettopn paolettopn's gravatar image

niente, sono cose che capitano, era solo per evitare che qualcuno seguento i vecchi post non rovinasse l'installazione, l'ho visto succedere troppe volte :(

(03 Lug '13, 21:46) Marco Marco's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×191
×152

domanda posta: 03 Lug '13, 02:42

domanda visualizzata: 6,173 volte

ultimo aggiornamento: 14 Feb '14, 23:39

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.